Bug 94666 - Narrow spacing of menu items, and truncated tooltips with lower resolution
Summary: Narrow spacing of menu items, and truncated tooltips with lower resolution
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All Linux (All)
: low trivial
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: bibisectRequest, regression
: 101416 103422 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-10-01 12:20 UTC by martinof
Modified: 2017-11-15 09:15 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Narrow menu display (LibreOffice 5.0.2) (60.04 KB, image/png)
2015-10-01 12:20 UTC, martinof
Details
Regular menu display (LibreOffice 4.4) (60.52 KB, image/png)
2015-10-01 12:24 UTC, martinof
Details
The bug reproduced in Virtualbox (640x480) (149.63 KB, image/png)
2016-08-10 20:50 UTC, John Felton
Details
The comparison of default toolbar icons in desktop (1280x1024) and Virtualbox (640x480) (371.50 KB, image/png)
2016-08-10 20:52 UTC, John Felton
Details
Fixed menu after changing icon style (79.34 KB, image/png)
2016-08-10 21:12 UTC, John Felton
Details
Flattened menu after restarting LibreOffice (84.68 KB, image/png)
2016-08-10 21:14 UTC, John Felton
Details
The menu and tooltips on notebook (1024x600) (133.00 KB, image/png)
2016-08-13 17:09 UTC, John Felton
Details
Main menu and tooltips on LibreOffice with GTK3 in Ubuntu 16.10 official repository (109.61 KB, image/png)
2016-11-04 18:49 UTC, John Felton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description martinof 2015-10-01 12:20:28 UTC
Created attachment 119165 [details]
Narrow menu display (LibreOffice 5.0.2)

Since LibreOffice 5.0.0, I have a problem with the way menus are displayed on my netbook, which is a Asus EeePC 1015 (OS Lubuntu 15.04, resolution 1024x600). The screenshot seems self explanatory to me, I took it with Writer but it's the same with Calc and Impress. 

This bug can be reproduced with LibreOffice 5.0.0, 5.0.1 and 5.0.2. I installed LibreOffice with the packages from https://fr.libreoffice.org, I didn't use the packages from the Linux distribution. Menus are displayed properly with LibreOffice 4.x
Comment 1 martinof 2015-10-01 12:24:01 UTC
Created attachment 119166 [details]
Regular menu display (LibreOffice 4.4)
Comment 2 tommy27 2015-10-01 18:16:49 UTC
version should indicate the earliest affected release, in this case 5.0.0
and regression has to be added to keywords since you say the bug wasn't present in 4.x

let's wait another Linux user to confirm it
I'm on Windows and I don't see that bug
Comment 3 martinof 2015-11-04 07:40:33 UTC
This regression is still present in 5.0.3 and can also be seen in 5.1.0.0.alpha1. 

This means that Linux netbooks will be stuck with the 4.6 branch and I think that will be a problem. Anyone can confirm this bug or provide a workaround ?

Thanks
Comment 4 tommy27 2015-12-19 18:14:39 UTC
can you retest with latest 5.0.4.2 release?
Comment 5 martinof 2015-12-20 11:30:05 UTC
Sorry, bug still present in 5.0.4. Also in 5.1.0 RC1
Comment 6 martinof 2016-02-11 19:59:31 UTC
No changes for this bug in 5.0.5 and 5.1.0.

Now that LibreOffice 4.4 is no longer supported, that means I should upgrade to 5.0 or 5.1 and have this annoying display bug. Any chance someone will look into it ?

Thanks
Comment 7 Maxim Monastirsky 2016-02-11 21:15:24 UTC
Please don't set your own bugs as NEW.

(In reply to martinof from comment #6)
> Any chance someone will look into it ?
No one can look into something that he can't reproduce. I also tried with Lubuntu, but couldn't reproduce despite all my attempts. Maybe it's some combination of theme/fonts? Can you state the exact theme/fonts that in use on your system?

Also you could try to bisect [1]. This could give us some hints on what is causing this problem.

(And BTW - no idea if this is related, but the minimum supported resolution according to [2] is 1024x768, so you're out of luck here.)

[1] https://wiki.documentfoundation.org/QA/Bibisect
[2] http://www.libreoffice.org/get-help/system-requirements
Comment 8 martinof 2016-02-13 10:38:05 UTC
Maybe I missed some messages, but I didn't see comments telling me that someone tried and failed to duplicate this bug. So, thanks for your help :)

I tried some things on my computer. I purged all libreoffice packages and deleted my profile ($HOME/.config/libreoffice) to get a fresh start. I installed LO 5.1.0 from the website, not from Ubuntu's repository. I got the same bug. 

Then, I went to Options / Display and changed Zoom from 100% to 110% (my interface is in french, I hope I give the correct names). The menu displayed properly. I turned the option back to 100% and it was still ok.

The funny thing is : if I close LO and open it again, the bug reappears. I need to get to Options and do the same procedure again.

I use Lubuntu default settings (theme/font), no specific custom change from me.
Comment 9 Aron Budea 2016-08-03 04:59:20 UTC
I can confirm this with LibreOffice 5.2.0.3/Ubuntu 15.10, with resolution set to 800x600 (but not with 1024x768). I can also confirm this with an MSI Wind having native resolution 1024x600, same as the reporter's.

While it's true that the resolution is less than 1024x768, I'd consider this a valid issue for these reasons:
-In 1024x600 resolution the width is the same as 1024x768, so there should be no reason for the horizontal spacing to change.
-Even in 800x600 resolution, about 1/3rd of the menu bar is left empty.
-Setting scaling to 110%, then back to 100% fixes the issue until LibreOffice is closed.
Comment 10 Aron Budea 2016-08-10 09:35:03 UTC
*** Bug 101416 has been marked as a duplicate of this bug. ***
Comment 11 Aron Budea 2016-08-10 09:39:38 UTC
In bug 101416 this was reported with 1366x768 resolution, so it seems to be affecting higher resolutions as well, under certain circumstances.

Note that the labels are also truncated:
https://bug-attachments.documentfoundation.org/attachment.cgi?id=126705
Comment 12 John Felton 2016-08-10 20:04:29 UTC
By the way, look at this
https://bug-attachments.documentfoundation.org/attachment.cgi?id=126705
I saw that not only meny and tooltips changed on notebook, but even the icons on toolbars. This is really strange.
Comment 13 Aron Budea 2016-08-10 20:21:12 UTC
(In reply to John Felton from comment #12)

Those are different themes (Tango and Galaxy), you can verify/change via Tools -> Options... -> LibreOffice -> View.
Comment 14 John Felton 2016-08-10 20:50:10 UTC
Created attachment 126732 [details]
The bug reproduced in Virtualbox (640x480)
Comment 15 John Felton 2016-08-10 20:52:02 UTC
Created attachment 126733 [details]
The comparison of default toolbar icons in desktop (1280x1024) and Virtualbox (640x480)
Comment 16 John Felton 2016-08-10 20:56:09 UTC
Thanks Aron.
By the way, this bug can be reproduced in Virtualbox with 640x480 settings (https://bugs.documentfoundation.org/attachment.cgi?id=126732).
And I saw that LibreOffice chooses the default icon style dependently from screen resolution (https://bugs.documentfoundation.org/attachment.cgi?id=126733). Is this a bug or not?
Comment 17 John Felton 2016-08-10 21:12:57 UTC
Created attachment 126734 [details]
Fixed menu after changing icon style
Comment 18 John Felton 2016-08-10 21:14:10 UTC
Created attachment 126735 [details]
Flattened menu after restarting LibreOffice
Comment 19 John Felton 2016-08-10 21:19:53 UTC
I've found something. The menu fixes after changing icon style (it's not important, to Elementary or to Galaxy). It looks so (https://bugs.documentfoundation.org/attachment.cgi?id=126734).
But after restarting LibreOffice the menu flattenes again :-( (https://bugs.documentfoundation.org/attachment.cgi?id=126735).
It doesn't affects the tooltips, they're cut in both situations.
Comment 20 Aron Budea 2016-08-11 00:57:33 UTC
Thanks for the extensive checks, it's interesting to see that changing icon style also temporarily fixes the placement (in Comment 8 it was noted that changing scaling does this).

I didn't know automatic themes depended on resolution, it seems intended, but I don't know anything about it.

Note that resolutions below 1024x768 would not be supported normally, and while I made arguments in Comment 9 why this should definitely count as an issue to be fixed, it was good to see that the bug also occurred with 1366x768 resolution in your case.
Comment 21 John Felton 2016-08-13 17:09:52 UTC
Created attachment 126818 [details]
The menu and tooltips on notebook (1024x600)
Comment 22 John Felton 2016-08-13 17:13:47 UTC
Thanks for the explanations, Aron.
My friend with 1024x600 notebook has the same problems (https://bugs.documentfoundation.org/attachment.cgi?id=126818).
They are really serious, but all we can do is to hope that developers have their attention of them, and it saddens.
Comment 23 Maxim Monastirsky 2016-10-23 07:51:53 UTC
*** Bug 103422 has been marked as a duplicate of this bug. ***
Comment 24 Joel Madero 2016-10-24 03:21:03 UTC
If anyone who is seeing this problem wants to see it move forward, it'd be really useful to have a bibisect: https://wiki.documentfoundation.org/QA/Bibisect/
Comment 25 John Felton 2016-11-04 18:49:13 UTC
Created attachment 128499 [details]
Main menu and tooltips on LibreOffice with GTK3 in Ubuntu 16.10 official repository
Comment 26 John Felton 2016-11-04 18:53:04 UTC
Hi all,
recently I knew that Ubuntu mainainers built LibreOffice with GTK3 for Ubuntu 16.10. It doesn't have these bugs with menu and tooltips
https://bugs.documentfoundation.org/attachment.cgi?id=128499
But there is only GTK2 in official LibreOffice PPA that has these bugs.
Does somebody know will LibreOffice go to GTK3 in next releases like 5.3?
Comment 27 Aron Budea 2016-11-14 02:03:39 UTC
As far as I know, there's no plan to switch TDF-supplied builds from GTK2 to GTK3.
Comment 28 QA Administrators 2017-11-15 09:15:50 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug