Bug 91748 - Grid in Special Characters does not follow the chosen font and is too small
Summary: Grid in Special Characters does not follow the chosen font and is too small
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: All All
: highest critical
Assignee: Tomaz Vajngerl
URL:
Whiteboard: target:5.1.0 target:5.0.0.1
Keywords: regression
: 91991 92078 92356 92435 92904 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-05-30 11:25 UTC by hkg.mahwa
Modified: 2016-10-25 19:20 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Preview of Special Character is very small. Please make it bigger, bolder and crispier (215.85 KB, image/jpeg)
2015-05-30 11:25 UTC, hkg.mahwa
Details
LO50RC1 still has the problem on OSX (63.37 KB, image/png)
2015-06-25 09:47 UTC, Martin Srebotnjak
Details
Another proof (60.74 KB, image/png)
2015-06-25 10:48 UTC, Martin Srebotnjak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hkg.mahwa 2015-05-30 11:25:01 UTC
Created attachment 116171 [details]
Preview of Special Character is very small. Please make it bigger, bolder and crispier

Preview of Special Character is very small. Please make it bigger, bolder and crispier.
Comment 1 Buovjaga 2015-05-30 11:34:31 UTC
Works ok in 4.4. Regression.

Win 7 Pro 64-bit, Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale: fi_FI

Version: 5.1.0.0.alpha1+
Build ID: bf9c96238e33f63922af35c0c77ceb83ff447d3e
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-27_07:04:47
Locale: fi-FI (fi_FI)

Ubuntu 15.04 64-bit 
Version: 4.4.2.2
Build ID: 40m0(Build:2)
Locale: en_US

Version: 5.1.0.0.alpha1+
Build ID: be01d68420086fc36ecf26b5f597ba7c6b29b369
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-05-28_03:30:12
Locale: en-US (en_US.UTF-8)
Comment 2 Adolfo Jayme Barrientos 2015-06-10 22:50:16 UTC
*** Bug 91991 has been marked as a duplicate of this bug. ***
Comment 3 Adolfo Jayme Barrientos 2015-06-10 22:55:16 UTC
The dialog is ignoring the document font and rendering the grid with the UI font and size.
Comment 4 V Stuart Foote 2015-06-11 20:07:42 UTC
(In reply to Adolfo Jayme from comment #3)
> The dialog is ignoring the document font and rendering the grid with the UI
> font and size.

confirming on Windows 8.1 with
Version: 5.0.0.0.beta3 (x64)
Build ID: 96345c15d8ab19c49014f055fe41ba8e1f421e5c
Locale: en-US (en_US)

Yes but just the repaint of the canvas is corrupt. The Special Characters dialog is not refreshing the display window to display selected fontset. It seems stuck on Liberation Serif and is painting those mappings.

But, the working fontset seems to follow drop down, and is making character picks from the selected font if it has corresponding glyphs defined.

So, think function is correct, but the display rendering of the dialog is broken.
Comment 5 Adolfo Jayme Barrientos 2015-06-15 08:11:19 UTC
*** Bug 92078 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2015-06-17 05:39:04 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=56d62036862462ca7147686268558a754613858f

tdf#91748 fix preview of special characters

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2015-06-17 05:45:53 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=efc5602dd3a2c2c138e0290e58ed1527523e4dcf&h=libreoffice-5-0

tdf#91748 fix preview of special characters

It will be available in 5.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Martin Srebotnjak 2015-06-25 09:47:03 UTC
Created attachment 116822 [details]
LO50RC1 still has the problem on OSX

Sorry, but I can still see this in LO50RC1 on OSX.
Comment 9 Tomaz Vajngerl 2015-06-25 10:46:01 UTC
Did you try to select another character - one that is not "space"? :)
Comment 10 Martin Srebotnjak 2015-06-25 10:48:59 UTC
Created attachment 116825 [details]
Another proof

Tomaž, seveda, of course I did.
Comment 11 Francisco 2015-06-25 12:52:38 UTC
(In reply to miles from comment #8)
> Created attachment 116822 [details]
> LO50RC1 still has the problem on OSX
> 
> Sorry, but I can still see this in LO50RC1 on OSX.

The problem is also still present on Linux x86_64
Comment 12 Buovjaga 2015-06-27 12:15:21 UTC
*** Bug 92356 has been marked as a duplicate of this bug. ***
Comment 13 Adolfo Jayme Barrientos 2015-06-29 14:39:19 UTC
Yeah, only the preview in the right side got fixed, but not the grid.
Comment 14 Buovjaga 2015-07-02 13:07:24 UTC
*** Bug 92435 has been marked as a duplicate of this bug. ***
Comment 16 V Stuart Foote 2015-07-24 13:12:16 UTC
*** Bug 92904 has been marked as a duplicate of this bug. ***
Comment 17 V Stuart Foote 2015-07-24 14:49:32 UTC
The grid of gylyps for selected fonts is still not redrawn correctly on drop down selection of font, as in dupe bug 92904
Comment 18 Matthew Francis 2015-08-13 07:53:16 UTC
Doesn't seem like any bibisection is required here, so removing bibisectRequest
Comment 19 David 2015-08-21 15:18:38 UTC
Still affected (experiencing the symptoms described in the several duplications) on Ubuntu 14.04 LTS 64-bit with LibO Version: 5.0.0.5, Build ID: 00m0(Build:5), Locale: en-GB (en_GB.UTF-8).

Am looking forward to a fix arriving in my neck of the woods!
Comment 20 V Stuart Foote 2015-10-17 13:25:11 UTC
On Windows 10 Pro 64-bit en-US with

Version: 5.0.3.1 (x64)
Build ID: fd8cfc22f7f58033351fcb8a83b92acbadb0749e-GL
Locale: en-US (en_US)

as well as

Version: 5.1.0.0.alpha1+
Build ID: 07bc49b43187ecc691d98eec1b9b129cf92efd70
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-15_22:30:35
Locale: en-US (en_US)

Residual issues of dupe bug 92904 do seem to be resolved.

STR

1. Open Writer
2. Open Special Character dialog
3. select "Liberation Serif" in fontlist dropdown
4. navigate to the "Miscellaneous Symbols" on the subset drop down
5. select a sharp ♯ (U+266F)
   grid of glyphs defined in Liberation Serif is rendered, with preview of the ♯
6. select "DejaVu Sans" in fonlist dropdown
   different grid of glyphs as defined in DejaVu Sans is rendered, and ♯ changes
7. select "Caldea" in fontlist dropdown (or another font without a glyph for ♯) 
   different grid of glyphs as defined in Caldea is rendered--there is no U+266F glyph defined and the ♯ preview receives a substitution (I can't tell which font or the mechanism of that substitution).

But, this all seems to be working correctly now for 5.0.3 and 5.1.0alpha1+ (master). Please test, but closing WFM.

=-=
p.s. - It might be better if the preview in a case where the glyph is not defined for the font showed a generic "not defined this font" error. But that would be a different issue.
Comment 21 Frank 2015-10-17 14:47:59 UTC
(Using Ubuntu 14.04.3 with LO 5.0.2.2)

I have to second the P.S. by V. Stuart Foote.

Specifically, if a character/glyph is displayed on the right side of the Insert Special Characters dialog, and a different font is then chosen that doesn't contain that character/Unicode block, the "Subset" becomes blank and the previous sample character (in the previous font) remains displayed along with the grid of lower ASCII characters from the new font.

Of course, once a valid Subset for the new font is chosen, things correct themselves, but this could be confusing to many users and isn't very elegant. Clearing the sample character display upon any new selection in the Subset OR font before proceeding would seem to be called for.

But the regression itself seems to have been corrected.