Bug Hunting Session
Bug 92765 - black icons in taskbar in 5.0.0.3 on Kubuntu 14.04.2 x86_64
Summary: black icons in taskbar in 5.0.0.3 on Kubuntu 14.04.2 x86_64
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.3 rc
Hardware: Other Linux (All)
: medium normal
Assignee: Jan Holesovsky
URL:
Whiteboard: target:5.1.0 target:5.0.0
Keywords: regression
: 93051 93253 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-07-15 13:20 UTC by JPJ
Modified: 2016-10-25 19:23 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Kubuntu taskbar, LibreOffice 5.0.0.3 (69.71 KB, image/png)
2015-07-15 13:20 UTC, JPJ
Details
Kubuntu taskbar, LibreOffice 5.0.0.2 (69.75 KB, image/png)
2015-07-15 13:21 UTC, JPJ
Details
LibreOffice 5.0.0.3 StartCenter on Kubuntu (73.81 KB, image/png)
2015-07-15 13:22 UTC, JPJ
Details
LibreOffice 5.0.0.2 StartCenter on Kubuntu (76.64 KB, image/png)
2015-07-15 13:22 UTC, JPJ
Details
LibreOffice 5.0.0.2 StartCenter on Kubuntu (77.89 KB, image/png)
2015-07-15 13:27 UTC, JPJ
Details
printscreen (191.52 KB, image/png)
2015-07-16 14:43 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JPJ 2015-07-15 13:20:19 UTC
Created attachment 117250 [details]
Kubuntu taskbar, LibreOffice 5.0.0.3

As of 5.0.0.3, icons in the taskbar for LibreOffice are black on Kubuntu 14.04.2 x86_64.  This issue was not present in earlier RCs or the Betas.  

        Simultaneously, the background in StartCenter changed to a graphic, overriding my custom colors.  Perhaps these two changes are related.

        I've attached screenshots of the taskbar from both 5.0.0.2 and 5.0.0.3.  In both cases, the third item in the taskbar is LibreOffice.  I've also attached screenshots of StartCenter from both 5.0.0.2 and 5.0.0.3.
Comment 1 JPJ 2015-07-15 13:21:05 UTC
Created attachment 117251 [details]
Kubuntu taskbar, LibreOffice 5.0.0.2
Comment 2 JPJ 2015-07-15 13:22:13 UTC
Created attachment 117252 [details]
LibreOffice 5.0.0.3 StartCenter on Kubuntu
Comment 3 JPJ 2015-07-15 13:22:46 UTC
Created attachment 117253 [details]
LibreOffice 5.0.0.2 StartCenter on Kubuntu
Comment 4 JPJ 2015-07-15 13:27:47 UTC
Created attachment 117254 [details]
LibreOffice 5.0.0.2 StartCenter on Kubuntu
Comment 5 JPJ 2015-07-15 19:24:14 UTC
This issue is present in daily build libreoffice-5-0~2015-07-14_03.50.43_LibreOfficeDev_5.0.1.0.0_Linux_x86-64_deb.tar.gz with Kubuntu 14.04.2 as well.
Comment 6 raal 2015-07-16 14:43:37 UTC
Created attachment 117282 [details]
printscreen

I can confirm with Version: 5.1.0.0.alpha1+
Build ID: 9be553f4c61f220ebbe212dc76cb9cce4ae1c106
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-07-13_22:45:19
Comment 7 JPJ 2015-07-17 01:21:44 UTC
        The black icons in KDE taskbar issue is not present when using the Ubuntu PPA version of rc3, 5.0.0~rc3.1-1ubuntu1~trusty1.  Taskbar icons are normal with and without libreoffice-kde installed.

        However, custom colors are still being overridden.
Comment 8 JPJ 2015-07-25 18:33:50 UTC
        This problem is still present in Version: 5.0.0.4, Build ID: cf112dc905650fb985306a7a03d2fe3fcc6c978f on Kubuntu 14.04.2 x86_64
Comment 9 Jan Holesovsky 2015-07-30 10:11:37 UTC
Not 100% sure it is the same problem; but I see black icons when I force the gtk plugin:

export SAL_USE_VCLPLUGIN=gtk

I'll push a fix for that; hope that helps in your case too.
Comment 10 Commit Notification 2015-07-30 10:19:32 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=28ef8e43cdb2944326963c0becc2812a46be5be1

tdf#92765: Show the real icon instead of a black square with gtk vclplug.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Jan Holesovsky 2015-07-30 10:24:30 UTC
Let's hope this fixes the problem for you too :-)
Comment 12 Maxim Monastirsky 2015-07-31 13:17:33 UTC
*** Bug 93051 has been marked as a duplicate of this bug. ***
Comment 13 Buovjaga 2015-07-31 14:05:50 UTC
Fixed it for me in Ubuntu Unity sidepanel & alt-tab.

Waiting for a KDE user to set to verified.

Ubuntu 15.04 64-bit 
Version: 5.1.0.0.alpha1+
Build ID: 8552e92873911ddbcb9b8b62f0cde0a0f2c81fe6
TinderBox: Linux-rpm_deb-x86_64@70-TDF-dbg, Branch:master, Time: 2015-07-30_23:49:27
Locale: en-US (en_US.UTF-8)
Comment 14 tagezi 2015-07-31 14:33:53 UTC
I confirm that the problem is still present in LO 5.0.05 for Kubuntu 14.04. And it is regresion.
I reopen this bug.
Comment 15 Maxim Monastirsky 2015-07-31 14:43:14 UTC
(In reply to Lera from comment #14)
> I confirm that the problem is still present in LO 5.0.05
No surprise here, given that it was commited to 5-0 only a few minutes ago (not sure why the commit bot didn't work)
Comment 16 Eike Rathke 2015-07-31 14:46:27 UTC
5-0-0 doesn't have the change (yet?) so of course you don't see it fixed in your 5.0.0.5, setting to resolved fixed again.

As Commit Notification seem to be on vacation..
5-0 has http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-0&id=0e530f22bf43993ca5db7efec4b6dbc0673b2e12
5-0-0 pending review https://gerrit.libreoffice.org/17449
but re-spin isn't decided yet.

It is said that installing the corresponding desktop integration package may solve the issue, but that's likely not installed for daily builds.
Comment 17 Commit Notification 2015-07-31 15:39:52 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0e530f22bf43993ca5db7efec4b6dbc0673b2e12&h=libreoffice-5-0

tdf#92765: Show the real icon instead of a black square with gtk vclplug.

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 JPJ 2015-07-31 23:52:20 UTC
This bug is still present on Kubuntu 14.04.2 in daily build:

Version: 5.0.1.0.0+
Build ID: 5edd74d8983705900681163edfc315cfbee6c08e
TinderBox: Linux-rpm_deb-x86_64@46-TDF
Branch:libreoffice-5-0
Time: 2015-07-30_23:49:52
Locale: en-US (en_US.UTF-8)

I do have the integration package lodevbasis5.0-kde-integration installed.  I had the integration package installed when I reported the bug and each time I tested it.

I just tested this daily build with neither kde nor gnome integration installed and the problem went away.  I reinstalled the kde integration package and the icons were still fine.

I went back to 5.0.0.4 and uninstalled gnome integration.  That also fixed the icon issue.

However, in all cases, when gnome integration is not installed, I end up with a horrible file picker that doesn't seem to be either the qt or gtk file picker.

In the Ubuntu PPA version of rc3, the icon problem is not present even with both gnome and kde integration installed.  It is still the case in the PPA version that uninstalling gnome integration results in a horrible file picker.
Comment 19 JPJ 2015-08-01 00:08:15 UTC
I just went back to 5.0.0.2 from http://dev-builds.libreoffice.org/pre-releases/deb/x86_64 and verified that the icon issue is not present with both gnome and kde integration installed on Kubuntu 14.04.2.  This problem definitely showed up in 5.0.0.3.

Version: 5.0.0.2
Build ID: a26d58f11b99b6aeddf7f7884effea188cc6e512
Locale: en-US (en_US.UTF-8)
Comment 20 Maxim Monastirsky 2015-08-01 19:30:03 UTC
(In reply to JPJ from comment #18)
> This bug is still present on Kubuntu 14.04.2 in daily build:
> 
> Version: 5.0.1.0.0+
> Build ID: 5edd74d8983705900681163edfc315cfbee6c08e
> TinderBox: Linux-rpm_deb-x86_64@46-TDF
> Branch:libreoffice-5-0
> Time: 2015-07-30_23:49:52
> Locale: en-US (en_US.UTF-8)
Well, you're testing a build from 2015-07-30, before the fix was committed to that branch (see comment 17).

> I do have the integration package lodevbasis5.0-kde-integration installed.
(Just keep in mind that in 5.0 this package has only KDE3 integration.)
Comment 21 Commit Notification 2015-08-02 18:55:46 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a630310ba749ba572281de684502a72fcf92dfa4&h=libreoffice-5-0-0

tdf#92765: Show the real icon instead of a black square with gtk vclplug.

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 JPJ 2015-08-03 20:12:47 UTC
(In reply to Maxim Monastirsky from comment #20)
> (In reply to JPJ from comment #18)
> > This bug is still present on Kubuntu 14.04.2 in daily build:
> > 
> > Version: 5.0.1.0.0+
> > Build ID: 5edd74d8983705900681163edfc315cfbee6c08e
> > TinderBox: Linux-rpm_deb-x86_64@46-TDF
> > Branch:libreoffice-5-0
> > Time: 2015-07-30_23:49:52
> > Locale: en-US (en_US.UTF-8)
> Well, you're testing a build from 2015-07-30, before the fix was committed
> to that branch (see comment 17).
> 
> > I do have the integration package lodevbasis5.0-kde-integration installed.
> (Just keep in mind that in 5.0 this package has only KDE3 integration.)


I should have responded to comments 13 "Fixed it for me ... Waiting for a KDE user to set to verified." and 16 "... installing the corresponding desktop integration package may solve the issue ..." instead of adding new comments.
Comment 23 Yousuf Philips (jay) (retired) 2015-08-08 16:37:59 UTC
*** Bug 93253 has been marked as a duplicate of this bug. ***