Download it now!
Bug 93373 - Black bar when launched maximized (GTK3)
Summary: Black bar when launched maximized (GTK3)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard:
Keywords:
: 93393 94047 94246 94440 95070 96041 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-08-11 20:37 UTC by Julio
Modified: 2015-12-03 19:27 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen capture (69.71 KB, image/png)
2015-08-11 20:37 UTC, Julio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julio 2015-08-11 20:37:40 UTC
Created attachment 117844 [details]
Screen capture

Since libreoffice 5.0.0 update a vertical black bar appears on right side and the bottom of the window when launched maximized.

Steps to reproduce:
- Open LibreOffice (or any component like Writer) and maximize its window.
- Close it.
- Open it again, it will be maximized and the black bar will be there.

After resizing the window the black thing disappears.
Comment 1 Maxim Monastirsky 2015-08-11 21:20:14 UTC
Also reported in Bug 93232, so setting as NEW, although I'm unable to reproduce it myself under Fedora 22 (64-bit).

As a workaround, you can export SAL_USE_VCLPLUGIN=gtk. If by a chance you're Arch Linux user (and I guess you are...), you can set this in /etc/profile.d/libreoffice-fresh.sh.
Comment 2 Julio 2015-08-12 10:42:43 UTC
Yes, I'm using Arch and with this workaround it works as expected.
Comment 3 Maxim Monastirsky 2015-08-12 16:52:45 UTC
*** Bug 93393 has been marked as a duplicate of this bug. ***
Comment 4 Maxim Monastirsky 2015-09-09 08:46:27 UTC
*** Bug 94047 has been marked as a duplicate of this bug. ***
Comment 5 v17564 2015-09-11 09:45:30 UTC
*** Bug 94047 has been marked as a duplicate of this bug. ***
Comment 6 Maxim Monastirsky 2015-09-16 07:07:10 UTC
*** Bug 94246 has been marked as a duplicate of this bug. ***
Comment 7 Maxim Monastirsky 2015-09-24 07:16:08 UTC
*** Bug 94440 has been marked as a duplicate of this bug. ***
Comment 8 Nicolas Glassey 2015-10-16 09:51:08 UTC
Confirming this bug also.

Arch Linux, xfce, nvidia, without compton.

Using gtk instead of gtk3 fixes it too.

I can reproduce that on 3 of my machines.
Comment 9 Caolán McNamara 2015-11-12 11:19:44 UTC
I can't quite reproduce this. But I can reproduce something very similar so I'm hoping that http://cgit.freedesktop.org/libreoffice/core/commit/?id=6adfbe62f6bb67d7d78c1561e9af5169d7f5bb9a fixes this
Comment 10 Maxim Monastirsky 2015-11-15 09:07:50 UTC
*** Bug 95070 has been marked as a duplicate of this bug. ***
Comment 11 Maxim Monastirsky 2015-11-24 14:26:59 UTC
*** Bug 96041 has been marked as a duplicate of this bug. ***