Bug 93446 - [l10n, Russian] Discrete distributions do not have probability density
Summary: [l10n, Russian] Discrete distributions do not have probability density
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-15 09:46 UTC by Mercury
Modified: 2019-08-19 05:04 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mercury 2015-08-15 09:46:58 UTC
Discrete distributions do not have probability density (плотность вероятности), they instead have probability function (функция вероятности). For example, BINOM.DIST function, C parameter:

Currently: Интегральная. При C=0 вычисляет функцию плотности вероятности, при C=1 - функцию распределения.

Should be: Интегральная. При C=0 вычисляет функцию вероятности, при C=1 — функцию распределения.
Comment 1 Mercury 2015-08-15 10:03:45 UTC
P.S. Of course, continuous distributions DO HAVE probability density, and you should change nothing for NORM.DIST.
Comment 2 Julien Nabet 2015-08-15 13:15:08 UTC
Code pointer:
sc/source/ui/src/scfuncs.src, eg http://opengrok.libreoffice.org/xref/core/sc/source/ui/src/scfuncs.src#7655

Winfried: one for you?
Comment 3 Mercury 2015-08-16 05:17:23 UTC
No! 1. The string repeats many, many times, and this one is exponential distribution, continuous one. 2. I meant Russian localization.
Comment 4 sophie 2015-08-25 11:32:36 UTC
I'm pinging Helen from the Russian l10n team for this one - Sophie
Comment 5 Julien Nabet 2015-08-25 11:46:37 UTC
Mercury: I was wrong for my previous comment. But just to be sure, is it specific Russian localization or is it general?
Indeed, it seems the wording in general is wrong.
Comment 6 Mercury 2015-08-25 15:10:27 UTC
You have more than one Russian localization? Weird. I don’t know your system.
Specifically, Russian localization I download from official site.
In English the things are seemingly OK, “individual probability” for binomial distribution (discrete), and “probability density” for normal (continuous).
Comment 7 Mercury 2015-08-25 18:47:17 UTC
To be specific, I’m enumerating all discrete distributions you have down here:

Binomial.
Hypergeometric.
Poisson.
Negative binomial.

It seems to me, that’s all.
Comment 8 tagezi 2015-08-26 08:24:32 UTC
The discussion is conducted in Russian forum http://forumooo.ru/index.php/topic,5126.0.html
Comment 9 Serg Bormant 2015-08-26 10:42:07 UTC
(In reply to Mercury from comment #0)
> Discrete distributions do not have probability density (плотность вероятности), they instead have probability function (функция вероятности).

(In reply to Mercury from comment #7)
> To be specific, I’m enumerating all discrete distributions you have down
> here:
> 
> Binomial.
> Hypergeometric.
> Poisson.
> Negative binomial.

Fixed:

BINOMDIST
https://translations.documentfoundation.org/ru/translate/#search=PBzyB&sfields=notes&soptions=exact
BINOM.DIST
https://translations.documentfoundation.org/ru/translate/#search=EhXR5&sfields=notes&soptions=exact
HYPGEOM.DIST
https://translations.documentfoundation.org/ru/translate/#search=EXAWV&sfields=notes&soptions=exact

Fixed in Russian, still have "probability density" instead of "probability function" or same in msgids:

NEGBINOM.DIST
https://translations.documentfoundation.org/ru/translate/#search=bBgXv&sfields=notes&soptions=exact
POISSON
https://translations.documentfoundation.org/ru/translate/#search=sC7ZZ&sfields=notes&soptions=exact
POISSON.DIST
https://translations.documentfoundation.org/ru/translate/#search=9fJ2Z&sfields=notes&soptions=exact
Comment 10 QA Administrators 2017-03-06 13:57:44 UTC Comment hidden (obsolete)
Comment 11 Mercury 2017-03-06 20:56:54 UTC
Done, but there’s another problem. In current window size you cannot see the entire message. What to do?
Comment 12 QA Administrators 2018-03-07 03:41:07 UTC Comment hidden (obsolete)
Comment 13 Julien Nabet 2019-08-18 15:33:33 UTC
Any update with a recent LO version?
Comment 14 Mercury 2019-08-18 21:16:30 UTC
Watched those four distributions, OK.
Comment 15 Julien Nabet 2019-08-19 05:04:29 UTC
thank you for your feedback.
since there’s no patch associated to this bug, let’s put WFM instead of FIXED