Download it now!
Bug 93471 - Export as EPS crashing 5.0.1.1rc builds
Summary: Export as EPS crashing 5.0.1.1rc builds
Status: RESOLVED DUPLICATE of bug 91782
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-08-16 17:25 UTC by V Stuart Foote
Modified: 2015-08-16 19:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
gdb backtrace for crash on export to EPS on LibreOffice 5.0.1.1rc (7.12 KB, text/plain)
2015-08-16 19:06 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2015-08-16 17:25:40 UTC
On Windows 10 Pro, 64-bit en-US with nVidia GTX260
Version: 5.0.1.1 (x64)
Build ID: 13f702ca819ea5b9f8605782c852d5bb513b3891
Locale: en-US (en_US)

Export of any drawing open in Draw as .EPS format will crash 32-bit and 64-bit builds LibreOffice 5.0.1.1rc

However, no issue with export to EPS with recent builds of master, 32-bit TB39 or 64-bit TB62.
Comment 1 V Stuart Foote 2015-08-16 17:33:28 UTC
Same Windows 10 Pro 64-bit en-US with /a administrative install of
Version: 5.0.1.1
Build ID: 13f702ca819ea5b9f8605782c852d5bb513b3891
Locale: en-US (en_US)

32-bit build also crashing on export to .EPS from Draw.
Comment 2 MM 2015-08-16 18:05:06 UTC
Confirmed with v5.0.1.1 under mint 17.2 x64.
Confirmed with v5.0.0.5 under ubuntu 14.04 x64.

Doesn't crash when saving, but before the eps options windows gets open.

No crash with v4.4.5.2, so regression.
Comment 3 V Stuart Foote 2015-08-16 19:06:06 UTC
Created attachment 117951 [details]
gdb backtrace for crash on export to EPS on LibreOffice 5.0.1.1rc

Back trace attached... seems to be in libepslo.so
Comment 4 V Stuart Foote 2015-08-16 19:23:50 UTC
Julien already caught it, should be fixed for 5.0.1.2

*** This bug has been marked as a duplicate of bug 91782 ***