Download it now!
Bug 94112 - Unreadable non accesible entries in menu with kde dark theme
Summary: Unreadable non accesible entries in menu with kde dark theme
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2015-09-10 21:43 UTC by Houston4444
Modified: 2016-09-24 02:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen Capture of unreadable menu entries (16.20 KB, image/png)
2015-09-10 21:43 UTC, Houston4444
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Houston4444 2015-09-10 21:43:45 UTC
Created attachment 118587 [details]
Screen Capture of unreadable menu entries

Using Breeze dark color scheme , unaccessible entries in menu are unreadable because black on black.
I tried to remove libreoffice-kde and apply oxygen-gtk theme for gtk3 apps (this theme colors apps with kde default color), and unaccessible entries becomes green and so, readables.

Sorry for my english.

Kubuntu 15.04 64bits
Pre-release ppa tested.
Comment 1 Houston4444 2015-09-10 22:18:19 UTC
Sorry, before removing libreoffice-kde, I did check an accesibility option which adapt colors contrast . That's why unaccessible entries were green.
Comment 2 Zeki Bildirici 2015-09-12 21:21:55 UTC
Hi,

I can confirm the issue but i couldn't find the applied name (of deactive text) on KDE System Settings-> Color - > Color Tab - Color Schemes.

Best regards
Zeki
Comment 3 Yousuf Philips (jay) (retired) 2016-09-19 17:00:01 UTC
@Caolan, @Maxim: Any thoughts on this as i see with kde neon, breeze dark theme, and kde package installed.
Comment 4 Caolán McNamara 2016-09-19 19:50:35 UTC
no idea unfortunately, I haven't the capacity to stretch over kde issues
Comment 5 Commit Notification 2016-09-22 18:22:17 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=987a4a994edf1512aaa7a92721c4b6e829806b62

tdf#94112 KDE4 use disabled WindowText color

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Heiko Tietze 2016-09-22 23:18:38 UTC
Issue is fixed, thanks a lot.