Bug 94164 - Hide whitespace mode: shrink page height to remove all white space between pages in case of page break
Summary: Hide whitespace mode: shrink page height to remove all white space between pa...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-12 15:26 UTC by Laurent BP
Modified: 2017-05-22 20:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of Hide WhiteSpace hover sprite masking text (34.01 KB, image/gif)
2016-01-08 18:30 UTC, GavinB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2015-09-12 15:26:55 UTC
Description: Follow up of bug 39080. "Hide whitespace" is working, but page size should be adapt to keep the same width for text as in normal mode. Moreover, when page breaks before the bottom of the page, some white space are still visible.

Steps to reproduce:
1. Enable View > Hide Whitespace
2. Create a new document and enter dummy text (dt+F3)
3. Hit Ctrl+Enter to insert a manual page break

Actual behavior:
A large white space is still visible at the bottom of the page

Expected behavior:
Page height should be shrink to hide white space

Same problem if page break occurs for any other reason before the bottom of the page
Comment 1 Jean-Baptiste Faure 2015-09-12 16:03:31 UTC
Reproducible. I observed the same problem.

Best regards. JBF
Comment 2 Ashod Nakashian 2015-09-20 16:16:35 UTC
Fixed, pending review: https://gerrit.libreoffice.org/#/c/18156/
Comment 3 GavinB 2016-01-07 16:46:31 UTC
While shrinking page height to obtain the Hide Whitespace mode it would be good to follow the established practice of NOT removing the white space :
from the top of the first page, nor 
from the bottom of the last.  

IMO this aids usability and 
it is as done in MS word since way back when.
Comment 4 GavinB 2016-01-07 16:51:44 UTC
On a related issue it would be good when Whitespace is Hidden that the space between pages was a 10 or so pixels bigger.

That way the hover mechanism/floating icon 
would no longer distract/interfere with the user 
when they are typing on the first line of each new page.
Comment 5 Ashod Nakashian 2016-01-08 00:46:01 UTC
(In reply to GavinB from comment #3)
> While shrinking page height to obtain the Hide Whitespace mode it would be
> good to follow the established practice of NOT removing the white space :
> from the top of the first page, nor 
> from the bottom of the last.  

The original implementation did exactly that. It removed the header and footer sections, leaving the page size exactly the same. So the contents had more space to fill.

The problem was that pages restructured and pagination changed. So the view was not consistent with the normal view.

Current implementation crops the header and footer and shrinks the page to fit the contents exactly. So pagination and page structure is retained.

I'm not sure what MSW is doing, but I believe it preserves the pagination as well, which is what we're doing.
Comment 6 Ashod Nakashian 2016-01-08 00:47:15 UTC
(In reply to GavinB from comment #4)
> On a related issue it would be good when Whitespace is Hidden that the space
> between pages was a 10 or so pixels bigger.
> 
> That way the hover mechanism/floating icon 
> would no longer distract/interfere with the user 
> when they are typing on the first line of each new page.

Can you elaborate please? Maybe a screenshot would help.

How is the icon distracting now and how would making the space larger avoid this?

Thanks.
Comment 7 GavinB 2016-01-08 18:30:48 UTC
Created attachment 121804 [details]
Screenshot of Hide WhiteSpace hover sprite masking text

LibreOffice Writer
Version: 5.2.0.0.alpha0+ (x64)
Build ID: a454a9b3ae0f6ab81012fbef7b3ff6f0f44bf6cb
Threads 4; Ver: Windows 6.19; Render: default;
Comment 8 GavinB 2016-01-08 18:33:16 UTC
Here's a screenshot.  
The word "The" is masked in the line beneath the cropped page break.
Comment 9 Ashod Nakashian 2016-01-08 18:54:07 UTC
(In reply to GavinB from comment #8)
> Here's a screenshot.  
> The word "The" is masked in the line beneath the cropped page break.

Thanks. Of course any cursor will cover the text it is over. If we make the distance between pages larger it won't solve the problem because that space is not fixed, it depends on the zoom. So one can zoom out enough and still complain that the cursor covers the text. The current space size is chosen to be small enough to hint at the break but to make the content look continuous. Making it very large will be wasteful, and as mentioned depends on zooming.

Luckily, the mouse can be moved if it distracts the user :)
Comment 10 GavinB 2016-01-09 16:26:31 UTC
Thanks Ashod
points taken,
but it is a real pain trying to edit footnotes 
with that sprite popping up all the time.
Comment 11 Ashod Nakashian 2016-01-09 16:49:15 UTC
(In reply to GavinB from comment #10)
> Thanks Ashod
> points taken,
> but it is a real pain trying to edit footnotes 
> with that sprite popping up all the time.

In my mind, the Hide Whitespace mode has a certain workflow in mind: to make the _content_ of the page continuous and uninterrupted by distractions (such as headers, footers, and whitespace between pages). It really isn't a substitute for something like the Browser mode, or Normal view.

I do realize that ideally we'd have these values as settings the users could tweak to their liking. But for now we have something that does the job fairly well, but doesn't come with bells and whistles.

Perhaps a good solution to this particular issue you raise is to 'hide the mouse cursor when typing'. It would be great if we could have something similar (if we don't already) and essentially hide the mouse cursor while the user is typing, and show it when they move the mouse. (Feel free to check if we don't have it and file a feature bug to track it.)

Thanks for your suggestions... keep them coming.
Comment 12 QA Administrators 2017-05-22 13:20:09 UTC Comment hidden (obsolete)
Comment 13 Laurent BP 2017-05-22 20:08:25 UTC
Hard break page are correctly displayed in LibO:
- Version: 5.1.6.2 (x64)
- Version: 5.2.7.2 (x64)
- Version: 5.3.2.2 (x64)