Bug 94165 - Hide whitespace mode: adapt page width to keep the same page numbers
Summary: Hide whitespace mode: adapt page width to keep the same page numbers
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-12 15:37 UTC by Laurent BP
Modified: 2017-05-22 20:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent BP 2015-09-12 15:37:40 UTC
Description: Follow up of bug 39080. "Hide whitespace" is working, but page width should be adapt to keep the same width for text as in normal mode. Otherwise page number are modified.

Steps to reproduce:
1. Disable View > Hide Whitespace
2. Type dummy text so that it exceeds one page
3. Enable View > Hide Whitespace

Actual behavior
Page break is not at the same place because text width is wider than with normal mode.

Expected behavior
Page break should be kept at the same place, otherwise page numbers in the table of content would be different. Page width should be adapt to keep the same text width.
Comment 1 Buovjaga 2015-09-18 16:28:19 UTC
Yep.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+ (x64)
Build ID: 9ce08dcc2e32c5554ddf71b79173f8854e0568ad
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-09-17_21:43:51
Locale: en-US (fi_FI)
Comment 2 Ashod Nakashian 2015-09-20 16:16:11 UTC
Fixed, pending review: https://gerrit.libreoffice.org/#/c/18156/
Comment 3 QA Administrators 2017-05-22 13:19:37 UTC Comment hidden (obsolete)
Comment 4 Laurent BP 2017-05-22 20:00:40 UTC
Width of text is correct. It is page length which is wrong. See bug 98958