Bug Hunting Session
Bug 94843 - OpenGL messes up interface with black flashing refreshes etc. on Windows with 5.1, while 5.0 is ok
Summary: OpenGL messes up interface with black flashing refreshes etc. on Windows with...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 95628 (view as bug list)
Depends on:
Blocks: 96385
  Show dependency treegraph
 
Reported: 2015-10-07 05:29 UTC by Buovjaga
Modified: 2016-01-13 10:35 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2015-10-07 05:29:36 UTC
Pretty much the same as bug 94726, but only on 5.1. 5.0.2 is fine with OpenGL enabled.

Some icons have black background or other glitches, most visible when using Breeze.
Sluggish redraw performance.
Tooltips, dialogs and menus flash black before rendering. Sidebar doesn't flash black.

Thinkpad T520 with Intel HD3000.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: f830600ece806ec365a4839e79afabe183c5e36d
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-06_22:49:09
Locale: en-US (fi_FI)
Comment 1 Maxim Monastirsky 2015-10-08 17:23:28 UTC
I reproduce the "dialogs flash black before rendering" with OpenGL enabled in 5.0.2 under Fedora 22 (64-bit). The rest is not repro here.

Lenovo G580 with Intel HD3000.
Comment 2 Buovjaga 2015-11-11 09:01:17 UTC
*** Bug 95628 has been marked as a duplicate of this bug. ***
Comment 3 Buovjaga 2015-11-11 09:01:39 UTC
New per tommy's report.
Comment 4 Roman Kuznetsov 2015-11-18 14:36:43 UTC
i reproduce this -> "Tooltips flash black before rendering" on Windows 7 HB x86-64 in LO 5.1 with enabled OpenGL

Version: 5.1.0.0.alpha1+
ID build: 510f463099272cec7f2193f3ffa1dbbd20d9f718
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-17_22:33:07
Locale: ru-RU (ru_RU)
videocard: intel HD 4000

in LO 5.0.1 this problem is missing

link to video https://yadi.sk/i/RqSUrZIbkYe8Y, do not look it on site, download it and look in locale player
Comment 5 Roman Kuznetsov 2015-11-18 18:48:39 UTC
(In reply to kompilainenn from comment #4)
> i reproduce this -> "Tooltips flash black before rendering" on Windows 7 HB
> x86-64 in LO 5.1 with enabled OpenGL
> 
> Version: 5.1.0.0.alpha1+
> ID build: 510f463099272cec7f2193f3ffa1dbbd20d9f718
> TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-17_22:33:07
> Locale: ru-RU (ru_RU)
> videocard: intel HD 4000
> 
> in LO 5.0.1 this problem is missing
> 
> link to video https://yadi.sk/i/RqSUrZIbkYe8Y, do not look it on site,
> download it and look in locale player

on videocard AMD 7750 this not reproduced
Comment 6 Michael Meeks 2016-01-13 10:33:40 UTC
Beluga reports the flashing is gone - "in the start center with ogl, the menus don't flash black, but they do flash blank/grey ie. there is a lag".

Perhaps good to file the lagging as a separate issue; we try to render the window completely before showing it at idle; but perhaps there is some prioritisation issue; I don't see a significant lag here though.

Thanks !
Comment 7 Michael Meeks 2016-01-13 10:35:50 UTC
We should not flash black anymore; perhaps a white background; Beluga reports:

commit 6c8fffdf4f968b4838dc4cb3d5161631877b0ebd
Author: Michael Meeks <michael.meeks@collabora.com>
Date:   Tue Jan 12 21:13:13 2016 +0000

    bug#96385 - opengl: dynamically adjust priority of swap buffers.

Thanks for reporting ! =)