Bug Hunting Session
Bug 94726 - Sluggish performance on high-end computer
Summary: Sluggish performance on high-end computer
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf
: 95185 (view as bug list)
Depends on:
Blocks: VCL-OpenGL
  Show dependency treegraph
 
Reported: 2015-10-03 10:16 UTC by Marek Lukáš
Modified: 2016-01-13 10:46 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Lukáš 2015-10-03 10:16:40 UTC
User-Agent:       Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
Build Identifier: LibreOffice 5.0.2.2

On 8GB of RAM, 64bit Libreoffice and i7 LibreOffice suit seems lagging all the time. I even tried giving LO more memory in settings, but it doesn't seem to help at all.

1)When resizing window, window turns black, freezes, computes everything it needs and then finally resizes properly.

2)When fast scrolling through properly formatted text document which has only 2 pages, I get about 1-2 fps.

3)When hovering over any tools menu, I get black popup window before the tools load for few few ms. Not a big deal, but it shouldn't happen on powerful computers.

Reproducible: Always

Actual Results:  
LO suit (any package) doesn't re-draw as quick as it should be. Not snappy at all :-(

Expected Results:  
Fast and lightweigh experience.

[Information automatically included from LibreOffice]
Locale: cs
Module: TextDocument
[Information guessed from browser]
OS: Windows 10
OS is 64bit: yes
GPU: GTX 660 TI
CPU: i7 3770
RAM: 8GB


Reset User Profile?No
Comment 1 Buovjaga 2015-10-06 11:55:13 UTC
Does it help, if you go to Tools - Options - LibO - View - uncheck Use OpenGL?
Comment 2 Marek Lukáš 2015-10-06 12:30:16 UTC
Thanks for response :-)

Yes, it seems to help.
Comment 3 Buovjaga 2015-10-07 05:30:34 UTC
It's weird, but I get the same behavior only on 5.1, bug 94843
Comment 4 Michael Meeks 2015-10-07 16:39:03 UTC
How interesting; Miklos - your NVidea was working fine - right ? =)
Comment 5 Michael Meeks 2015-10-08 16:55:07 UTC
We just found a rather silly thing here around shader re-compilation that impacts performance; but - prolly not -that- much; will try to get that into 5.0.3 RC2.
Comment 6 Fotis 2015-10-09 14:59:06 UTC
Same problem as OP here. Also a Nvidia card (750gtx), windows 7-64. LO 5.0.2.2 Switching off OpenGL helps too.
Comment 7 Buovjaga 2015-10-09 15:05:41 UTC
As Fotis confirmed, let's set to NEW, while we wait for 5.0.3 RC2
Comment 8 Matoyak 2015-10-13 02:28:36 UTC
I'm assuming this is related, but I'm getting severe slowdown using drop down menus, coinciding with massive jump in CPU usage. The product did not do this in the previous release. Included is a link to an unlisted video to show the exact behavior.

https://youtu.be/BK9ilOCTgs8

System: (also shown in video)
Windows 10 x64
LibreOffice 5.0.2.2
Nvidia GTX 760
AMD Hexcore FX 6300
8GB RAM
Comment 9 Matoyak 2015-10-13 02:30:54 UTC
(In reply to Matoyak from comment #8)
> I'm assuming this is related, but I'm getting severe slowdown using drop
> down menus, coinciding with massive jump in CPU usage. The product did not
> do this in the previous release. Included is a link to an unlisted video to
> show the exact behavior.
> 
> https://youtu.be/BK9ilOCTgs8
> 
> System: (also shown in video)
> Windows 10 x64
> LibreOffice 5.0.2.2
> Nvidia GTX 760
> AMD Hexcore FX 6300
> 8GB RAM

I should mention that as shown in the video, changing the OpenGL setting does not show any effect.
Comment 10 Buovjaga 2015-10-13 05:04:36 UTC
(In reply to Matoyak from comment #9)
> I should mention that as shown in the video, changing the OpenGL setting
> does not show any effect.

You restarted LibreOffice after changing the setting?
If yes, then your problem is not the same.
Comment 11 Buovjaga 2015-10-21 18:36:07 UTC
*** Bug 95185 has been marked as a duplicate of this bug. ***
Comment 12 bughunt1234 2015-10-24 15:46:34 UTC
Librecalc 5.0.2.2
I saw the same performance problems moving around a modest spreadsheet (80 rows)

Tools, Options, View
Use Open GL for all rendering -unticked  This fixed the problem for me

Desktop PC
12 GB Ram
AMD Athlon X3 445
Video AMD Radeon HD-6670
Windows 10.0.10565 (Preview)
SSD
Comment 13 ckakman 2015-10-28 19:00:28 UTC
After disabling the OpenGL rendering setting, the application became more responsive.
Comment 14 Kim 2015-10-30 18:50:07 UTC
(In reply to Marek Lukáš from comment #0)
> User-Agent:       Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:42.0)
> Gecko/20100101 Firefox/42.0
> Build Identifier: LibreOffice 5.0.2.2
> 
> On 8GB of RAM, 64bit Libreoffice and i7 LibreOffice suit seems lagging all
> the time. I even tried giving LO more memory in settings, but it doesn't
> seem to help at all.
> 
> 1)When resizing window, window turns black, freezes, computes everything it
> needs and then finally resizes properly.
> 
> 2)When fast scrolling through properly formatted text document which has
> only 2 pages, I get about 1-2 fps.
> 
> 3)When hovering over any tools menu, I get black popup window before the
> tools load for few few ms. Not a big deal, but it shouldn't happen on
> powerful computers.
> 
> Reproducible: Always
> 
> Actual Results:  
> LO suit (any package) doesn't re-draw as quick as it should be. Not snappy
> at all :-(
> 
> Expected Results:  
> Fast and lightweigh experience.
> 
> [Information automatically included from LibreOffice]
> Locale: cs
> Module: TextDocument
> [Information guessed from browser]
> OS: Windows 10
> OS is 64bit: yes
> GPU: GTX 660 TI
> CPU: i7 3770
> RAM: 8GB
> 
> 
> Reset User Profile?No

I experienced very similar behavior on 5.0.2. Disabling OpenGL did not solve the problem (nor did resetting user profile). However, downgrading to version 5.0.1 did (even with OpenGL enabled).
System:
OS: Windows 8.1 Pro (64bit)
GPU: Nvidia GTX 770
CPU: i7-4770K
RAM: 16GB
Comment 15 Robinson Tryon (qubit) 2015-12-09 18:08:17 UTC
Migrating Whiteboard tags to Keywords: (perf)
Comment 16 Buovjaga 2015-12-16 14:01:22 UTC
Question for all affected people: do you have the latest graphics card drivers?
Comment 17 Kim 2015-12-16 16:13:12 UTC
(In reply to Beluga from comment #16)
> Question for all affected people: do you have the latest graphics card
> drivers?

I believe that I was using 358.50 when i tested 5.0.2, but if it was the latest, at the time of testing, I don't know.
Comment 18 Kim 2015-12-23 15:28:27 UTC
Today I installed LibreOffice_5.0.4_Win_x86 and all of the performance issues seems to be history.

OpenCL is enabled with default settings.

System:
OS: Windows 8.1 Pro (64bit)
GPU: Nvidia GTX 770 (driver: NVIDIA 358.50)
CPU: i7-4770K
RAM: 16GB
Comment 19 Michael Meeks 2015-12-23 15:43:13 UTC
5.0.4 disables GL by default ;-) so - glad that fixes things for you - but we'll leave this bug open in order to track the underlying problem.

Then again 5.1 is significantly improved performance-wise too =) thanks !
Comment 20 Kim 2015-12-23 17:57:59 UTC
(In reply to Michael Meeks from comment #19)
> 5.0.4 disables GL by default ;-) so - glad that fixes things for you - but
> we'll leave this bug open in order to track the underlying problem.
> 
> Then again 5.1 is significantly improved performance-wise too =) thanks !

I am not sure what you mean by "5.0.4 disables GL by default". If I go to Options -> LibreOffice -> OpenCL the "Allow use of OpenCL" is checked. Is this setting ignored in 5.0.4?
Comment 21 Buovjaga 2015-12-23 18:01:57 UTC
(In reply to Kim from comment #20)
> (In reply to Michael Meeks from comment #19)
> > 5.0.4 disables GL by default ;-) so - glad that fixes things for you - but
> > we'll leave this bug open in order to track the underlying problem.
> > 
> > Then again 5.1 is significantly improved performance-wise too =) thanks !
> 
> I am not sure what you mean by "5.0.4 disables GL by default". If I go to
> Options -> LibreOffice -> OpenCL the "Allow use of OpenCL" is checked. Is
> this setting ignored in 5.0.4?

Tools - Options - LibO - View - Use OpenGL for all rendering
Comment 22 Kim 2015-12-23 18:09:51 UTC
(In reply to Beluga from comment #21)
> (In reply to Kim from comment #20)
> > (In reply to Michael Meeks from comment #19)
> > > 5.0.4 disables GL by default ;-) so - glad that fixes things for you - but
> > > we'll leave this bug open in order to track the underlying problem.
> > > 
> > > Then again 5.1 is significantly improved performance-wise too =) thanks !
> > 
> > I am not sure what you mean by "5.0.4 disables GL by default". If I go to
> > Options -> LibreOffice -> OpenCL the "Allow use of OpenCL" is checked. Is
> > this setting ignored in 5.0.4?
> 
> Tools - Options - LibO - View - Use OpenGL for all rendering

Enabling OpenGL does lower the smoothness when scrolling and everything seems a bit more sluggish (in 5.0.4).

I seem to have mixed the terms OpenCL and OpenGL, my apologies.
Comment 23 Michael Meeks 2016-01-13 10:46:55 UTC
This should be significantly improved in 5.0.2 RC2 (due this week). Please can you re-test, and re-open if problems persist.

Thanks !