Bug 94956 - Colors inverted when playing animations
Summary: Colors inverted when playing animations
Status: RESOLVED DUPLICATE of bug 92184
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-11 13:33 UTC by CptSpaceToaster
Modified: 2015-10-13 14:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
DirectX Diagnostic and System Information (38.59 KB, text/plain)
2015-10-11 13:33 UTC, CptSpaceToaster
Details
3 Slide Presentation, with two images. (559.05 KB, application/vnd.oasis.opendocument.presentation)
2015-10-13 13:31 UTC, CptSpaceToaster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description CptSpaceToaster 2015-10-11 13:33:24 UTC
Created attachment 119512 [details]
DirectX Diagnostic and System Information

This does not appear to effect [4.4.5.2 release]

Possibly related to something in here: https://bugs.documentfoundation.org/show_bug.cgi?id=84205

Occurs:
Bug occurs when playing animations and transitions between slides that perform a complex manipulation of the image/background.

Description:
Background images appear to be inverted for the duration of the animation.  Yellows turn blueish, until the animation finishes playing.  Then the image displays as expected.  This effects the preview shown in the editor when "Play/Preview animation" button from the transitions menu is clicked as well as animations in the live presentation.

This system has 2 monitors on an on-board GPU.
Graphics Chipset:  ATI Radeon 3000 Graphics
Provider:          ATI Technologies Inc.
2D Driver Version: 8.01.01.1152
Direct3D Version:  7.14.10.0833

The problem was observed on both monitors

No Transition: Not observed
Wipe Up: Not observed
Wipe Left: Not observed

Example Transitions:
Fade Smoothly: OBSERVED
Fade through black: OBSERVED
There was an animation that rotated in the image from the top, like a meat cleaver swinging down.  I'm not sure what it was called, but it was OBSERVED in that case as well.
Comment 1 raal 2015-10-12 19:03:13 UTC
Hello,

Thank you for filing the bug. Please send us a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO', so please do change it back to 'UNCONFIRMED' once you have attached a document.
(Please note that the attachment will be public, remove any sensitive information before attaching it.)
How can I eliminate confidential data from a sample document?
https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F
Thank you
Comment 2 CptSpaceToaster 2015-10-13 13:31:19 UTC
Created attachment 119554 [details]
3 Slide Presentation, with two images.
Comment 3 V Stuart Foote 2015-10-13 14:13:56 UTC

*** This bug has been marked as a duplicate of bug 92184 ***