Bug 92184 - 3D slide transitions work but during the transition images are bluish
Summary: 3D slide transitions work but during the transition images are bluish
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta3
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 94956 (view as bug list)
Depends on:
Blocks: Impress-OpenGL VCL-OpenGL
  Show dependency treegraph
 
Reported: 2015-06-19 13:33 UTC by pieter kristensen
Modified: 2015-11-29 17:58 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
here you see the bluish transition (73.20 KB, image/jpeg)
2015-06-23 11:22 UTC, pieter kristensen
Details
here is the orriginal picture (77.68 KB, image/jpeg)
2015-06-23 11:24 UTC, pieter kristensen
Details
example .odp file (1.76 MB, application/vnd.oasis.opendocument.presentation)
2015-06-23 11:28 UTC, pieter kristensen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pieter kristensen 2015-06-19 13:33:55 UTC
For the first time the 3d slide transitions really work on my windows box. I use W7 32 bit. My video card is a Nvidia GeForce GT 520.

But during the transitions, the slides that are being transitioned colour bluish.
I am happy that the work is progressing so good.
Almost there!
Thanks.
PK
Comment 1 tommy27 2015-06-22 19:19:08 UTC
would you please upload a test file and screenshots?
Comment 2 pieter kristensen 2015-06-23 11:22:52 UTC
Created attachment 116757 [details]
here you see the bluish transition
Comment 3 pieter kristensen 2015-06-23 11:24:48 UTC
Created attachment 116758 [details]
here is the orriginal picture
Comment 4 pieter kristensen 2015-06-23 11:28:09 UTC
Created attachment 116759 [details]
example .odp file
Comment 5 pieter kristensen 2015-06-23 11:43:43 UTC
I just tested with 5.0.0.1 and it behaves in the same way as the previous version. The 3d transitions have a bluish colour.
Comment 6 Aleksei 2015-06-23 12:31:17 UTC
Can you add steps to reproduce this bug?
Comment 7 Buovjaga 2015-06-23 12:46:37 UTC
(In reply to Aleksei from comment #6)
> Can you add steps to reproduce this bug?

1. New Impress document
2. Click the Slide transition button (above the star icon) in the sidebar in the right
3. Double click a 3d transition like Venetian blinds 3D vertical to apply it to the slide
I guess the blueness should show already in the preview (?), but you can start the presentation with F5 to see, how it goes.

I haven't seen any blueness myself.
Comment 8 pieter kristensen 2015-06-23 13:35:33 UTC
When I run the presentation using F5 the blue also occurs. It's makes no difference.
Comment 9 pieter kristensen 2015-06-23 14:14:16 UTC
I happen to dual-boot Windows 7 32 bit with Ubuntu 14.04 LTS 32 bit on my desktop. So I tried LO 5.0.0.1 on ubuntu too (same NVIDIA GeForce GT 520 GPU). Both the Nouveau display driver and the NVIDIA binary driver - version 331.113 with updates behaved flawless.
Comment 10 pieter kristensen 2015-08-06 18:20:26 UTC
The bug still occurs in 5.0.0.5.
I even tested this windows-version of LO on a total different (linux) computer under wine. When I started a 3d transition LO crashed but short before it crashed LO showed a bluish image. 
This surprised me.
Comment 11 pieter kristensen 2015-08-29 07:14:55 UTC
Still occurs in 5.0.1.2
Upgraded W7 to W10.
But still 3d transitions are blueish
Comment 12 Darrell 2015-10-12 19:48:04 UTC
This is still occurring in 5.0.2.2/Windows 10
Comment 13 V Stuart Foote 2015-10-12 21:00:14 UTC
Confirming and setting New

Confirming on Windows 8.1 Ent 64-bit en-US with
Name	NVIDIA Quadro K2000
PNP Device ID	PCI\VEN_10DE&DEV_0FFE&SUBSYS_094C10DE&REV_A1\4&2412C6A&0&0008
Adapter Type	Quadro K2000, NVIDIA compatible
Adapter Description	NVIDIA Quadro K2000
Adapter RAM	(2,147,483,648) bytes
Installed Drivers	nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver Version	9.18.13.3182

Attachment 116759 [details] adjusted to use a "3D" transition (Venetian Blinds 3D Vertical, Turn around) 

With "Use Hardware Acceleration" and "Use OpenGL for all Rendering" set from Tools -> Options -> View

Images seem to only compose with Blue layer -- Red and Green omitted. Once the transition effect completes--the full image is rendered.  Affects both the JPGs recorded in this ODG, as well as  other graphic formats (SVGs, PNGs).

If "Use Hardware Acceleration" is set disabled--the transitions render as RGB.

@Michael M.--adding to bug 94691, but don't know that this is exclusively an OpenGL issue. Seems like it is...
Comment 14 V Stuart Foote 2015-10-12 21:26:50 UTC
Also affecting recent builds of master -- so both meta's bug 93529 and bug 94691

Affecting these transitions, they all render with "Use Hardware Acceleration" disabled.

Shape Diamond
Fade Through Black
Fade Smoothly
Flipping Tiles
Outside Turning Cube
Revolving Circles
Turning Helix
Inside Turning Cube
Fall
Turn Around
Iris
Turn Down
Rochade
Venetian Blinds 3D Vertical
Venetian Blinds 3D Horizontal
Static
Fine Disolve
News Flash
Comment 15 V Stuart Foote 2015-10-13 14:13:56 UTC
*** Bug 94956 has been marked as a duplicate of this bug. ***
Comment 16 Michael Meeks 2015-10-15 17:42:59 UTC
"Use Hardware Acceleration" and "Use OpenGL for all rendering" should be mutually exclusive in 5.0.2.2+ - I can't reproduce this on Windows / AMD with a fresh -5-0 branch as of now.

I suspect this is a duplicate of bug#94384 - can you reproduce it in recent build with that fix included ?

Thanks !
Comment 17 V Stuart Foote 2015-10-15 19:15:54 UTC
(In reply to Michael Meeks from comment #16)
> "Use Hardware Acceleration" and "Use OpenGL for all rendering" should be
> mutually exclusive in 5.0.2.2+ - I can't reproduce this on Windows / AMD
> with a fresh -5-0 branch as of now.

OK, but on today's TB62 build it remains...
Version: 5.1.0.0.alpha1+
Build ID: 4b55c28940d741e53648115a9cfb58f2d6db38a5
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-15_06:14:50
Locale: en-US (en_US)

So I'm confused, if "Use OpenGL for all rendering" is unchecked what is "Use hardware acceleration" controlling?  Why when it is unchecked it eliminates the single band color use in the BMP rendered by the transition?

I can have "Use OpenGL for all rendering" checked on, but "Use hardware acceleration" unchecked--and not have the single band bitmap show. But is the OpenGL rendering even active when hardware acceleration is unchecked?

Does the malformed issue come from some generic graphics processing in those transitions?  Nothing to do with OpenGL hardware acceleration?
Comment 18 V Stuart Foote 2015-11-17 18:04:00 UTC
With current master on Windows 8.1 Ent 64-bit (en-US)
Adapter Description	NVIDIA Quadro K2000
Adapter RAM	(2,147,483,648) bytes
Installed Drivers	nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
Driver Version	9.18.13.3182

Version: 5.1.0.0.alpha1+ (x64)
Build ID: 32d4c03cba399ada807b8ec113a3928aa9e3ff7b-GL
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-11-16_23:41:46
Locale: en-US (en_US)

Blue layer is no longer present in the image being rendered during OpenGL transition effects. Seems like the full color image from canvas is used now.
Comment 19 pieter kristensen 2015-11-17 18:15:02 UTC
I do NOT agree with that. When /Tools/Options/LiberOfficeDev/View/use hardware acceleration is selected the 3d transitions are blue in the 5.1.0.0 alpha1+ on my Windows 10 32 bit machine.
You could try it on your computer as well Stuart (comment 18).
When I unselect "use hardware acceleration" then the colour is not blue. But all together not the ideal situation I would think.
Comment 20 Buovjaga 2015-11-17 18:19:14 UTC
(In reply to pieter kristensen from comment #19)
> I do NOT agree with that. When /Tools/Options/LiberOfficeDev/View/use
> hardware acceleration is selected the 3d transitions are blue in the 5.1.0.0
> alpha1+ on my Windows 10 32 bit machine.
> You could try it on your computer as well Stuart (comment 18).
> When I unselect "use hardware acceleration" then the colour is not blue. But
> all together not the ideal situation I would think.

From what date is your 5.1 build?
Comment 21 pieter kristensen 2015-11-17 18:22:05 UTC
The build is made 2015-10-17
Comment 22 Buovjaga 2015-11-17 18:29:58 UTC
(In reply to pieter kristensen from comment #21)
> The build is made 2015-10-17

There you have it :) Plz try a fresh build: http://dev-builds.libreoffice.org/daily/master/?C=M;O=A
Comment 23 pieter kristensen 2015-11-17 18:44:34 UTC
Oh, I'm sorry. I feel a little stupid.
I didn't even know that e.g. the 5.1.0.0.alpha1+ changed every day but kept the same name.
One is never to old to learn. 
You are absolutely right. I share your experience. 
There is still a little glitch with the 3d transitions but it is not the snow white one there used to be. It lasts to short to see what it is.