Bug 95366 - FILEOPEN: DOCX Picture Fill in shape not visible (Office 2007 / VML import )
Summary: FILEOPEN: DOCX Picture Fill in shape not visible (Office 2007 / VML import )
Status: RESOLVED DUPLICATE of bug 78749
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: Object-Fill DOCX-Images OOXML-2007 VML-Shapes
  Show dependency treegraph
 
Reported: 2015-10-27 17:36 UTC by mcjarod
Modified: 2020-09-02 16:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
7 pages have images (1.09 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-10-27 17:36 UTC, mcjarod
Details
screenshots as I see in MS Word. (312.36 KB, image/jpeg)
2015-10-27 17:36 UTC, mcjarod
Details
Stripped Down Word 2007 Bug Doc Showing Fill Issue (273.09 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-12-08 23:37 UTC, Luke
Details
Word 2013 DrawingML version works as expected (814.38 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-12-08 23:39 UTC, Luke
Details
The stripped down image in 7.0 bibisect (272.46 KB, image/png)
2020-09-02 16:41 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mcjarod 2015-10-27 17:36:10 UTC
Created attachment 120009 [details]
7 pages have images

I have a problem to display images and blank pages appear an image of the second page is lost in the page 5 an empty page appear . Attached is a part of the file.
Comment 1 mcjarod 2015-10-27 17:36:49 UTC
Created attachment 120010 [details]
screenshots as I see in MS Word.
Comment 2 Buovjaga 2015-11-03 09:35:03 UTC
Confirmed the picture in the circle on page two is not visible.
I also see the empty page 5.

Please create a new report for the empty page 5 and add a comment here to let us know.

You can reference your attachments in the new report by saying: attachment 120009 [details] and attachment 120010 [details]. They will be automatically linked to your old attachments.

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)

Version: 5.1.0.0.alpha1+
Build ID: 37d41674c2b1a706c95c2c326cbfbd06b0c1a655
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-02_00:13:27
Locale: fi-FI (fi_FI)
Comment 3 Cor Nouws 2015-12-02 15:21:28 UTC
already a problem in 3.3.0 (that makes a total mess of the document, buy the way) so this never worked.

Thanks mcjarod for these nice examples of possible further improvements :) !
Comment 4 Telesto 2016-12-03 19:14:15 UTC
Confirming with:
Version: 5.4.0.0.alpha0+
Build ID: 33f5bc54aaa7fe7aa9335726e30f9c349155e04d
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-12-01_23:21:05
Locale: nl-NL (nl_NL); Calc: CL
Comment 5 Cor Nouws 2016-12-04 10:47:38 UTC
(component Filters and Storage is for more generic issues in that area.
document import/export issues belong under the related component, in this case Writer)
Comment 6 Luke 2016-12-08 23:37:13 UTC
Created attachment 129413 [details]
Stripped Down Word 2007 Bug Doc Showing Fill Issue
Comment 7 Luke 2016-12-08 23:39:07 UTC
Created attachment 129414 [details]
Word 2013 DrawingML version works as expected
Comment 8 Luke 2017-12-05 22:07:04 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2018-12-06 03:57:53 UTC Comment hidden (obsolete)
Comment 10 Luke 2018-12-06 16:44:01 UTC
Still reproducible with Version: 6.3.0.0.alpha0+ (x64)
Build ID: 0abce68927f45673b73d8f806e108a51a36fb543
Comment 11 NISZ LibreOffice Team 2020-09-02 16:41:02 UTC
Created attachment 165037 [details]
The stripped down image in 7.0 bibisect

This looks good now since:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9283cd9e13cd3e0dd7d6b831d930128931862a40

author	Attila Bakos <bakos.attilakaroly@nisz.hu>	2020-04-08 14:50:07 +0200
committer	László Németh <nemeth@numbertext.org>	2020-04-20 10:55:53 +0200

tdf#78749 DOCX: import VML background image
Comment 12 NISZ LibreOffice Team 2020-09-02 16:46:39 UTC
Thanks Attila for fixing this!

*** This bug has been marked as a duplicate of bug 78749 ***