Bug 95806 - FILEOPEN: DOCX import: strange layout problem with table in footnote
Summary: FILEOPEN: DOCX import: strange layout problem with table in footnote
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: compatibilityMode14 target:7.2.0
Keywords: filter:docx
: 104422 125301 (view as bug list)
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2015-11-13 22:06 UTC by Andras Timar
Modified: 2021-07-05 07:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bugdoc (DOCX) (16.51 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-11-13 22:06 UTC, Andras Timar
Details
bugdoc compared in MSO and LO (59.96 KB, image/png)
2021-03-29 15:26 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2015-11-13 22:06:58 UTC
Created attachment 120527 [details]
bugdoc (DOCX)

The attached DOCX document contains a simple table in a footnote. When the file is opened with LibreOffice, the table in footnote is not displayed correctly.  However, when user hovers the mouse over the footnote area, the table cells appear one by one, and finally the table is displayed correctly.
Comment 1 Cor Nouws 2015-11-14 09:18:49 UTC
same problem in 3.6.6
4.4.3 shows a different problem and 3.4.4 no table at all.
Comment 2 Cor Nouws 2015-11-14 09:24:53 UTC Comment hidden (obsolete)
Comment 3 Telesto 2016-12-06 23:13:13 UTC
Reproducible with:
Version: 5.4.0.0.alpha0+
Build ID: 2bad9f1cd8da0cd3d8ff33e875eaf10c1fd9d0bf
CPU Threads: 4; OS Version: Mac OS X 10.12.1; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-11-29_01:04:44
Locale: nl-NL (nl_NL.UTF-8); Calc: group
Comment 4 Telesto 2016-12-07 08:01:33 UTC
*** Bug 104422 has been marked as a duplicate of this bug. ***
Comment 5 QA Administrators 2018-01-26 03:27:17 UTC Comment hidden (obsolete)
Comment 6 Gellért Gyuris 2018-08-31 09:36:50 UTC
Reproducible with: 
Version: 6.1.0.3
Build ID: libreoffice-6.1.0.3-snap1
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: hu-HU (hu_HU.UTF-8); Calc: group threaded
Comment 7 Timur 2018-12-17 14:58:43 UTC
Repro 6.3+.
Comment 8 Timur 2019-05-15 10:44:30 UTC
*** Bug 125301 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2021-03-28 12:49:39 UTC
László Németh committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e11c51eefe8c3210cef2b5850f401ba67a401d01

tdf#95806 tdf#125877 tdf#141172 DOCX: fix tables in footnotes

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Timur 2021-03-29 15:26:33 UTC
Created attachment 170812 [details]
bugdoc compared in MSO and LO

Here is a comparison after round-trip. 
Table is better, immediate appearance instead of gradual, somewhat different width, additional lines after table.
Not sure if something can be done for those lines, I will not open a bug.
Comment 11 Timur 2021-03-29 15:50:48 UTC
Extra line could be bug 132611.
Comment 12 László Németh 2021-04-06 08:20:17 UTC
(In reply to Timur from comment #10)
> Created attachment 170812 [details]
> bugdoc compared in MSO and LO
> 
> Here is a comparison after round-trip. 
> Table is better, immediate appearance instead of gradual, somewhat different
> width, additional lines after table.
> Not sure if something can be done for those lines, I will not open a bug.

@Timur: thanks for the verification and finding the report about the remaining problem.
Comment 13 NISZ LibreOffice Team 2021-07-05 07:51:04 UTC
Verified in:
Version: 7.3.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 0afa7e64d547a8f2a48402660acf5c95a468a0ab
CPU threads: 4; OS: Windows 10.0 Build 17134; UI render: Skia/Raster; VCL: win
Locale: hu-HU (hu_HU); UI: hu-HU
Calc: threaded