Bug 96239 - FORMATTING Area Fill acting silly: stays None despite selection
Summary: FORMATTING Area Fill acting silly: stays None despite selection
Status: RESOLVED DUPLICATE of bug 96119
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.0.beta1
Hardware: x86 (IA32) Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-12-04 10:23 UTC by Buovjaga
Modified: 2015-12-04 15:46 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2015-12-04 10:23:22 UTC
1. Writer - Format - Page - Area - Fill from None to Color or any other selection. 
2. Nothing happens.
3. Switch to another tab and back.
4. You see the colors, but the dropdown still says None.
5. You can only get the color selection to take effect, if you press OK while in some other tab than Area.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: 81fa5340191baf8687f9c82f1f414f5afc86b529
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-03_21:19:19
Locale: fi-FI (fi_FI)

Also seen with build from 11-28.
Comment 1 m.a.riosv 2015-12-04 14:16:25 UTC
Reproducible:
Win7x64
Version: 5.1.0.0.beta1-buildfix1 (x64)
Build ID: 13010a13177025f633c9b85adcb3edf6920e44e3
Threads 4; Ver: Windows 6.19; Render: GL; 

but not in:
Version: 5.1.0.0.alpha1 (x64)
Build ID: 0b48731919433e46e4fda7e5a5ca27c08c28b981
Comment 2 Buovjaga 2015-12-04 14:33:05 UTC
Hmm.. I marked it as minor as we can still set the color in an admittedly silly way.

While poking in the code, might be worth looking at bug 83904
Comment 3 m.a.riosv 2015-12-04 14:58:30 UTC
Not reproducible with:
Version: 4.4.7.2 Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Version: 5.0.4.1 (x64) Build ID: 2def61bcbb29a7a8611b833682fe1291910b11ad

Reproducible with master:
Version: 5.2.0.0.alpha0+ (x64)
Build ID: a454a9b3ae0f6ab81012fbef7b3ff6f0f44bf6cb
Threads 4; Ver: Windows 6.19; Render: GL; 

I have just verify that also affect to Area for Paragraph Style.
Even worse seems all drop-down selection boxes have the same issue, included the sidebar.
Enable/disable OpenGL, have not effect on the issue.

The issue is not only for Writer but the whole LibreOffice.
So for me a blocker.
Comment 4 Regina Henschel 2015-12-04 15:46:12 UTC

*** This bug has been marked as a duplicate of bug 96119 ***