Download it now!
Bug 96119 - Cannot select item with mouse in any combobox / drop down menu
Summary: Cannot select item with mouse in any combobox / drop down menu
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: x86 (IA32) Windows (All)
: highest critical
Assignee: Juergen Funk (CIB)
URL:
Whiteboard: target:5.2.0 target:5.1.0.2
Keywords: regression
: 96118 96165 96194 96239 96240 96260 96351 96525 96632 96633 96654 96665 96668 96728 96958 96960 97069 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-28 19:53 UTC by Regina Henschel
Modified: 2016-10-25 19:11 UTC (History)
29 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2015-11-28 19:53:55 UTC
Start Writer. Open the drop-down list "style" in the Formatting toolbar. Click an item, e.g. Title.
Expected behavior: The selected style is applied to the current paragraph.
Seen behavior: Nothing happens, the same style is selected as before.

I see the same problem in Calc. I see the same problem with the lists: .uno:GrafMode, .uno:XLineStyle, .uno:FillColor, .uno:FillStyle, .uno:CharFontName, Toolbar selection in Customize dialog. There are likely others.

I see the error in Version: 5.2.0.0.alpha0+
Build-ID: a8860122fecbaa932a48f41a38077f621275be9d
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-27_10:34:00
Gebietsschema: de-DE (de_DE)

It was OK in Version: 5.1.0.0.alpha1+
Build ID: f271602f7193ddf584ea58dc6a468e6842d0781e
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-08_22:37:35
Locale: de-DE (de_DE)
Comment 1 Jacques Guilleron 2015-11-29 08:51:12 UTC
Hi Regina,

I reproduce with
LO 5.2.0.0.alpha0+ Build ID: 03c37cee476d14d1d8644ccc7ea5c69d74d9c7f9
Threads 2; Ver: Windows 6.1; Render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2015-11-28_00:15:51
Locale: fr-FR (fr_FR)
Windows 7 Home.
Worked with
LO 5.1.0.0.alpha1+ Build ID: f6bc5b79c31225c02e9500d0ced4bd26f998f82b
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-24_01:07:47
Locale: fr-FR (fr_FR)
Comment 2 Maxim Monastirsky 2015-12-01 08:22:51 UTC
*** Bug 96165 has been marked as a duplicate of this bug. ***
Comment 3 Maxim Monastirsky 2015-12-01 08:25:55 UTC
Seems to affect *any* comboxbox in the app.
Comment 4 Laurent BP 2015-12-01 20:19:40 UTC
It was OK with Version: 5.1.0.0.alpha1+
Build ID: 229583f298b9de05e1ad1727e233d597995099e3-GL
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-11-22_23:09:05
Locale: fr-FR (fr_FR)
Comment 5 Jacques Guilleron 2015-12-02 08:12:25 UTC
*** Bug 96194 has been marked as a duplicate of this bug. ***
Comment 6 Regina Henschel 2015-12-04 15:46:12 UTC
*** Bug 96239 has been marked as a duplicate of this bug. ***
Comment 7 Regina Henschel 2015-12-04 15:47:59 UTC
*** Bug 96240 has been marked as a duplicate of this bug. ***
Comment 8 baffclan 2015-12-05 11:13:30 UTC
*** Bug 96260 has been marked as a duplicate of this bug. ***
Comment 9 k-j 2015-12-06 15:36:33 UTC
I can reproduce the bug in 5.1.0.0.beta2 (x64), WIN10
Comment 10 ribotb 2015-12-07 08:45:09 UTC
Hi,

This bug is very annoying, it also affects the drop-down lists in Base forms.
Still present in 5.1.0.0.beta2 Win7/x86

Bernard
Comment 11 Jared 2015-12-07 21:48:49 UTC
similar issue when attempting to select a different color palette from the drop down in font or highlight color tools.
Comment 12 Kevin Suo 2015-12-08 01:10:28 UTC
A "workaround" is to use your UP/DOWN key + ENTER to do the selection.
Comment 13 yanjingtao 2015-12-08 02:26:03 UTC
Hi,
   It reproduce in every combobox where I have tried, "Open Remote Dialog", "Font List", "Font Size", "Style List", Setting's combobox etc.


Version: 5.1.0.0.beta2 (x64)
Build ID: 53054959a12edc6510f51b94ddc9b73d27aedaf6
Threads 8; Ver: Windows 6.1; Render: GL;
Comment 14 Maxim Monastirsky 2015-12-09 11:33:51 UTC
*** Bug 96351 has been marked as a duplicate of this bug. ***
Comment 15 Juergen Funk (CIB) 2015-12-13 23:34:10 UTC
I want fix this, i think monday evening
Comment 16 Joel Madero 2015-12-14 15:18:09 UTC
Is a bibisect really needed here? If not - please remove it from the keywords. If so, just let me know.
Comment 17 Juergen Funk (CIB) 2015-12-14 22:12:39 UTC
this commit has make the problem, the removing of the SALEVENT_MOUSEACTIVATE

   commit dd351dd728687cffe432ce0ec9367ceb80e097fb 
   Author: Noel Grandin <noel@peralex.com> 
   Date: Tue Nov 24 08:50:39 2015 +0200 
   loplugin:unusedfields in vcl/ and 
   remove the unused SALEVENT_MOUSEACTIVATE stuff 

Without of there, when click in the opened list-box it send first the "PreNotify" with "MouseNotifyEvent::LOSEFOCUS" http://opengrok.libreoffice.org/xref/core/vcl/source/control/lstbox.cxx#940 and that close the listbox. 
After that, it send the mouse-event to a closed window http://opengrok.libreoffice.org/xref/core/vcl/source/window/winproc.cxx#354 (get a nullptr), that is the reason why the Listbox not get the mouse-click. 
With this patch, first send the mouse-click and then the "PreNotify"
Comment 18 Juergen Funk (CIB) 2015-12-14 22:14:12 UTC
forget my commit, now here
https://gerrit.libreoffice.org/#/c/20708/
Comment 19 Commit Notification 2015-12-15 06:27:47 UTC
Juergen Funk committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8a86d673140febc39be2044d2feb7c28fd307aa0

tdf#96119 Cannot select item with mouse in any combobox / drop down menu

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Maxim Monastirsky 2015-12-15 18:56:25 UTC
Hi Juergen,

Thank you for taking care of this bug. Please commit the patch also to 5-1 branch, which is also affected. Thanks!
Comment 21 Jean-Baptiste Faure 2015-12-16 07:53:00 UTC
*** Bug 96525 has been marked as a duplicate of this bug. ***
Comment 22 Juergen Funk (CIB) 2015-12-16 11:07:14 UTC
Hi Maxim look here https://gerrit.libreoffice.org/#/c/20734/
port to LO5.1 done
Comment 23 Commit Notification 2015-12-16 12:22:00 UTC
Juergen Funk committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=04f7270236ddac1d02187d5a8c24ed70000c73a5&h=libreoffice-5-1

tdf#96119 Cannot select item with mouse in any combobox / drop down menu

It will be available in 5.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Maxim Monastirsky 2015-12-17 09:04:09 UTC
*** Bug 96118 has been marked as a duplicate of this bug. ***
Comment 25 Maxim Monastirsky 2015-12-17 09:05:00 UTC
Thanks!
Comment 26 Regina Henschel 2015-12-17 14:38:10 UTC
It works now in Version: 5.1.0.1.0+
Build-ID: 51a1b41ab4a840544e5454d1d4234b443edd5466
Threads 4; Ver: Windows 6.1; Render: GL; 
TinderBox: Win-x86@62-merge-TDF, Branch:libreoffice-5-1, Time: 2015-12-17_11:44:49
Gebietsschema: de-DE (de_DE)
Comment 27 Maxim Monastirsky 2015-12-20 21:35:04 UTC
*** Bug 96632 has been marked as a duplicate of this bug. ***
Comment 28 Maxim Monastirsky 2015-12-20 21:59:16 UTC
*** Bug 96633 has been marked as a duplicate of this bug. ***
Comment 29 Maxim Monastirsky 2015-12-22 00:01:14 UTC
*** Bug 96654 has been marked as a duplicate of this bug. ***
Comment 30 Maxim Monastirsky 2015-12-22 11:26:03 UTC
*** Bug 96665 has been marked as a duplicate of this bug. ***
Comment 31 m.a.riosv 2015-12-26 17:53:44 UTC
*** Bug 96728 has been marked as a duplicate of this bug. ***
Comment 32 Maxim Monastirsky 2016-01-08 12:45:00 UTC
*** Bug 96958 has been marked as a duplicate of this bug. ***
Comment 33 Jean-Baptiste Faure 2016-01-09 13:40:39 UTC
*** Bug 96960 has been marked as a duplicate of this bug. ***
Comment 34 Luke 2016-01-11 01:11:19 UTC
It seems the fix for Windows has broken drop down boxes for Linux. See Bug 97032
Comment 35 Óvári 2016-01-11 01:22:26 UTC
*** Bug 97032 has been marked as a duplicate of this bug. ***
Comment 36 Óvári 2016-01-11 01:25:14 UTC
Added CC from bug 97032.
Comment 37 Maxim Monastirsky 2016-01-12 13:45:04 UTC
*** Bug 97069 has been marked as a duplicate of this bug. ***
Comment 38 f5d505f9 2016-01-15 17:47:11 UTC
*** Bug 96668 has been marked as a duplicate of this bug. ***
Comment 39 ryan.dugan 2016-02-10 22:16:43 UTC
How do I upgrade my version beyond 5.1.0.1? Its says I'm up to date. Windows 10. Thank you.
Comment 40 ryan.dugan 2016-02-10 22:17:44 UTC
How do I upgrade my version beyond 5.1.0.1? Its says I'm up to date. Windows
10. Thank you. Note that I'm asking because this bug is still affecting me.
Comment 42 ryan.dugan 2016-02-11 18:41:21 UTC
(In reply to Joel Madero from comment #41)
> 5.1.0.3 is here:
> http://downloadarchive.documentfoundation.org/libreoffice/old/latest/win/
> x86_64/

Thank you! Installed latest version and now this is fixed :)
Comment 43 Buovjaga 2016-02-11 19:07:35 UTC
Let's set it to verified while we're at it.