Bug 96609 - FORMATTING: Picture disappears between page breaks
Summary: FORMATTING: Picture disappears between page breaks
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Anchor-and-Text-Wrap Writer-Images Writer-Page-Break
  Show dependency treegraph
Reported: 2015-12-20 09:54 UTC by szotsaki
Modified: 2020-08-24 16:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

Bug example (467.35 KB, application/vnd.oasis.opendocument.text)
2015-12-20 09:54 UTC, szotsaki

Note You need to log in before you can comment on or make changes to this bug.
Description szotsaki 2015-12-20 09:54:27 UTC
Created attachment 121421 [details]
Bug example

Have the following page structure:

Page full with text
-- pagebreak --
Picture with caption anchored to page
-- pagebreak --
Page with text

Now if you enter a bit more text on the first page, the picture will disappear as soon as the text overflows to the second page.

Example attached.
Comment 1 Buovjaga 2015-12-23 19:13:25 UTC
Picture in the file was anchored To paragraph, not To page.

No matter how the picture was anchored, I could not get it to disappear.
I tried writing to the 1st page like in the bug description. I tried writing to the "WRITE HERE UNTIL THE TEXT FLOWS TO THE NEXT PAGE" part in the text.

Win 7 Pro 64-bit, Version: (x64)
Build ID: 2b9802c1994aa0b7dc6079e128979269cf95bc78
Locale: fi-FI (fi_FI)

Build ID: 18565a34d6e2768d70462f124c6d6972448efe22
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-23_11:31:57
Locale: fi-FI (fi_FI)
Comment 2 Buovjaga 2015-12-23 19:14:31 UTC
Oh yeah, sorry, with the caption it is anchored To page.
Comment 3 Buovjaga 2015-12-23 19:15:20 UTC
Are you using Linux? What distro and what desktop environment?
Comment 4 szotsaki 2015-12-29 16:19:14 UTC
Yes, I use openSUSE Leap 42.1, x64 with the latest KDE 5 from its repository: http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.1/.

When I get home, I'll check whether the versions around the LibreOffice packages are alright, but they should be.
Comment 5 raal 2016-01-02 10:57:27 UTC
Reproducible with Version:
Build ID: a27fac3b8f2bae18f62bab315051732df1bb29ab
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-01-01_05:08:26
Locale: cs-CZ (cs_CZ.UTF-8) and
LibreOffice 3.5.0 
Build ID: d6cde02
Comment 6 Julien Nabet 2016-05-06 19:12:44 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

Remark: the picture isn't lost, if you save and reopen the file, the image is still here.
Comment 7 Telesto 2016-12-20 14:05:01 UTC
Reproducible with 
Build ID: 53edf60c4ce6ed32f87471e018878c40b788005a
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-18_06:57:59
Locale: nl-NL (nl_NL); Calc: CL
Comment 8 szotsaki 2018-03-07 18:01:49 UTC
Reproducible with 
Build ID: f7f06a8f319e4b62f9bc5095aa112a65d2f3ac89
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: hu-HU (hu_HU); Calc: CL
Comment 9 QA Administrators 2019-03-08 03:39:50 UTC Comment hidden (obsolete)
Comment 10 Telesto 2020-08-18 07:07:17 UTC
No repro
Build ID: c01aa64b6c3d89ebe5fe69c28c7adb24eb85249c
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; VCL: osx
Locale: nl-NL (nl_NL.UTF-8); UI: en-US
Calc: threaded
Comment 11 Buovjaga 2020-08-18 13:53:42 UTC
szotsaki: as Telesto was able to see the problem in 2016, but not anymore, could you re-test?
Comment 12 szotsaki 2020-08-24 16:07:44 UTC
I retested it and I cannot reproduce it anymore with the following config:

Build ID: <buildversion>
CPU threads: 16; OS: Linux 5.8; UI render: default; VCL: kf5
Locale: hu-HU (hu_HU.UTF-8); UI: hu-HU
Calc: threaded
Comment 13 Buovjaga 2020-08-24 16:15:45 UTC
Fantastic news after 5 years :) Let's close.