Download it now!
Bug 99612 - Loss of all images
Summary: Loss of all images
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Image-Caching
  Show dependency treegraph
 
Reported: 2016-05-01 18:08 UTC by Bill
Modified: 2019-02-22 14:50 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bill 2016-05-01 18:08:55 UTC
It started with version 5.1.2.2 in win 10 x64 and continues to the 5.1.3.1
Loss of images in the document.
I am working on a long document, It started with text of 85 pages. I started to add png photos. About 30 photos,were included,  anchored to page, to paragraph, to character. Some with borders, and the majority with test written around them.
despite the difficulty on positioning, sticking mainly to the right side, not moving to the correct set position, they disappeared 4 times in the updated versions of the document as progressing. The relevant box in settings, is always checked, but the file from 18 mb was reduced to 500 kb, only with the frames of the photos appearing, but not including the photos.At least I did not have to import and re-calibrate each photo manually!I had to re-enter the photos using for comparison an older file,  but with not the same full content!
This happened 4 times.

I had the same problem with impress as well. At an international conference in Germany, where I was also suggesting the use of open source software, all my photos disappeared from my presentation. Only blank border lines, but no photos, I had to do the same work 3 times, including the legends of the photos that were lost!

I see on the net that a lot of people have the same problem for quite sometime. As the documents are sheared with other colleagues, they also loose photos. using other software, but also the photos are changing positions, making it very hard to use Libreoffice. Already I am asked to use the MS Office, for safety of not repeating the same job already done


The problem must be fixed as soon as possible. Otherwise a turn to the stupid Office will not be avoided!
Comment 1 Julien Nabet 2016-05-01 18:55:10 UTC
Michael: Could it be related to tdf#47148?
BTW, is there some project (like vclptr) to refactor images management?
Indeed, there are still many bugs linked to images.
So if it's not already the case, it should be an high priority.
Badfully, I'm not C++ expert but if I can contribute with janitorial/simple prepare work, no problem.
Comment 2 Michael Meeks 2016-05-02 04:45:49 UTC
Hi Julien - so - yes, in a nut-shell we need a similar work to the VclPtr cleanup here - so we have hard references on images instead of the current truck-load of lame heuristics and workarounds - with all the fragility they bring =)

For my part, the image loss problems I experienced in the past around impress are gone in ~5.0+ I think - so I'm interested to see a more recent duplicate here.

Bill - sorry about that; and thanks for filing - this is an inherited legacy issue we need to nail.
Comment 3 Julien Nabet 2016-05-06 14:56:48 UTC
From https://bugs.documentfoundation.org/show_bug.cgi?id=98686#c9:
"
I have used a hex inspector, and I have observed that the corresponding image file is corrupted. It is full of secuences like 00 FF 00 FF... or 33 66 99 CC FF."
Comment 4 Yousuf Philips (jay) (retired) 2016-10-18 02:53:20 UTC
@Meeks, @Julien: Setting this to NEEDINFO so its no longer unconfirmed, so please close if needed.
Comment 5 Michael Meeks 2016-10-18 07:57:10 UTC
This is un-related to VclPtr. We -need- a VclPtr -like- solution to this, but it is certainly not related; we already have a tracker for the mis-designed image lifecycle mess here; lets stick with that one.
Comment 6 Michael Meeks 2016-10-18 07:58:42 UTC
Bill - do you have any way to reproduce this ? we need concrete steps to do that - since it is really unclear how this happens and short of large-scale re-work of the whole image handling code, it would be nice to isolate and fix just this issue.
Comment 7 QA Administrators 2017-05-02 11:36:32 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2017-05-31 10:45:47 UTC Comment hidden (obsolete)
Comment 9 Yousuf Philips (jay) (retired) 2017-05-31 15:36:43 UTC
Meeks said this should be reopened and that there is a TDF tender set to fix this issue.

https://blog.documentfoundation.org/blog/2017/05/02/tender-improve-image-handling-libreoffice-201705-01/
Comment 10 Peter 2018-01-29 19:47:40 UTC
I found this bug report while searching for possible solutions to images disappearing in multiple documents (Draw, Writer) in recent months. Currently I am using LibreOffice 5.3.7.2 (x64) on Windows 10. It is very discouraging to open up a document and find broken links to images. On multiple occasions it has taken an hour or more of work re-inserting and re-creating images to get back to where the document is usable again. An inspection of the document renamed as a zip file shows images still existing inside the document in the Pictures directory.
Comment 11 Michael Meeks 2018-01-30 09:17:05 UTC
Sorry for the loss - Tomaz is actively working on this even now =) and no doubt watching this tracker carefully; my hope is to close all of the bugs there when that work is done but ... lets see ;-)
Comment 12 Michael Weghorn 2019-02-20 12:07:45 UTC
Is this bug here the same as bug 98686, which has now been marked fixed due to the image handling rework also mentioned here in comment 9?
Comment 13 Buovjaga 2019-02-20 14:58:33 UTC
(In reply to Michael Weghorn from comment #12)
> Is this bug here the same as bug 98686, which has now been marked fixed due
> to the image handling rework also mentioned here in comment 9?

Probably, so Bill and Peter might test with version 6.2.0.
Comment 14 Bill 2019-02-20 17:40:42 UTC
Since version 6.2, I have not encountered the same problem
I therefore consider the problem solved
Thank you all
Comment 15 Buovjaga 2019-02-20 17:43:43 UTC
Fantastic. Tweaking status to WFM.
Comment 16 Peter 2019-02-22 14:02:33 UTC
Recently I have been using the 6.1 series and yesterday updated to 6.2.0.3. Spot checks using 6.2.0.3 of some files that previously gave me trouble did not turn up any loss of graphics. I loaded the files and scrolled through the pages looking for broken image links. I made a few edits and went through multiple save-load cycles. Based on relatively limited testing I cannot prove that the problem is solved, but I am encouraged.
Comment 17 Michael Meeks 2019-02-22 14:50:17 UTC
Thanks for testing it Peter ! =)