Bug 97493 - Crash on creating new document
Summary: Crash on creating new document
Status: RESOLVED DUPLICATE of bug 96546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-01 23:17 UTC by Kurt Roeckx
Modified: 2016-02-12 17:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Roeckx 2016-02-01 23:17:51 UTC
Hi,

I tried the 5.1.0.1 rc version and it crashed on me, so I had to uninstall it and return back to some 5.0.X version.  I tried the 5.1.0.3 today and had the same problem.

It starts properly and shows me the preview of the previous documents I've opened.  But when I press calc or writer on the left side it's showing me something about a segfault and closes.  When I start it the next time it will actually show me a recovery window.

I'm testing it on windows 7 if that's relevant.


Kurt
Comment 1 m.a.riosv 2016-02-02 01:16:25 UTC
Please try resetting the user profile, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile
Usually it's enough renaming/deleting the file "user/registrymodifications.xcu",  it affect all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.
Comment 2 Kurt Roeckx 2016-02-03 21:44:24 UTC
I have HD2000 graphics, and see that there are some related bugs that this might be a duplicate of this.

In any case, I find those solution here unacceptable:
- Crash the first time, but then disable something the 2nd time.
- Tell people that they need to remove a working profile to be able to upgrade to a newer version.

If there is an OpenGL issue, it probably also shouldn't be segfaulting but recover in some sane way.

If the driver is really broken I suggest you start working on a blacklist, but I currently doubt that it's the driver.  In any case if you think it's the driver it would be nice if you could provide a simple test case.
Comment 3 Buovjaga 2016-02-10 18:38:37 UTC
(In reply to Kurt Roeckx from comment #2)
> I have HD2000 graphics, and see that there are some related bugs that this
> might be a duplicate of this.
> 
> In any case, I find those solution here unacceptable:
> - Crash the first time, but then disable something the 2nd time.
> - Tell people that they need to remove a working profile to be able to
> upgrade to a newer version.
> 
> If there is an OpenGL issue, it probably also shouldn't be segfaulting but
> recover in some sane way.
> 
> If the driver is really broken I suggest you start working on a blacklist,
> but I currently doubt that it's the driver.  In any case if you think it's
> the driver it would be nice if you could provide a simple test case.

Yep, I have HD3000 and this same issue.

There is already a blacklist.

We should probably close this as duplicate of bug 97458
Comment 4 Buovjaga 2016-02-11 08:10:13 UTC
Yep, I will close this as dupe.

Just turn off OpenGL: Tools - Options - LibO - View - Use OpenGL for all rendering

*** This bug has been marked as a duplicate of bug 97458 ***
Comment 5 Michael Meeks 2016-02-11 17:57:58 UTC
Lets aggregate these all in one place too.

Kurt - could you attach some details from your user-profile's cache directory - there should be a file there:

opengl_device.log.

Thanks !

*** This bug has been marked as a duplicate of bug 96546 ***
Comment 6 Kurt Roeckx 2016-02-12 17:44:35 UTC
The file contains:
DriverVersion: 9.17.10.4229
DriverDate: 5-26-2015
DeviceID: PCI\VEN_8086&DEV_0102&SUBSYS_844D1043&REV_09
AdapterVendorID: 0x8086
AdapterDeviceID: 0x0102
AdapterSubsysID: 0x844d1043
DeviceKey: System\CurrentControlSet\Control\Video\{F2C7F4E6-1F50-4FC5-B757-C0D43ED2F953}\0000
DeviceString: Intel(R) HD Graphics


I've also tried it with the 5.1 release, still have the same issue.  I've also tried this a 2nd time and I still get the same error.  So I can't use the 5.1 release currently.