Bug 97644 - Next to complete fail after switching on 'Use OpenGL for all rendering'.
Summary: Next to complete fail after switching on 'Use OpenGL for all rendering'.
Status: RESOLVED DUPLICATE of bug 96546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-02-08 12:19 UTC by Wolfgang Jäger
Modified: 2016-02-15 23:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
the mentioned file supplied by the user 'Lem3' in the mentioned thread; renamed by 'Lupp' (28.50 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-02-08 12:19 UTC, Wolfgang Jäger
Details
Device log as requested by @Beluga (314 bytes, text/plain)
2016-02-15 22:10 UTC, Wolfgang Jäger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Jäger 2016-02-08 12:19:55 UTC
Created attachment 122439 [details]
the mentioned file supplied by the user 'Lem3' in the mentioned thread; renamed by 'Lupp'

For some issues I regularly keep OpenGL rendering not selected for some time now.
Trying to help a user with an issue described by this thread: http://en.libreofficeforum.org/node/10136 
I had to switch on OpenGL rendering. This resulted in a mess.

Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
Locale: de-DE (de_DE)
(In addition) UI language: English (Great Britain)

Steps to reproduce the problem (uncertain; I did not try a second time.)
1. Have OpenGL switched off. (V5.1.0.3 on Win 8.1
2. Open the attached file I downloded myself from the link in post #5 of the mentioned thread.
3. (At least I did choosing column N: Check the claims of the poster; negative!)
4. Select OpenGL rendering under 'View' since this was the poster's setting.
5. Close the document and close LibO.
6. Doubleclick the downloaded example file.
Expected: LibO should start, open, and render the contained Document.
Observed: 
LibO starts (partially?). 
The Window title is set to the filename.
The document is not rendered (no view of it at all).
No menu is present. No PickList preview. No lefthand column with controls.
7. Reset the user profile
Expected: Problem solved so far.
Observed: No remedy!
8. Repair the LibO installation. Some extra steps. Restore your user profile specifics.

In my case: Success, fortunately.
Comment 1 Buovjaga 2016-02-11 10:15:18 UTC
Could enable OpenGL one more time and launch LibreOffice? Then you could paste here the contents of the file:
C:\Users\user\AppData\Roaming\LibreOfficeDev\4\cache\opengl_device.log
Comment 2 Wolfgang Jäger 2016-02-15 15:30:13 UTC
See also bug#97849 and forum topic http://en.libreofficeforum.org/node/12674.
Comment 3 Buovjaga 2016-02-15 15:39:19 UTC
(In reply to Wolfgang Jäger from comment #2)
> See also bug#97849 and forum topic http://en.libreofficeforum.org/node/12674.

Still waiting for you opengl log file info :)
Comment 4 V Stuart Foote 2016-02-15 15:58:41 UTC
This is a failure in our OpenGL blacklisting mechanism. You should not have been able to enable OpenGL with your GPU/driver combination.

Resolving Duplicate of bug 96546 -- please post your opengl_device.log details there.
Comment 5 V Stuart Foote 2016-02-15 15:59:06 UTC

*** This bug has been marked as a duplicate of bug 96546 ***
Comment 6 Wolfgang Jäger 2016-02-15 22:10:33 UTC
Created attachment 122667 [details]
Device log as requested by @Beluga
Comment 7 V Stuart Foote 2016-02-15 23:20:47 UTC
Listed drivers for nVidia GTX 650
DriverVersion: 9.18.13.3165
DriverDate: 10-23-2013

failed black listing in

http://opengrok.libreoffice.org/xref/core/vcl/opengl/opengl_blacklist_windows.xml

this is issue bug 96546