Bug 97668 - Java 1.8, Mac 10.10 incorrect JDK path for SDK - scripts look for "Commands/javac"
Summary: Java 1.8, Mac 10.10 incorrect JDK path for SDK - scripts look for "Commands/j...
Status: RESOLVED DUPLICATE of bug 96163
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.4.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-02-09 00:25 UTC by Alister Pillow
Modified: 2016-06-14 11:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alister Pillow 2016-02-09 00:25:07 UTC
When running setsdkenv_unix initially, the script refused to accept a valid JDK 1.8 path (/Library/Java/JavaVirtualMachines/jdk1.8.0_45.jdk/Contents/Home - as reported by /usr/libexec/java_home)

The script checks for Commands/javac which does not exist. (javac is in $JAVA_HOME/bin/).

grep "Commands" configure.pl setsdkenv_unix.sh.in settings/settings.mk
configure.pl:    $main::OO_SDK_JAVA_BIN_DIR="Commands";
configure.pl:# prepare Java suggestion (cut bin or Commands directory to be in the root of the Java SDK)
setsdkenv_unix.sh.in:    javadir=Commands
settings/settings.mk:JAVABIN=Commands

To enable correct settings and then run "make", I had to comment out or change "Commands" to "bin".

This also applies to JDK 1.7.0_51
Comment 1 Uwe Altmann 2016-02-25 14:06:32 UTC
To add more: LO 5.1. Mac does not find (or at least show up in Preferences > Advanced) an installed JRE. Instad it complains at startup. "JRE is defective" - "LibreOffice requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under LibreOffice - Preferences - LibreOffice - Advanced."

On the same machine, LO 5.0.5.2 works on this as expected and shows the installed JRE.
@Allister: Is that the same problem? Are you shure about the version?
Comment 2 Alex Thurgood 2016-06-14 11:02:13 UTC

*** This bug has been marked as a duplicate of bug 96163 ***