Bug 96163 - LO51a1: On OSX installed Java 1.8 is not shown in Settings-Advanced-Java Options tab
Summary: LO51a1: On OSX installed Java 1.8 is not shown in Settings-Advanced-Java Opti...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha1
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
: 97668 98518 99012 100884 (view as bug list)
Depends on:
Blocks: Java-Runtime-JRE
  Show dependency treegraph
 
Reported: 2015-11-30 23:28 UTC by Martin Srebotnjak
Modified: 2016-10-16 12:01 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2015-11-30 23:28:21 UTC
On OSX 10.11.1 with Oracle Java 1.8 installed and using LO51a1:
when opening the LibreOfficeDev - Settings - LibreOfficeDev - Advanced under Java Options in the already installed Java the installed Oracle Java 1.8 is not listed, so it cannot be checked to be used by LO.

On the same system the LO 5.0.4.1 sees it and it can be selected and used.
Comment 1 Alex Thurgood 2015-12-01 08:03:20 UTC
@miles : are you talking about a JRE or a JDK ?

In my master build 5.2 alpha, LO sees my Oracle java.jar installed in :

/Library/Java/JavaVirtualMachines/jdk1.8.0_60.jdk/Contents/Home/jre/bin

this is where the JDK is installed to (which contains a JRE). If you have only installed a JRE, then try changing that for a JDK and report back.
Comment 2 Yvan Rose 2016-02-15 15:14:17 UTC
I just installed the JDK (as opposed to the JRE) and it fixed the issue, using LO 5.1 on El Capitan. Some documentation of this would be nice, though, unless you can get the JRE to appear, as this is what most people will get to install, in line with the label used in the Advanced preference pane. Many thanks!
Comment 3 Alex Thurgood 2016-03-11 10:17:03 UTC
Per comment 2 WFM
Comment 4 Cor Nouws 2016-03-11 10:26:25 UTC
(In reply to Yvan Rose from comment #2)

> [...] Some documentation of this would be nice,
> though, unless you can get the JRE to appear, as this is what most people
> will get to install, in line with the label used in the Advanced preference
> pane. Many thanks!

Good idea, I think Yvan.
Do you have a clear/finished proposal for that, or is there an issue for this?

Cheers - Cor
Comment 5 Alex Thurgood 2016-03-11 11:35:20 UTC
*** Bug 98518 has been marked as a duplicate of this bug. ***
Comment 6 Larry Gusaas 2016-03-11 17:49:35 UTC Comment hidden (me-too)
Comment 7 V Stuart Foote 2016-03-12 16:38:06 UTC
As work around for Oracle/Apple NOTOURBUG bug 74877 LibreOffice has incorporated Patrick Luby's patches developed for NeoOffice that by-passes OS X JNI calls, but that now require use of the JRE bundled with a JDK install.

We could NOTOURBUG this or, WONTFIX it as I just did.  The workaround of a JDK install on OS X is sufficient until Apple and/or Oracle resolve.

=-ref-=

http://bugs.java.com/bugdatabase/view_bug.do?bug_id=7131356

http://bugs.java.com/bugdatabase/view_bug.do?bug_id=8024281
Comment 8 Alex Thurgood 2016-05-09 06:39:49 UTC
*** Bug 99012 has been marked as a duplicate of this bug. ***
Comment 9 Alex Thurgood 2016-06-14 11:02:13 UTC
*** Bug 97668 has been marked as a duplicate of this bug. ***
Comment 10 V Stuart Foote 2016-07-13 12:36:09 UTC
*** Bug 100884 has been marked as a duplicate of this bug. ***