Download it now!
Bug 98167 - CONFIGURATION: Ctrl+Alt+F footnote shortcut only works with left ALT key
Summary: CONFIGURATION: Ctrl+Alt+F footnote shortcut only works with left ALT key
Status: RESOLVED DUPLICATE of bug 97908
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators Footnote-Endnote
  Show dependency treegraph
 
Reported: 2016-02-24 22:39 UTC by gpbarentsen
Modified: 2017-08-06 02:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gpbarentsen 2016-02-24 22:39:15 UTC
Under the Keyboard tab in Tools>Customize, I configured Ctrl+Alt+F as a shortcut for inserting a footnote in a Writer document.  This shortcut works, but ONLY with the left ALT key; no combination using the right ALT key will work.

Just FYI, I reported this same bug in a previous version (can't remember which one).
Comment 1 Óvári 2016-02-25 09:19:18 UTC
On some keyboard layouts, the left is called ‘Alt’ and the right is call ‘Alt Gr’.
https://en.wikipedia.org/wiki/File:Hungarian_keyboard_layout.svg
For such layout where the keys have different names, they are different functions.

Even English keyboards vary.
https://en.wikipedia.org/wiki/British_and_American_keyboards

If you require the left and the right Alt work as the same key, try using the United States keyboard layout (not to be confused with the US International keyboard layout).

Setting as status as WorksForMe.

If the problem still persists, please set status to Unconfirmed and provide additional information. Thank you
Comment 2 gpbarentsen 2016-02-25 22:05:49 UTC
How does one change keyboard layout?  Is it the language setting in the bottom status line?  I have been using English (USA) for a long time, and especially confusing is the fact that both Alt keys WORKED for this shortcut a couple of revisions ago.
Comment 3 Óvári 2016-02-26 06:53:04 UTC
(In reply to gpbarentsen from comment #2)
> How does one change keyboard layout?
It depends on your operating system.
Have you googled, or otherwise, "How to change your keyboard layout"
When you write a bug report it may help if you state each time:
a) Your operating system
b) Which version of LibreOffice you are using
You can copy the information from LibreOffice's menu bar:
Help → About LibreOffice
Alt works correctly is:
Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 2; OS Version: Windows 6.29; UI Render: default; 
Locale: en-AU (en_AU)

> Is it the language setting in the bottom status line?
No, this is the language the spelling checker, grammar, etc uses.

All the best
Comment 4 gpbarentsen 2016-02-27 21:01:08 UTC
I did Google it, but wasn't sure if it was LO or OS.  And I understand the in-progress nature of LO but changing OS settings to troubleshoot one program is never the best option, since it can affect other apps on a system.

I also didn't set OS as it happens across two Windows platforms, but I noticed there is a Windows (all) setting so I have used that.

Other information:

Version: 5.1.0.3
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Windows 6.2; UI Render: GL; 
Locale: en-US (en_CA)

Hope this helps!
Comment 5 gpbarentsen 2016-02-27 21:29:15 UTC
Ok...I confirmed that my keyboard is US keyboard layout.  Even changed my laptop's OS language to English (Ausralia).  But my locale reads the same as in the previous comment of mine and the problem persists.
Comment 6 Buovjaga 2016-03-09 15:31:15 UTC

*** This bug has been marked as a duplicate of bug 97908 ***