Bug 98288 - Enter edit mode after using Ctrl+; and Ctrl+Shift+; shortcuts
Summary: Enter edit mode after using Ctrl+; and Ctrl+Shift+; shortcuts
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2016-03-01 00:41 UTC by Óvári
Modified: 2016-03-01 20:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Óvári 2016-03-01 00:41:11 UTC
1. Open Calc
2. Press        :   Ctrl+;
   Inserts the current date
3. Press        :   SpaceBar
   Incorrectly removes the current time
   Should append a space after current date
4. Press        :   Ctrl+:  (Ctrl+Shift+;)
   Appends the current time

Result shown    :   11:33:27
Expected result :   01/03/2016 11:33:27

Blocks          :   Bug 98259
See Also        :   Bug 88027

Thank you

Version: 5.1.0.3 (x64)
Build ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 2; OS Version: Windows 6.29; UI Render: default; 
Locale: en-AU (en_AU)
Comment 1 m.a.riosv 2016-03-01 01:40:35 UTC

*** This bug has been marked as a duplicate of bug 88027 ***
Comment 2 Yousuf Philips (jay) (retired) 2016-03-01 04:01:14 UTC
So i see this behaviour working Excel because it enters edit mode after either of the shortcuts. Gnumeric also entered edit mode, while Google Docs didnt enter edit mode.

So the question is, do we want to imitate this Excel functionality?
Comment 3 Óvári 2016-03-01 07:09:57 UTC
(In reply to Yousuf (Jay) Philips from comment #2)
> So the question is, do we want to imitate this Excel functionality?

Yes please as it speeds up manual data entry. Thanks
Comment 4 Eike Rathke 2016-03-01 12:38:56 UTC
Actually not. Or it depends on the workflow. Note also that the shortcuts behave differently if executed on a cell (not in edit mode) or within a cell (in edit mode). I'd rather prefer if we did not mimic the Excel behavior here.

On a cell with Ctrl+; the current date is written to the cell and the date format is applied. A Shift+Ctrl+; adds the current time to an existing date and a date+time format is applied. If there was no date then just the current time is written and a time format applied. Ctrl+; on a cell with an existing time adds the date to the time and a date+time format is applied.

Note that Excel does not add a date or time to an existing time or date, it overwrites the data instead. Which likely is the reason that it places the cell into edit mode so that after Ctrl+; it adds an additional blank and the user can hit Shift+Ctrl+; to get a full date+time value, which is the only way in Excel to accomplish this. Calc does not need the edit mode for this.

In Calc, placing the cell into edit mode after all these operations would require an additional Enter to use the data as is.

In a cell already in edit mode just the date or time are inserted at the current cursor position. The date and/or time format would only be applied if no additional data is entered, similar to as if the user manually entered a date/time in the cell. This is the same as in Excel.
Comment 5 Eike Rathke 2016-03-01 12:43:05 UTC
(In reply to Óvári from comment #0)
> Expected result :   01/03/2016 11:33:27

So actually for that just hit the sequence  Ctrl+;  Shift+Ctrl+;
Comment 6 Yousuf Philips (jay) (retired) 2016-03-01 19:32:39 UTC
(In reply to Eike Rathke from comment #5)
> (In reply to Óvári from comment #0)
> > Expected result :   01/03/2016 11:33:27
> 
> So actually for that just hit the sequence  Ctrl+;  Shift+Ctrl+;

I think its F2, Ctrl+;, Space, Shift+Ctrl+; :D
Comment 7 Eike Rathke 2016-03-01 19:52:01 UTC
No, only if you want to do it complicated ;) ... note what I wrote in comment 4.
On any cell without entering edit mode (F2), hit  Ctrl+;  Shift+Ctrl+;
Comment 8 Óvári 2016-03-01 20:04:49 UTC
(In reply to Eike Rathke from comment #5)
> (In reply to Óvári from comment #0)
> > Expected result :   01/03/2016 11:33:27
> 
> So actually for that just hit the sequence  Ctrl+;  Shift+Ctrl+;

Thank you Eike. Calc will save even more time with manual data entry.
Comment 9 Yousuf Philips (jay) (retired) 2016-03-01 20:06:33 UTC
(In reply to Eike Rathke from comment #7)
> No, only if you want to do it complicated ;) ... note what I wrote in
> comment 4.
> On any cell without entering edit mode (F2), hit  Ctrl+;  Shift+Ctrl+;

Sorry my bad. :D