Download it now!
Bug 99226 - PDF export of ODP with EMF image: crashes or (headless mode) the table misses text
Summary: PDF export of ODP with EMF image: crashes or (headless mode) the table misses...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
5.1.1.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:emf, filter:pdf, regression
Depends on:
Blocks: PDF-Export EMF-WMF
  Show dependency treegraph
 
Reported: 2016-04-11 14:31 UTC by Tobias Burnus
Modified: 2017-02-06 14:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test.ods - convert to PDF and check for LO crashes or missing text in the .pdf file (19.02 KB, application/vnd.oasis.opendocument.presentation)
2016-04-11 14:31 UTC, Tobias Burnus
Details
export from LO 5.2 (140.24 KB, application/x-download)
2016-04-20 21:01 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Burnus 2016-04-11 14:31:07 UTC
Created attachment 124255 [details]
test.ods - convert to PDF and check for LO crashes or missing text in the .pdf file

I have two issues related to a presentation (originally PPTX, reduced example is ODP) with an EMF image. The EMF shows a table with text.

Used version is LibreOffice 5.1.1.3 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d (as downloaded) on CentOS 6 and CentOS7.


(a) Using
  soffice --headless  --invisible  --convert-to pdf test.odp
the file is converted to PDF, but the table lacks the text - only the border and the background of the cells is shown. (Missing text might or might not be related to bug 92849 and bug 95584.)


(b) Using
  soffice  --convert-to pdf test.odp
it fails with: "X IO Error" and no PDF is generated.
(Vaguely related to bug 63324)


(c) Opening the file in GUI mode looks good, but at "Export to PDF", LO also crashes with "X IO Error"


(d) As with (c), using 4.3.7.2 of/on CentOS 7.2 and 4.2.8.2 on/of CentOS 6.2, also fails with "X IO Error"; oddly, it those also fail with "--headless --invisible".


The headless part [i.e. (a)] is a REGRESSION to LO 5.0: Looking at older conversions, on CentOS 6.x (version = what's listed as producer): "LibreOffice 4.0" and "LibreOffice 5.0" is fine, "LibreOffice 5.1" lacks the text in the table.
Comment 1 Tobias Burnus 2016-04-11 14:37:37 UTC
If I open the attached file in LO 5.1.0.3 on Windows 7, it shows up correct - and it does not crash when exporting to PDF in the GUI.

However: While in step (a) [Linux only] before and in GUI mode (Linux and Windows), the table EMF is about 1/3 of the page width wide, in the LO/Windows-exported PDF file, it is shrunken to about a 11th of the page width!
Comment 2 Tobias Burnus 2016-04-14 15:28:52 UTC
(In reply to Tobias Burnus from comment #1)
> If I open the attached file in LO 5.1.0.3 on Windows 7 [...] in the
> LO/Windows-exported PDF file, it is shrunken to about a 11th of the page
> width!

That issue of comment 1 is seemingly fixed in LO 5.1.2.2/Windows.
Comment 3 raal 2016-04-20 21:01:50 UTC
Created attachment 124538 [details]
export from LO 5.2

(c) Opening the file in GUI mode looks good, but at "Export to PDF", LO also crashes with "X IO Error"

No crash with Version: 5.2.0.0.alpha0+
Build ID: 170a473597534cf59887b1d817538322e7039862
CPU Threads: 4; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-04-19_00:41:06
Comment 4 Tobias Burnus 2016-04-22 12:15:41 UTC
(In reply to Tobias Burnus from comment #0)
> Used version is LibreOffice 5.1.1.3 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
> (as downloaded) on CentOS 6 and CentOS7.

Now, I re-tried with 5.1.2.2 d3bf12ecb743fc0d20e0be0c58ca359301eb705f - and the result is the same.

> (a) Using soffice --headless  --invisible  --convert-to pdf test.odp
> the file is converted to PDF, but the table lacks the text

Remains an issue.


> (b) [...] (c) [...] crashes with "X IO Error"

seems to depend on the X server:
* "X IO Error" occurs using mobaXterm (which uses its Xorg X server) on Windows to ssh into the Linux machine
* The conversion works [no crash, text in the converted result] (cf. also comment 3) with a VNC server on CentOS 5 and ssh to another Linux machine, where one runs libreoffice.
Comment 5 Julien Nabet 2016-05-01 19:13:19 UTC
What option do you use in PDF export?

For the test, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#GNU.2FLinux) and give a new try?

Also, could you test on 1 machine only for the moment, then with other machines with ssh?

Finally, 1 bugtracker must correspond to 1 bug to avoid complicate bug management.
Comment 6 Buovjaga 2016-05-02 12:39:57 UTC
Tried a, b and c and no problems

64-bit, KDE Plasma 5
Build ID: 5.1.2.2 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 7 Tobias Burnus 2017-02-06 14:34:20 UTC
Mark as FIXED: Seems to be fixed in LO 5.2 (and remains fixed in 5.3 + today's MASTER).

LO 5.3 has a new, possibly related issue - but that's tracked in bug 105798.
Comment 8 Julien Nabet 2017-02-06 14:39:05 UTC
Since there's no specific fix, let's put this one to WFM.