Bug 99528 - Better handling for multiline tabs
Summary: Better handling for multiline tabs
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Samuel Mehrbrodt (allotropia)
URL:
Whiteboard: target:25.2.0
Keywords:
: 113418 (view as bug list)
Depends on:
Blocks: Dialog-UX Vertical-Tab-dialogs
  Show dependency treegraph
 
Reported: 2016-04-27 11:00 UTC by Samuel Mehrbrodt (allotropia)
Modified: 2024-06-21 14:21 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Paragraph style: Current layout (58.93 KB, image/png)
2016-04-27 11:00 UTC, Samuel Mehrbrodt (allotropia)
Details
Mockup: Vertical tabs for paragraph style dialog (25.90 KB, image/png)
2016-04-27 11:01 UTC, Samuel Mehrbrodt (allotropia)
Details
Character Style (47.23 KB, image/png)
2024-05-03 07:43 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Mehrbrodt (allotropia) 2016-04-27 11:00:46 UTC
Created attachment 124669 [details]
Paragraph style: Current layout

Currently we have some dialogs which have multiple rows of tabs, for example the "paragraph style" dialog.

I find it highly confusing to use this kind of tabs. As they are not in one row, it is hard to read all tabs to get a glance what tabs you have. Also when selecting a tab from the top, that row moves to the bottom, which is even more confusing, since the position of all tabs changes.

I have two ideas how to improve the situation:
1. Leave the tabs as they are (multiline), but don't switch rows when selecting a tab from the top.
2. Stop using multiline tabs at all and use vertical tabs instead (have them on the left).

Any thougts on this?
Comment 1 Samuel Mehrbrodt (allotropia) 2016-04-27 11:01:25 UTC
Created attachment 124670 [details]
Mockup: Vertical tabs for paragraph style dialog
Comment 2 Heiko Tietze 2016-04-27 12:37:54 UTC
The proposal was to introduce icon views instead of tabs. Looks tidy and modern with icons and enough white space. But I remember harsh criticism saying we cannot change all dialogs.

http://listarchives.libreoffice.org/global/design/msg07251.html
https://wiki.documentfoundation.org/Design/PropertyDialog 

An alternative is to just disable multiline tabs. In that case, arrows allow to navigate to the undisplayed tabs.
Comment 3 Samuel Mehrbrodt (allotropia) 2016-04-27 12:53:28 UTC
(In reply to Heiko Tietze from comment #2)
> The proposal was to introduce icon views instead of tabs. Looks tidy and
> modern with icons and enough white space. But I remember harsh criticism
> saying we cannot change all dialogs.

In this case we have *17* tabs. That would mean a lot of scrolling with your mockup. I'm sure power users would complain very soon. If anything, I would keep the small tab size and add icons left to the text, like:

[icon] label
[icon] label
...

> 
> http://listarchives.libreoffice.org/global/design/msg07251.html
> https://wiki.documentfoundation.org/Design/PropertyDialog 
> 
> An alternative is to just disable multiline tabs. In that case, arrows allow
> to navigate to the undisplayed tabs.

This is ok as long as there is one or two tabs that cannot be shown by default, but I wouldn't do it if half of the tabs need scrolling, this would also seriously slow down power users.
Comment 4 Cor Nouws 2016-04-27 13:12:25 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #3)
> (In reply to Heiko Tietze from comment #2)
> > The proposal was to introduce icon views instead of tabs. Looks tidy and
> > modern with icons and enough white space. But I remember harsh criticism
> > saying we cannot change all dialogs.
> 
> In this case we have *17* tabs. That would mean a lot of scrolling with your
> mockup. I'm sure power users would complain very soon. If anything, I would
> keep the small tab size and add icons left to the text, like:
> 
> [icon] label
> [icon] label
> ...

Looks as a reasonable idea.
Wrt power users: one might expect a decent key stroke to move to the next/previous page/tab. Maybe the same as currently.

We must realize that also dialogs with as little as two tabs exist. Then the labels in a vertical row is a waste of space..

(In reply to Samuel Mehrbrodt (CIB) from comment #0)
> I have two ideas how to improve the situation:
> 1. Leave the tabs as they are (multiline), but don't switch rows when
> selecting a tab from the top.

I would love to see some experimenting with that.
Comment 5 Samuel Mehrbrodt (allotropia) 2016-04-27 13:16:06 UTC
(In reply to Cor Nouws from comment #4)
> We must realize that also dialogs with as little as two tabs exist. Then the
> labels in a vertical row is a waste of space..

Sure, I am talking about dialogs with more than one row of tabs, I wouldn't change the others.


> I would love to see some experimenting with that.

Maybe we can do this as a first step and then iterate? Or do we want to ban multiline tabs at all, then I won't waste time on this.
Comment 6 Heiko Tietze 2016-04-27 15:06:00 UTC
Stacking text/tabs to avoid whitespace and having different UI concepts that would be two epic design failures.
Comment 7 Cor Nouws 2016-04-27 16:53:45 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #5)
> Sure, I am talking about dialogs with more than one row of tabs, I wouldn't
> change the others.

Would look odd to me, to have two types..

> > I would love to see some experimenting with that.
> 
> Maybe we can do this as a first step and then iterate? Or do we want to ban
> multiline tabs at all, then I won't waste time on this.

I would love to have a look with a not so much used dialogue maybe in a daily.
Heiko, what do you think?

Honestly I see no solution, bringing more improvements that drawbacks ;) , in the first option.
Comment 8 Yousuf Philips (jay) (retired) 2016-04-27 18:24:50 UTC
When there is a limited number of tabs and the dialog contains functionality that is seen by basic users (benjamin), the icon-based vertical tabs which is found in the hyperlink dialog is nice. We are hoping to implement this in a simplified options dialog (bug 90989).

When there are many tabs and the dialog is primarily focused on more experienced users (eve), the non-icon vertical tabs found in the options dialog is nice. MS Office does a similar type of vertical tabs dialog with sufficient white spacing between each entry - https://support.content.office.net/en-us/media/5053c209-22b4-4336-a8ec-fd03d4547678.jpg
Comment 9 Thomas Lendo 2017-05-18 22:59:36 UTC
I find the current layout much more clear and faster readable than any vertical layout. Most people are used to read LTR or RTL, not top to bottom or reverse. Also there is much more horizontal than vertical space. Using a scrollbar would be a usability disaster. A vertical layout should only be an option for very few (~handful) points.

Disabling multiline tabs and showing arrows to scroll reduces the usability too because you can't have all options at a look, what's important especially for Benjamin to find the right tab/option.
Comment 10 Yousuf Philips (jay) (retired) 2017-05-19 20:01:52 UTC
(In reply to Thomas Lendo from comment #9)
> Most people are used to read LTR or RTL, not top to bottom or reverse.

The contents of the tabs are ordered top to bottom in columns.

> Also there is much more horizontal than vertical space.

That all depends on how the controls are organized. Many tabs have extra wide controls for no reason (e.g. Character dialog's hyperlink and highlighting tabs, nearly every tabs in the Paragraph dialog)

> Using a scrollbar would be a usability disaster. A vertical layout should only
> be an option for very few (~handful) points.

Cant say i agree with you, as when you have content that is larger than the available space, scrollbars are common and useful (e.g. browser, file manager). Alternatively you would have to have more vertical tabs, but you wouldnt be for scrolling within the vertical tabs.
Comment 11 Mike Kaganski 2018-12-10 06:05:14 UTC
Having no tabs at all, and have every area collapsing/expanding (like "Other options" section in Find & Replace dialog) would IMO be much better option. Such layouts are used e.g. in apps like 3ds max, AutoCAD (MS Office has a single non-collapsing long sheet, and that is much worse). Having a dialog with all such sections initially collapsed would create something like ToC right in the middle of the main dialog area; clicking the expand button would automatically bring the area to the center of the dialog; and the scrollbar would only be needed when several of the areas are expanded (and then it would be handy IMO, not a "usability disaster").
Comment 12 Heiko Tietze 2018-12-10 16:14:15 UTC
(In reply to Mike Kaganski from comment #11)
> Having no tabs at all...

The pattern is called accordion and would change the native integration (see also bug 120371 c15). Not an easy decision.
Comment 13 Heiko Tietze 2019-03-01 13:43:40 UTC
Samuel, with the latest changes by Caolan can we close this issue as solved/wfm? Since we aim to be as close to the system as possible, the alternative concepts with accordions or icon views are also a wontfix. In a nutshell, feel free to reopen.
Comment 14 Samuel Mehrbrodt (allotropia) 2019-03-04 07:02:12 UTC
(In reply to Heiko Tietze from comment #13)
> Samuel, with the latest changes by Caolan can we close this issue as
> solved/wfm? Since we aim to be as close to the system as possible, the
> alternative concepts with accordions or icon views are also a wontfix. In a
> nutshell, feel free to reopen.

The issues I described in comment 0 are still there. I can't see how recent changes have improved anything there.
Comment 15 Heiko Tietze 2019-03-04 07:42:35 UTC
(In reply to Samuel Mehrbrodt (CIB) from comment #14)
> I can't see how recent changes have improved anything there.

gtk3 has no multiline tabs anymore, see also bug 121752.
Comment 16 Tomaz Vajngerl 2019-03-04 08:04:52 UTC
gtk3 is not our only backend
Comment 17 Samuel Mehrbrodt (allotropia) 2019-03-04 08:05:39 UTC
And gtk3 also has multiline tabs in current master?!
Comment 18 Xisco Faulí 2020-03-09 13:28:27 UTC Comment hidden (off-topic)
Comment 19 Heiko Tietze 2022-05-24 07:18:55 UTC
*** Bug 113418 has been marked as a duplicate of this bug. ***
Comment 20 Heiko Tietze 2022-05-24 07:20:16 UTC
Vertical Gnome-like tabs were requested on bug 113418.

(In reply to Heiko Tietze from bug 113418 comment #12)
> We discussed this in the design meeting:
> 
>    + dialogs with vertical "tabs" wouldn't be according the OS/DE anymore
>      but make the application likely more appealing than (stacked) tabs
>    + sidebar with large image and text might be a good solution for option
>      dialogs but not in case of properties; good icons are very challenging
>      and doubt it's helpful (Sascha)
>    + would appreciate the sidebar with icon solution instead of tabs (Rizal)
>    + never liked the tabs, go with sidebar (John)
>    + ideally we have a solution that can be reverted if not accepted (Heiko)
Comment 21 Commit Notification 2024-04-29 05:52:59 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b64751ba28fd69fb2a93a21b10a92b68f4dd2097

tdf#99528 Properly layout vertical tabs without icons

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2024-05-02 11:15:09 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/62172db2d71fdc49a3ad9c177b8635353b90a7eb

tdf#99528 Use vertical tabs in character style dialog

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Heiko Tietze 2024-05-03 07:43:55 UTC
Created attachment 193947 [details]
Character Style

Quite ugly with kf6 without any margins, no icons, badly colored highlighting, zero spacing between frames, cut-off text... How does the patch work in your environment?
Comment 24 Samuel Mehrbrodt (allotropia) 2024-05-06 06:12:37 UTC
(In reply to Heiko Tietze from comment #23)
> Created attachment 193947 [details]
> Character Style
> 
> Quite ugly with kf6 without any margins, no icons, badly colored
> highlighting, zero spacing between frames, cut-off text... How does the
> patch work in your environment?

Icons can be added in Glade files, see hyperlink dialog for reference. I'll leave that to you or other ux people.

For visual improvements please file a separate task with a graphic how it should look like.
I checked Windows & gen plugin which looks ok. Gtk is fine since it supports vertical tabs natively.
Comment 25 Commit Notification 2024-05-06 07:13:47 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d700acbcba68e8b56e22db53bfcdfeb4c5777b9c

tdf#99528 Use vertical tabs in Frame dialog

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 Heiko Tietze 2024-05-06 08:06:45 UTC
Can you make the vertical tabs optional? I expect some trouble and a lot users who want to stick with horizontal configuration.
Comment 27 Commit Notification 2024-05-06 08:18:57 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/67dc0edb688d345607ae6afe3ad849f143804e28

tdf#99528 Use vertical tabs in 'Edit Style' dialog

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Commit Notification 2024-05-06 09:03:13 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/971db10d73a0fe80cceca70d19edd02de30be414

tdf#99528 Use vertical tabs in Calc draw styles dialog

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 29 Commit Notification 2024-05-06 09:56:20 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d9bcf481b40d2a20169a98eb53caf7b19a03f3b8

tdf#99528 Use vertical tabs in list style dialog

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 30 Samuel Mehrbrodt (allotropia) 2024-05-06 09:57:41 UTC
(In reply to Heiko Tietze from comment #26)
> Can you make the vertical tabs optional? I expect some trouble and a lot
> users who want to stick with horizontal configuration.

From what I read in comment 20 the vertical tabs idea was generally accepted and if it causes too much trouble it can be reverted.
Don't see the need for having an option for this at the moment.
Comment 31 Commit Notification 2024-05-06 11:07:29 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d71ea85d286a9a89e6cf784da90a820a09c0db2e

tdf#99528 Use vertical tabs in Calc page styles dialog

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 32 Commit Notification 2024-05-06 11:15:36 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2199e603691a770ea6b67cbaba4ce1e0ce7b1919

tdf#99528 Use vertical tabs in 'Format cells' dialog

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 33 Commit Notification 2024-05-06 11:45:44 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2a41f854ceb2860239b1d7ec8fbc3d460c7499a1

tdf#99528 Use vertical tabs in Calc paragraph styles dialog

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 34 Commit Notification 2024-05-06 12:04:48 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e5e9ed7b87072c3c6366f50127cf2b9cf6bf4499

tdf#99528 Use vertical tabs in page dialog

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 35 Commit Notification 2024-05-06 20:12:27 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2f141c543494f44eab05db79533c60d342213901

tdf#99528 Use vertical tabs in frame style dialog

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 36 Eyal Rozenberg 2024-05-08 19:59:19 UTC
(In reply to Samuel Mehrbrodt (allotropia) from comment #30)
> From what I read in comment 20 the vertical tabs idea was generally accepted
> and if it causes too much trouble it can be reverted.

I have only now heard about this initiative... I can't say I like vertical tabs all that much. And while I do agree that the horizontal tabs are not very convenient, they are a better established UI "idiom". I believe that well before this commit was made, we should have seen some kind of outreach:

* Design meeting discussion (AFAICT that didn't occur)
* Heads-up in the design Telegram/Matrix/IRC channel 

since this is a really big deal.
Comment 37 Eyal Rozenberg 2024-05-08 21:33:37 UTC
(In reply to Eyal Rozenberg from comment #36)

Trying it out for the first time with a nightly.

* The vertical "tabs" are not very tabby. More like a vertical nav-bar with a special kind of selection highlight. But this is ok for me, I think. At least with GTK3.
* On second though, perhaps some kind of discoloration rectangle around the active tab would be nice, not just the blue bar.
* I'm lacking space at the top of the tab. There's too little before the first group title (e.g. Paper Format, Area Transparency mode etc.)

Also, now that all tabs are in sequence, their ORDER  begins to matter:

* Is their order purposeful? Why was this order chosen?
* Shouldn't 'Page' by the first tab, at the top and selected by default? It has the most frequently-sought-after properties after all
* Or maybe it should be 'organizer', which summarizes the style's features (and in the future, its delta from the parent style, see 41316), and has the style name?
* Or perhaps the tabs should be sorted, so it would be easier to "guess" where on the list to find a tab whose name you have in your mind?
* This draws attention to how Organizer is perhaps mis-named. It's more like the "General" or "Summary". Maybe I should open a bug about that.
* Maybe "Organizer" should be separated from the rest, or otherwise distinguished visually, and then the Page tab can be first among the "non-Organizer tabs" if you will.

Anyway, I'm weakly-in-favor of keeping the change.
Comment 38 Xisco Faulí 2024-05-09 12:23:07 UTC
(In reply to Samuel Mehrbrodt (allotropia) from comment #30)
> (In reply to Heiko Tietze from comment #26)
> > Can you make the vertical tabs optional? I expect some trouble and a lot
> > users who want to stick with horizontal configuration.
> 
> From what I read in comment 20 the vertical tabs idea was generally accepted
> and if it causes too much trouble it can be reverted.
> Don't see the need for having an option for this at the moment.

Considering the impact it might have on end users and the trouble it might cause, I'm also in favour of making it optional for the time being.
Comment 39 csongor 2024-05-09 16:53:13 UTC
Sorry, I had no time to comment before the design meeting but here are my thoughts. 

Since I swapped in my browser from top-of-the-window tabs to left-side-of-the window tabs, I love this layout a lot more. I needed a little time, maybe a day  or so, to get familiar with it but it uses the screen space a lot more efficiently and I would hate now to switch back. 

I think the proposed new layout should be the default, with keeping the option for switching back to the "old" style for the users who don't like it.
Comment 40 Eyal Rozenberg 2024-05-10 08:07:53 UTC
(In reply to Xisco Faulí from comment #38)
> Considering the impact it might have on end users and the trouble it might
> cause, I'm also in favour of making it optional for the time being.

I don't know about that. If you make it opt-in, then basically nobody will use it, and then you'll just have the same dilemma when you want to make it default; and if you make it opt-out, most of the "trouble" will happen anyway, since people who know how to fiddle with Tools > Options will be able to handle the tab layout change well enough. And - I don't think it would be a good idea to bring up a message box while people are watching the page properties dialog telling them "do you want to switch dialog layout?" ...
Comment 41 Commit Notification 2024-05-31 11:46:09 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/68260d7525aeaf38ac09ca9920fa1fa76dc8018a

tdf#99528 Move through tabs with Ctrl-PageUp/Down keys

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 42 Commit Notification 2024-06-10 05:13:41 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/30380c2f9888685ddceaafc9fb3a637e7167a3ac

tdf#99528 Use vertical tabs in para dialog

It will be available in 24.8.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 43 Commit Notification 2024-06-21 13:53:43 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-24-8":

https://git.libreoffice.org/core/commit/da21a102d072e73db8f7b8594903bf2780f6cdac

tdf#99528: revert vertical tabs changes (24.8 only)

It will be available in 24.8.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 44 V Stuart Foote 2024-06-21 14:21:00 UTC
with revert, have adjusted whiteboard and removed from the release notes Wiki