Bug 99793 - the sound starts again with each new slide
Summary: the sound starts again with each new slide
Status: CLOSED MOVED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks:
 
Reported: 2016-05-12 10:31 UTC by Davide Marchi
Modified: 2018-04-03 12:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Davide Marchi 2016-05-12 10:31:07 UTC
Hi,
on Linux Ubuntu 14.04 LTS (amd) and Libreoffice 4.2.8.2,
using an mp3 of "3 minutes" duration sound, Libreoffice does the music start over with each new slide.

I've follow this italian tutorial: https://forum.openoffice.org/it/forum/viewtopic.php?f=6&t=2210


On another Libreoffice release (4.1) on an Imac computer the same presentation goes well, but at the end of the sound it doesn't loop, so many slides remain without music.
Comment 1 Buovjaga 2016-05-13 05:55:17 UTC
What if you try LibreOffice 5.1.x? You can do it with this: https://wiki.documentfoundation.org/Installing_in_parallel/Linux
or this https://launchpad.net/~libreoffice/+archive/ubuntu/ppa

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 2 Davide Marchi 2016-05-13 16:42:36 UTC
Well Buovjaga,

At the end the question is the interface usability.

I opened the discussion in an Italian forum and we have understood that it was just a procedural problem:

Here the solution: https://wiki.openoffice.org/wiki/Documentation/FAQ/Impress/I_inserted_a_song_in_my_presentation,_but_when_I_change_slide_the_music_stops._How_do_I_play_music_throughout_a_presentation%3F

But the question is another: the usability interface.
In fact, to apply a soundtrack to an entire presentation, it would be enough of a button "sound loops", that automatically do disable the sound for each single slide and it and its start each new slide.


Then there's another thing: using the same presentation to create new ones, the sound tab keeps in memory the songs previously used, even if these have been removed from hard drive and not allows to understand its path. This is particularly problematic if the sound has the same name.



PS
the italian forum thread:  http://www.istitutomajorana.it/forum2/Thread-Libreoffice-e-musica-in-loop-di-sottofondo?pid=88473#pid88473


many many thanks!

davide
Comment 3 Heiko Tietze 2016-09-21 08:21:24 UTC
Links to AOO don't work anymore. Your Italian forum requires registration to zoom the image. 

To rephrase what I understand: You want to add a sound file to the whole presentation that is playing in the background during the presentation. Today the playback restarts when you go to the next slide. And the proposal is to add a checkbox that switches from per slide playback to per presentation.

Right?
Comment 4 Davide Marchi 2016-10-06 15:51:34 UTC
I think that the Italian AOO forum don't work anymore, I am convinced that does it the Italian Government :-D

For the question, as above, the problem is the usability and to have a clear interface.

1) on a new file the sound tab keeps in memory the songs previously used, even if these have been removed from hard drive and not allows to understand its path. And this is not good.

and

2) It would be very usable and comfortable to have a button where the user set the loop for the selected audio file for the entire slide. Now it's frustrating to calculate the duration of the slide and take it to the length of the audio track. To ensure the sound track properly over the whole slide.

;-)
Comment 5 Heiko Tietze 2016-10-09 21:32:00 UTC
(In reply to Davide Marchi from comment #4)
> I think that the Italian AOO forum don't work anymore, I am convinced that
> does it the Italian Government :-D
> 
> For the question, as above, the problem is the usability and to have a clear
> interface.
> 
> 1) on a new file the sound tab keeps in memory the songs previously used,
> even if these have been removed from hard drive and not allows to understand
> its path. And this is not good.
> 
> and
> 
> 2) It would be very usable and comfortable to have a button where the user
> set the loop for the selected audio file for the entire slide. Now it's
> frustrating to calculate the duration of the slide and take it to the length
> of the audio track. To ensure the sound track properly over the whole slide.
> 
> ;-)

Okay, sounds reasonable. I suggest to show a confirmation dialog when a path/file cannot get accessed temporarily. And a simple checkbox "[ ] Loop until next slide" for the other question. 

However, since we have two tasks I close this ticket as invalid and ask you kindly to create two new. Feel free to copy/paste. Having separate issues allow devs to close one as fixed while the other waits for someone else.