Download it now!
Bug 99866 - EDITING: File save as xlsx Conditional formatting not saved in excel and give error
Summary: EDITING: File save as xlsx Conditional formatting not saved in excel and give...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 100237 103609 (view as bug list)
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2016-05-15 20:53 UTC by vlb
Modified: 2017-12-21 08:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
test file (11.74 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-05-15 20:53 UTC, vlb
Details
saved xslx file (4.94 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-05-15 21:14 UTC, vlb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vlb 2016-05-15 20:53:29 UTC
Created attachment 125064 [details]
test file

windows 10 64 bits LO 5.1.3.2

Reproduce bug:

1)open attachment
2) save as *.xslx
3) open in excel and give error and conditional formatting are disappeared in excel
Comment 1 vlb 2016-05-15 20:56:35 UTC
(In reply to vlb from comment #0)
> Created attachment 125064 [details]
> test file
> 
> windows 10 64 bits LO 5.1.3.2
> 
> Reproduce bug:
> 
> 1)open attachment
> 2) save as *.xslx
> 3) open in excel and give error and conditional formatting are disappeared
> in excel

Conditional formatting are in cell a1
Comment 2 vlb 2016-05-15 21:14:46 UTC
Created attachment 125065 [details]
saved xslx file
Comment 3 Buovjaga 2016-05-17 14:00:33 UTC
Repro.

Win 8.1 32-bit
LibreOffice Version: 5.2.0.0.alpha1+
Build ID: cc1a0ba927ad6f85103059aa8e6108017f436304
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-05-17_02:31:19
Locale: fi-FI (fi_FI)
MSO 2013
Comment 4 Eike Rathke 2016-05-19 17:23:28 UTC
@moggi: my guess, related to bug 99917 and the <cfRule> element contains something Excel doesn't like, i.e. attributes unrelated to expression?
Comment 5 Markus Mohrhard 2016-05-21 02:05:22 UTC
It seems to work in my build and the only thing that seems different is that in the attached test file the dxf record is not exported.

Can someone else reproduce it with a current daily build?
Comment 6 vlb 2016-05-21 12:42:50 UTC
I have test in:
Version: 5.2.0.0.alpha1+
Build ID: 7b704dfbdb23540ff6366fa60c73474bbda9dc26
CPU Threads: 8; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-05-20_05:45:40
Locale: nl-NL (nl_NL)

and LO 5.1.3.2

What i have found is next:
Reproduce:

1) open test file
2) open a new file
2) copy cell A1:A2 to the new file and save as *.ods
3) then save the new file as XSLX
4 ) when open in excel there is a error present

Not reproduce when:
1) open test file
2) copy A1:A2 and close the file
2) open a new file
2) paste to cell A1 in the new file and save as *.ods
3) then save the new file as XSLX
4 ) when open in excel there isn't a error present
Comment 7 Buovjaga 2016-05-28 14:02:36 UTC
(In reply to vlb from comment #6)
> 1) open test file
> 2) open a new file
> 2) copy cell A1:A2 to the new file and save as *.ods
> 3) then save the new file as XSLX
> 4 ) when open in excel there is a error present

Repro.

Win 8.1 32-bit
MSO 2013
LibO Version: 5.3.0.0.alpha0+
Build ID: 9d2f7be4e65595241db3cf5135b69bd9e4ce6a30
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-05-27_22:55:26
Locale: fi-FI (fi_FI)
Comment 8 m.a.riosv 2016-06-06 21:24:37 UTC
*** Bug 100237 has been marked as a duplicate of this bug. ***
Comment 9 Andreas 2016-06-07 06:43:55 UTC
I tested it with LibreOffice and Excel, this is what LibreOffice 5.1.3 produces:

<conditionalFormatting sqref="A1">
    <cfRule type="cellIs" priority="2" operator="equal" aboveAverage="0" equalAverage="0" bottom="0" percent="0" rank="0" text="" dxfId="0">
        <formula>&quot;abc&quot;</formula>
    </cfRule>
</conditionalFormatting>



And this is what Excel 2016 produces:
<conditionalFormatting sqref="A1">
    <cfRule type="cellIs" dxfId="1" priority="1" operator="equal">
        <formula>"abc"</formula>
    </cfRule>
</conditionalFormatting>
Comment 10 Andreas 2016-06-07 07:46:40 UTC
Looked further into it. I tried this:
- Push F11 - Styles and Formatting
- Right click - New...
  - Name: GreenBackground
  - Background: Green
  - Save
- Enter "ab" in field A1
- Conditional Formatting: Condition on field A1
  - Cell value is equal to "ab"
  - Apply Style "GreenBackground"
  - OK
- Save as .xlsx file

When I open this file now in LibreOffice the conditional formatting is still there. But when I push F11, the style "GreenBackground" is not there anymore. There are 2 new styles: "ConditionalStyle_1" and "Excel Built-in Explanatory Text". Both have the background set as green.

When I now change anything else (not related to the conditional formatting), for exampe put 2 in field E3 and save (still as xlsx) and then open the file again the green background in A1 is gone. Of the two new styles only "ConditionalStyle_1" is left but without background color set.
Comment 11 m.a.riosv 2016-10-31 23:03:27 UTC
*** Bug 103609 has been marked as a duplicate of this bug. ***
Comment 12 vlb 2017-12-20 13:21:30 UTC
I have test with the latest version LO 5.4.3.2 (x64)and isn't still present.
Comment 13 Buovjaga 2017-12-20 17:45:55 UTC
(In reply to vlb from comment #12)
> I have test with the latest version LO 5.4.3.2 (x64)and isn't still present.

You mean the bug is gone?
Comment 14 vlb 2017-12-20 21:58:24 UTC
(In reply to Buovjaga from comment #13)
> (In reply to vlb from comment #12)
> > I have test with the latest version LO 5.4.3.2 (x64)and isn't still present.
> 
> You mean the bug is gone?

Yes