Bug 101057 - LO crash when creating database using JDK 1.8.0_102
Summary: LO crash when creating database using JDK 1.8.0_102
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.3.0 target:5.2.1 target:5.1.5
Keywords: haveBacktrace, regression
: 101346 101428 (view as bug list)
Depends on:
Blocks: Java-Runtime-JRE
  Show dependency treegraph
 
Reported: 2016-07-21 12:11 UTC by Thomas Maeder
Modified: 2016-10-27 02:51 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
ZIP of screenshots (PDF) + created empty base (Recettes.odb) (394.50 KB, application/zip)
2016-07-21 12:11 UTC, Thomas Maeder
Details
backtrace (41.38 KB, text/plain)
2016-07-21 14:41 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Maeder 2016-07-21 12:11:43 UTC
Created attachment 126341 [details]
ZIP of screenshots (PDF) + created empty base (Recettes.odb)

On MacBook Pro 15"Retina, late 2013, 2 GHz Intel Core i7
Java Oracle JDK 8 build 102 / 1.8.0_102-b14

(See attachment ; page = screenshot of corresponding step)

1) Create new base - HSQLBD embedded - go to other pane
2) Set to open for edit -> Finish
3) Type a name in save dialog -> Save
4) CRASH (note: no filename is mentioned)
5) Launch LO (note: new database now appears, even if not mentioned in crash dialog)
6) Recovery complete -> Finish
7) Database creation dialog -> click on Tables
8) Crash (note: now the database is mentioned)

Additional notes:
- If you now do it again, the same thing happens (crash when clicking on Tables)
- If you don't select "open for edit" in (2), no crash upon creating the base.
- Opening the so-creasted files lands you in the database creation dialog (7).
- There, clicking on Tables (7) again lead to a crash (8).
Comment 1 Alex Thurgood 2016-07-21 14:01:52 UTC
Confirming on 

Version: 5.1.4.2
Build ID: f99d75f39f1c57ebdd7ffc5f42867c12031db97a
Threads CPU : 8; Version de l'OS :Mac OS X 10.11.5; UI Render : par défaut; 
Locale : fr-FR (fr.UTF-8)

with JDK 1.8.0_102

Note that LO does not crash for me with JDK 1.8.0_40.
Comment 2 Alex Thurgood 2016-07-21 14:12:04 UTC
No crash for me with 

Version: 5.3.0.0.alpha0+
Build ID: e735ba57da04dc77ff1bfe6c3d48dacae42b0f87
Threads CPU : 2; Version de l'OS :Mac OS X 10.11.5; UI Render : par défaut; 
Locale : fr-FR (fr.UTF-8); Calc: group

and 

JDK 1.8.0_92
Comment 3 Alex Thurgood 2016-07-21 14:24:00 UTC
However, it crashes as described with

Version: 5.3.0.0.alpha0+
Build ID: 04c4fb0fa293708fd90e78c9384bb1211ebab244
Threads CPU : 2; Version de l'OS :Mac OS X 10.11.5; UI Render : par défaut; 
Locale : fr-FR (fr.UTF-8); Calc: group

and 

JDK 1.8.0_102
Comment 4 Alex Thurgood 2016-07-21 14:25:22 UTC
This is unfortunate because we tell users to download the latest JDK. Will try and obtain a backtrace from my master build.
Comment 5 Alex Thurgood 2016-07-21 14:31:07 UTC
warn:legacy.osl:21281:1:svtools/source/uno/genericunodialog.cxx:314: OGenericUnoDialog::OnDialogDying: where does this come from?
warn:jfw:21281:1:jvmfwk/plugins/sunmajor/pluginlib/sunjre.cxx:102: [Java framework] sunjavaplugin.dylib does not know the version: 1.8.0_102 as valid for a SUN/Oracle JRE.
libc++abi.dylib: terminating with unexpected exception of type jfw_plugin::MalformedVersionException
Process 21281 stopped
* thread #1: tid = 0xb0ca1c, 0x00007fff9b52cf06 libsystem_kernel.dylib`__pthread_kill + 10, queue = 'com.apple.main-thread', stop reason = signal SIGABRT
    frame #0: 0x00007fff9b52cf06 libsystem_kernel.dylib`__pthread_kill + 10
libsystem_kernel.dylib`__pthread_kill:
->  0x7fff9b52cf06 <+10>: jae    0x7fff9b52cf10            ; <+20>
    0x7fff9b52cf08 <+12>: movq   %rax, %rdi
    0x7fff9b52cf0b <+15>: jmp    0x7fff9b5277cd            ; cerror_nocancel
    0x7fff9b52cf10 <+20>: retq   


Pretty clear methinks.
Comment 6 Alex Thurgood 2016-07-21 14:41:20 UTC
Created attachment 126345 [details]
backtrace
Comment 7 Alex Thurgood 2016-07-21 14:41:51 UTC
@Stephan : one for you ?
Comment 8 Caolán McNamara 2016-07-21 21:00:54 UTC
The number after _ is now 3 digits long. My guess for the lack of recognition of the java version is...

jvmfwk/plugins/sunmajor/pluginlib/sunversion.cxx:140

//1.4.1_01-, 1.4.1_01a, the numerical part may only be 2 chars.
int len = pCur - pLast;
if (len > 2)
    return false;

if someone is in a position to build their own mac version and replace that 2 with something bigger (less that 128)
Comment 9 Commit Notification 2016-07-22 07:24:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=64d3270a89fd88d4d0cf70329af2c66f722fd95e

Related: tdf#101057 allow java update version number > 99

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2016-07-22 08:47:34 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=191e3809f5d62392bf98b940ad8f6937ae5ee6c6&h=libreoffice-5-2

Related: tdf#101057 allow java update version number > 99

It will be available in 5.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Aron Budea 2016-07-22 08:59:42 UTC
I haven't upgraded to Java 1.8 u102, yet. Is this bug supposed to affect all OSes?
Comment 12 Caolán McNamara 2016-07-22 19:58:44 UTC
I would imagine all oses will suffer from not being able to detect that version. It might be that only MacOSX will do the std::terminate thing cause of the enforcing exception spec. Not sure if that's only the dbgutil thing on mac though or release builds too.
Comment 13 Commit Notification 2016-07-22 20:41:12 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a3b3c5fcd7efd3e33a0f0078bd6fd23689c45c41

Related: tdf#101057 inherit MalformedVersionException from std::exception

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Caolán McNamara 2016-07-24 20:32:16 UTC
caolanm->alex: could you check to see if those changes made a difference ?
Comment 15 Julien Nabet 2016-07-25 07:51:51 UTC
On MacOs 10.11.5 with master sources updated yesterday, I don't have a crash but since this Java version isn't selected by default, I've got an popup error message.

About Java, here's what I did:
1) purge any Java version with 
sudo rm -rf /Library/Java/JavaVirtualMachines/jdk<version>.jdk
sudo rm -rf /Library/PreferencePanes/JavaControlPanel.prefPane
sudo rm -rf /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin
sudo rm -rf /Library/LaunchAgents/com.oracle.java.Java-Updater.plist
sudo rm -rf /Library/PrivilegedHelperTools/com.oracle.java.JavaUpdateHelper
sudo rm -rf /Library/LaunchDaemons/com.oracle.java.JavaUpdateHelper.plist
sudo rm -rf /Library/Preferences/com.oracle.java.Helper-Tool.plist
(see http://stackoverflow.com/questions/19039752/removing-java-8-jdk-from-mac)
2) install last jdk from java website
3) remove LO profile
4) restart computer to be sure there's only last Java in RAM

However, if I selected Java version in advanced menu then restart LO, no problem to create an hsqldb db file.

In brief, I don't reproduce this problem with master sources.
Comment 16 Alex Thurgood 2016-07-26 08:44:29 UTC
Verified fix in

Version: 5.3.0.0.alpha0+
Build ID: 36e61d03a252e73139a472c5be04ffc54a5c8efb
CPU Threads: 2; OS Version: Mac OS X 10.11.6; UI Render: default; 
Locale: fr-FR (fr.UTF-8); Calc: group
Comment 17 Commit Notification 2016-07-26 09:24:02 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-1-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=16d60f0632ea16ac5ad8dae2a3781195fef50d9d&h=libreoffice-5-1-5

Related: tdf#101057 allow java update version number > 99

It will be available in 5.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2016-07-26 10:22:59 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9bbed86d9c84a4faf6cc36b162d41a77d8480610&h=libreoffice-5-2

Related: tdf#101057 inherit MalformedVersionException from std::exception

It will be available in 5.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Aron Budea 2016-08-05 22:22:00 UTC
*** Bug 101346 has been marked as a duplicate of this bug. ***
Comment 20 Gerhard Schaber 2016-08-07 16:40:10 UTC Comment hidden (obsolete)
Comment 21 Gerhard Schaber 2016-08-07 16:41:52 UTC Comment hidden (obsolete)
Comment 22 Gerhard Schaber 2016-08-07 16:51:46 UTC Comment hidden (obsolete)
Comment 23 Gerhard Schaber 2016-08-07 19:35:08 UTC Comment hidden (obsolete)
Comment 24 Alex Thurgood 2016-08-10 16:39:21 UTC
*** Bug 101428 has been marked as a duplicate of this bug. ***