Bug 101165 - Crashing on a filter selection, every time
Summary: Crashing on a filter selection, every time
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0 target:5.2.2 target:5.1....
Keywords: haveBacktrace, regression
: 101421 102291 102842 102904 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-07-28 02:27 UTC by Tim Richardson
Modified: 2018-09-15 06:07 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
file which shows crash (32.33 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-07-28 02:27 UTC, Tim Richardson
Details
screen shot (194.37 KB, image/png)
2016-07-28 02:29 UTC, Tim Richardson
Details
filter crash on empty select (162.55 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-08-09 09:31 UTC, ebricca
Details
filter crash on empty select - screenshot (33.81 KB, image/jpeg)
2016-08-09 09:52 UTC, ebricca
Details
backtrace from lldb debugging session (24.54 KB, text/plain)
2016-08-10 11:43 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Richardson 2016-07-28 02:27:42 UTC
Created attachment 126443 [details]
file which shows crash

To reproduce:

Open attached doc.
It should have filtering active.
Click on the filter downarrow on column B Date (see screen shot)
Comment 1 Tim Richardson 2016-07-28 02:29:19 UTC
Created attachment 126444 [details]
screen shot

It seems I must submit before adding a second attachment.
So open the spreadsheet, choose the drop down filter on column B, and click the 'deselect all' button. Calc crashes every time. OS X.
Comment 2 Julien Nabet 2016-07-28 08:35:31 UTC
On MacOs 10.11.5, I don't reproduce this with LO 5.1.4 or with master sources updated some days ago.

Could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Mac_OS_X) and give a new try?

If you still reproduce this, could you attach debug info? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Mac_OSX:_How_to_get_debug_information)
Comment 3 Tim Richardson 2016-07-30 02:24:15 UTC
Just in case it wasn't clear what I meant, here's a short screen recording.

https://youtu.be/TVeglW8gxhU
Comment 4 Julien Nabet 2016-07-31 09:13:53 UTC
(In reply to Tim Richardson from comment #3)
> Just in case it wasn't clear what I meant, here's a short screen recording.
> 
> https://youtu.be/TVeglW8gxhU

It was clear but I could't reproduce the crash with this.
That's why I asked about renaming your LO directory profile and give a new try (see my previous comment).
Finally, if you still reproduce this, it could be interesting you attach error log here.
Comment 5 Gulliver 2016-08-09 04:06:12 UTC
Error is also reproduced on libreoffice 5.1.5.2 Rus win32 / 64.
Crash while deselect all.
Profile cleaned, it did not help.
Comment 6 ebricca 2016-08-09 09:31:54 UTC
Created attachment 126686 [details]
filter crash on empty select

filter crash on selecting just empty/blank lines
Comment 7 ebricca 2016-08-09 09:52:58 UTC
Created attachment 126687 [details]
filter crash on empty select - screenshot

crash with file "filter crash on empty select" 

-happens when one using the "line" filter box
(not the "empty" / "non empty" selectors)
as shown in the screenshot

i suspect size to matter (there are 20000 lines)
(though in excel the selection is near instantaneous)

crash happens on the latest libreoffice 5.2 
running on win7 / en / 64

also happens on libreoffice 4.0
Comment 8 Julien Nabet 2016-08-09 20:11:48 UTC
So let's put NEW since it's been confirmed.

Could someone retrieve and attach a backtrace? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information)
Comment 9 Tim Richardson 2016-08-10 08:13:43 UTC
the instructions for getting a trace on os x say that we can copy and paste from the standard OS X crash report.
However, when Calc crashes as I report, it opens immediately in the recovery dialog. It doesn't trigger a crash report.
Comment 10 Alex Thurgood 2016-08-10 11:19:22 UTC
(In reply to Tim Richardson from comment #9)
> the instructions for getting a trace on os x say that we can copy and paste
> from the standard OS X crash report.
> However, when Calc crashes as I report, it opens immediately in the recovery
> dialog. It doesn't trigger a crash report.

Unfortunately, those instructions are rubbish. Yes, sometimes, you do get the Apple Crash Reporter and sometimes there might be some helpful information in that output, but mostly it isn't of much use. Anyway, even if the Apple Crash Reporter doesn't display, you might stil find a file in the reporter logs, or by starting up Console.app and checking to see whether anything got registered.

The real way to get a trace is to start LO in lldb and for that you need XCode.
Comment 11 Alex Thurgood 2016-08-10 11:27:58 UTC
Tested on

Version: 5.3.0.0.alpha0+
Build ID: 3a668616968dbce778c54ec56847828efa7bdb6d
CPU Threads: 2; OS Version: Mac OS X 10.11.6; UI Render: default; 
Locale: fr-FR (fr.UTF-8); Calc: group

No crash
Comment 12 Alex Thurgood 2016-08-10 11:31:40 UTC
I can select any of the filters, Calc doesn't crash for me with master build.
Comment 13 Alex Thurgood 2016-08-10 11:34:26 UTC
Confirming however on

Version: 5.1.5.2
Build ID: 7a864d8825610a8c07cfc3bc01dd4fce6a9447e5
Threads CPU : 2; Version de l'OS :Mac OS X 10.11.6; UI Render : par défaut; 
Locale : fr-FR (fr.UTF-8); Calc: group

Immediate crash when selecting All in the filter list
Comment 14 Alex Thurgood 2016-08-10 11:43:18 UTC
Created attachment 126726 [details]
backtrace from lldb debugging session
Comment 15 Alex Thurgood 2016-08-10 11:51:09 UTC
*** Bug 101421 has been marked as a duplicate of this bug. ***
Comment 16 abma 2016-08-15 14:24:59 UTC
LO 5.1.5 on windows crashes for me too, 5.1.4 doesn't.

As this is a regression it seems, is bisecting this crash useful?
Comment 17 Caolán McNamara 2016-08-16 11:10:55 UTC
This appears to not crash in 5-2 and master because setAllMemberState was changed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=7967e5e51e5210b8c3d3dc63502bd7d875eb36b7
Comment 18 Commit Notification 2016-08-16 11:13:28 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b101ff56e874824fa9f0d37a8468b07dbf3d002c

Resolves: tdf#101165 crash on deselecting all filters

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Caolán McNamara 2016-08-16 11:15:01 UTC
https://gerrit.libreoffice.org/#/c/28165/ for 5-1 backport
Comment 20 Commit Notification 2016-08-16 12:34:48 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d15b7eb6b4525283343b5030b3227c264ec8976b&h=libreoffice-5-2

Resolves: tdf#101165 crash on deselecting all filters

It will be available in 5.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Caolán McNamara 2016-09-21 14:10:23 UTC
*** Bug 102291 has been marked as a duplicate of this bug. ***
Comment 22 Caolán McNamara 2016-10-03 20:04:33 UTC
*** Bug 102842 has been marked as a duplicate of this bug. ***
Comment 23 m.a.riosv 2016-10-30 23:42:58 UTC
*** Bug 102904 has been marked as a duplicate of this bug. ***
Comment 24 Commit Notification 2018-06-25 18:04:17 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0daff7fc119a4c6430bb47425d3f842e21abdfaf

uitest for bug tdf#101165

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.