Download it now!
Bug 101288 - Styles are not saved in LibreOffice Draw
Summary: Styles are not saved in LibreOffice Draw
Status: RESOLVED DUPLICATE of bug 101323
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-04 12:06 UTC by Nicholas Borisov
Modified: 2016-08-07 08:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
figure and example ".odg" (53.18 KB, application/x-rar)
2016-08-04 12:06 UTC, Nicholas Borisov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Borisov 2016-08-04 12:06:06 UTC
Created attachment 126569 [details]
figure and example ".odg"

Dear developers ! 

I hope my experience could be useful for our community. 

I use LibreOffice 5.0.6.3 on Windows 7.

1). Name changing (bug N.1).

1. I create a new style in LibreOffice Draw for my mindmap. 
2. I change the style name that i created. For examle from "Default-1" to "Connector-1". 
3. Save the file ".odg". 
4. Reload the file. The style name steal "Default-1".

Bug reproduced by me (LibreOffice 5.0.6.3 on Windows 7) and mr. Hagar Delest AOO 4.1.2 on Xubuntu 16.04.

2). Changing of connectors type (bug N.2).

How to reproduce the bug N.2:

1. I create a new connector for two objects.
2. Then, i create a new connectors style - "Connector - 1" and switch connectors type from default (blue line with right angle) to curve for this connector in the style menu (F11) that i selected. 
2. Save the file with new style ".odg". 
3. Reload.
4. LibreOffice show me that the type of connector in style properties is steel default but actually it's curve just like before i reloaded the file.
5. Then, i create default connector by using panel and apply my style for this one. Connectors type doesn't change for this new connector. There are not troubles with changing of color, font, connector starts and ends. 

You can see the result of this at Figure - 1 and Untitled - 2 in '.rar' archive. 

3). A problem with shortcut "repeat" (bug N.3).

I switch a combination from default to "Alt-A" and "Ctrl-A". I try this with enlgish, russian and german language.
In other applications (Writer, Calc) this problem did't appear.

You can see the topic about bugs - https://forum.openoffice.org/en/forum/viewtopic.php?f=11&t=84473&sid=00130800961cee833077472aec62911a
Comment 1 Regina Henschel 2016-08-04 22:17:47 UTC
Please try the behavior in a current version, 5.1.5 or 5.2.0.

If you still a wrong behavior, then write one report for one problem. Issues with a mix of problems cannot be handled properly.
Comment 2 Heiko Tietze 2016-08-05 08:26:09 UTC
#1: New styles are saved in the document
#2: Isn't this the same question? A style is a style.
#3: No idea what you mean but customization works well, usually.

Please update to a reasonably new version, as Regina suggested. We made a lot of improvements and fixed numerous bugs.

Closing this ticket as INVALID because of the outdated version.
Comment 4 Heiko Tietze 2016-08-07 08:32:23 UTC

*** This bug has been marked as a duplicate of bug 101323 ***