Bug 101930 - Cannot use page up/down keys in read-only mode
Summary: Cannot use page up/down keys in read-only mode
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.0.0.5 release
Hardware: All All
: medium normal
Assignee: Xisco Faulí
URL:
Whiteboard: target:6.2.0 target:6.1.0.2 target:6.0.6
Keywords: bibisected, bisected, regression
: 106837 118580 (view as bug list)
Depends on:
Blocks: Scrolling-PageUpDown Read-Only
  Show dependency treegraph
 
Reported: 2016-09-06 11:12 UTC by Jacobo Aragunde Pérez
Modified: 2018-07-09 14:16 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jacobo Aragunde Pérez 2016-09-06 11:12:02 UTC
Steps to reproduce:

1. Open any presentation file in read-only mode.
2. Use page up/down keys to browse the document.

Expected results: selected document page changes according to the pressed keys.
Actual results: selected document page doesn't change.

I think this is not a duplicate of bug #89688. That one refers to any application of the suite, and closing the read-only mode infobar works as a workaround. This one only happens in Impress, and closing the infobar has no effect.

Version: 5.1.5.2
Build ID: 5.1.5.2-3.fc24
CPU Threads: 4; OS Version: Linux 4.6; UI Render: default; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 Cor Nouws 2016-09-06 12:48:27 UTC
I've the same experience - more keys do not work
Comment 2 Aron Budea 2017-07-19 12:18:24 UTC
This is a regression that was introduced in two stages:
- in 5.0.0.5 the Navigator pane is focused initially, Page Up/Down works once you click in the presentation,
- in 5.1.0.3 the Navigator pane is not focused at the start, and clicking into the presentation doesn't help, Page Up/Down does nothing.
Comment 3 Aron Budea 2017-07-19 22:00:38 UTC Comment hidden (bibisection)
Comment 4 Aron Budea 2017-07-19 22:02:56 UTC Comment hidden (obsolete)
Comment 5 Michael Meeks 2017-07-20 08:54:07 UTC
Lets try to bisect the 5.1 regression - it is the most debilitating if we can; I guess that the bisection is not working well for the 5.0 regression - at least I can't see either of those patches causing this (as you say) =)

Thanks !
Comment 6 Aron Budea 2017-07-21 00:09:11 UTC Comment hidden (bibisection)
Comment 7 Aron Budea 2017-07-21 00:11:49 UTC
Michael, regarding the first stage, is it possible that the scheduler change had an impact on the order how UI components were initialized, which might not have been specified properly, and so the focus ended up in a different component? (or it is caused by a misconfiguration that surfaced here?)

The second stage is caused by the backport of the following commit from 5.2. This one is only configuration, so again it seems the issue is elsewhere...

https://cgit.freedesktop.org/libreoffice/core/commit/?id=9149dbf17329180e2c9e2fb39243c65acc07a182
author		Yousuf Philips <philipz85@hotmail.com>	2015-11-20 05:40:59 (GMT)
committer	Yousuf Philips <philipz85@hotmail.com>	2015-12-07 15:44:08 (GMT)

"tdf#91909 Add shortcuts to slide navigation"
Comment 8 Buovjaga 2018-05-31 18:58:36 UTC
*** Bug 106837 has been marked as a duplicate of this bug. ***
Comment 9 Buovjaga 2018-05-31 18:59:41 UTC
(In reply to Buovjaga from comment #8)
> *** Bug 106837 has been marked as a duplicate of this bug. ***

Note: "The entire Slide | Navigate menu is grayed-out"
Comment 10 Xisco Faulí 2018-07-06 15:34:59 UTC
*** Bug 118580 has been marked as a duplicate of this bug. ***
Comment 11 Xisco Faulí 2018-07-06 15:50:10 UTC
Patch submitted to gerrit: https://gerrit.libreoffice.org/#/c/57077/
Comment 12 Commit Notification 2018-07-07 18:52:57 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=614804f034a114544dc14047e72ca18a946fbae3

tdf#101930: Allow page up/down and first/last page in read-only mode

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2018-07-07 18:53:07 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c3bc3a59cd44ee4eb75c22084f825ce61ba217b0&h=libreoffice-6-1

tdf#101930: Allow page up/down and first/last page in read-only mode

It will be available in 6.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Federico Mena-Quintero 2018-07-08 09:43:31 UTC
Thanks for fixing this!
Comment 15 Commit Notification 2018-07-09 14:16:22 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1ba1279ed2163305a1a88c520b888ffa49e4dbb9&h=libreoffice-6-0

tdf#101930: Allow page up/down and first/last page in read-only mode

It will be available in 6.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.