Bug Hunting Session
Bug 106837 - Slide navigation shortcuts and uno commands don't work in file opened read-only
Summary: Slide navigation shortcuts and uno commands don't work in file opened read-only
Status: RESOLVED DUPLICATE of bug 101930
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Main-Menu Shortcuts-Accelerators Read-Only
  Show dependency treegraph
 
Reported: 2017-03-28 19:07 UTC by dlenski@gmail.com
Modified: 2018-05-31 18:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of grayed-out Slide | Navigate menu (49.17 KB, image/png)
2017-03-28 19:08 UTC, dlenski@gmail.com
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dlenski@gmail.com 2017-03-28 19:07:39 UTC
Description:
When I open a presentation file in read-only mode, the normal shortcuts for navigation within the document don't work, and the only way to navigate from slide to slide is with the mouse.

The entire Slide | Navigate menu is grayed-out.

Steps to Reproduce:
1. Open a presentation file in read-only mode
2. Attempt to use Page Up / Page Down shortcuts, or Slide | Navigate menu.

Actual Results:  
Nothing happens

Expected Results:
Moving to next or previous slide


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/56.0.2924.76 Chrome/56.0.2924.76 Safari/537.36
Comment 1 dlenski@gmail.com 2017-03-28 19:08:24 UTC
Created attachment 132236 [details]
Screenshot of grayed-out Slide | Navigate menu
Comment 2 Xisco Faulí 2017-03-29 07:53:35 UTC
Hello,

it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version.
Comment 3 QA Administrators 2018-01-02 10:15:25 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2018-01-29 10:36:27 UTC Comment hidden (obsolete)
Comment 5 Yousuf Philips (jay) (retired) 2018-01-30 23:57:18 UTC
regression as it works fine in 5.0.6.

Version: 6.1.0.0.alpha0+
Build ID: e29565272c57c6cd09cb015c2e66bfe8a1f4d7d2
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 6 Buovjaga 2018-05-31 18:58:36 UTC
Bisected with bibisect-win32-5.1 to https://cgit.freedesktop.org/libreoffice/core/commit/?id=0145083c067effe56cc30c7ea4b2e95b9f600d17

author	Yousuf Philips
commit	0145083c067effe56cc30c7ea4b2e95b9f600d17 (patch)
tree	d0af0b890c49ca486b97c8df9adf4836a0eecead
parent	8bbd11758537eff98b5cfc08c55091dec54b4bf6 (diff)
tdf#91909 Add shortcuts to slide navigation
Change-Id: If9819ec8065d0bdce9604ed74b7b0571b24580b0
Reviewed-on: https://gerrit.libreoffice.org/20070

Found a dupe by searching with the commit hash through comments

*** This bug has been marked as a duplicate of bug 101930 ***