Download it now!
Bug 102512 - UI: search settings from in Search and Replace (Ctrl+H) dialog frustrate work with Find bar (Ctrl+F) - should not be used
Summary: UI: search settings from in Search and Replace (Ctrl+H) dialog frustrate work...
Status: RESOLVED DUPLICATE of bug 62601
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2016-09-25 19:12 UTC by Cor Nouws
Modified: 2018-05-22 16:27 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2016-09-25 19:12:13 UTC
When an option is set in the dialog Search & Replace, and one used Ctrl+F afterwards, the result is influenced by the option. (well, most options..)
Often one has to go to the dialog, open Options, change it etc etc.
Shrug...

One could argue for a check box in the Find tool bar: "use Search&Replace options"
Comment 1 Cor Nouws 2016-09-25 19:18:07 UTC
one would think that this was (partly) fixed in bug 62601
Comment 2 V Stuart Foote 2016-09-25 22:16:40 UTC
Believe work on bug 62601 simply removed all influence of the Find Bar by search settings made in the Find & Replace dialog. Don't see any real reason to reverse that--e.g. use the more functional Find & Replace dialog for the heavy lifting.

Anything bleeding thorough is probably undesired.

Do need a few enhancements to add specific per module toggles--e.g. bug 102506 to Find in Values rather than just in Formulas and text. But best to keep the Find Bar simplistic.

There is a valid issue as with bug 98544 of the Find & Replace not retaining settings search to search--needs to be captured into user profile.
Comment 3 Cor Nouws 2016-09-26 08:41:56 UTC
Hi Stuart,

(In reply to V Stuart Foote from comment #2)
> Believe work on bug 62601 simply removed all influence of the Find Bar by
> search settings made in the Find & Replace dialog.

Not for me. I have to reset options quite regularly.. But now testing in a daily it does work... Hmm, will look more in detail to that next days..

> Don't see any real reason
> to reverse that--e.g. use the more functional Find & Replace dialog for the
> heavy lifting.

In general: yes.

> Anything bleeding thorough is probably undesired.
> 
> Do need a few enhancements to add specific per module toggles--e.g. bug
> 102506 to Find in Values rather than just in Formulas and text. But best to
> keep the Find Bar simplistic.

Sounds OK for me. (And the request to search values by default could be considered.)

> There is a valid issue as with bug 98544 of the Find & Replace not retaining
> settings search to search--needs to be captured into user profile.

It looks as if a comprehensive set of decisions in this area, covering all open questions, would be good..
Comment 4 V Stuart Foote 2016-09-29 14:41:12 UTC
*** Bug 102781 has been marked as a duplicate of this bug. ***
Comment 5 Butch 2016-09-29 15:01:01 UTC
@Cor Nouws, V Stuart Foote:
Butch here, the author of the duplicate (see above). (My report was completely independent...)
My English is not good enough, I don't understand exactly how you comment this issue, but I would say: 
There should be no doubt that this basic searching method (with Ctrl+F as one of the oldes shortcuts in computers!) should be free of all confusing side considerations, attributes etc. A visitor who likes to show something in a document on my computer should be sure that Ctrl+F works without restrictions.
Comment 6 V Stuart Foote 2016-09-29 15:22:26 UTC
(In reply to Butch from comment #5)
> @Cor Nouws, V Stuart Foote:
> Butch here, the author of the duplicate (see above). (My report was
> completely independent...)

No, it is exactly a duplicate of what Cor reports in comment 0 -- that using the Find Bar (Ctrl+F) is influenced by prior usage/settings of the Find & Replace (Ctrl+H) dialog.

> My English is not good enough, I don't understand exactly how you comment
> this issue, but I would say: 

Your English is fine :-)

> There should be no doubt that this basic searching method (with Ctrl+F as
> one of the oldes shortcuts in computers!) should be free of all confusing
> side considerations, attributes etc. A visitor who likes to show something
> in a document on my computer should be sure that Ctrl+F works without
> restrictions.

Exactly, but the issue to be worked out is exactly what is searched for and when--and of course how to provide users control over the default behavior they prefer. 

Clearly the linkage between the Find & Replace dialog and the Find bar is not optimal. That leave a persistent setting for the Find Bar from a Tools -> Options panel, or as Expert Configuration stanzas.
Comment 7 Butch 2016-09-29 15:40:46 UTC
> Exactly, but the issue to be worked out is exactly what is searched for and when-

I still don't understand your view. "What is searched for" and "when"...the only consistent approach is to use Ctrl+F for the simplest form of search and the find&search dialog for every form of complex search, isn't it?
Comment 8 V Stuart Foote 2016-09-29 16:01:44 UTC
(In reply to Butch from comment #7)
> > Exactly, but the issue to be worked out is exactly what is searched for and when-
> 
> I still don't understand your view. "What is searched for" and "when"...the
> only consistent approach is to use Ctrl+F for the simplest form of search
> and the find&search dialog for every form of complex search, isn't it?

And how would you define the "simplest form of search"?  

The Find Bar -> uno:TextFind widget is present in each of the major modules (Writer, Calc, Imress/Draw--not in Base, Chart or the Formula editor).

So behavior of the common widget has to be tailored for data exposed in each module--defaults assigned, and a means of allowing the user to adjust the defaults implemented.  

Currently, settings bleeding over from Find & Replace are not reliable--so adjusting the UI and configuration of the Find Bar and its elements becomes necessary--to support "simplest form of search" that is *useable* in each module.
Comment 9 Butch 2016-09-29 20:06:57 UTC
> The Find Bar -> uno:TextFind widget is present in each of the major modules 

This is not relevant to an average user of Writer at all. As I said, Ctrl+F is one of the oldest "tools" in computing, and it should at least in a word processor remain what it always has been. There is no rational reason to support a tool which behaves in an inpredictable and intransparent way: You search for "happiness" in a document but you don't find it, just because you forgot that some time ago you was searching for bold titles in the document... There can be no argument of more weight than this one. ;-)
Comment 10 Cor Nouws 2017-01-01 21:31:10 UTC
don't see any reason why this shouldn't be closed as a duplicate -

*** This bug has been marked as a duplicate of bug 62601 ***