Bug 103486 - Tabs overlap the toolbar when OSX Dock configured to MDI mode
Summary: Tabs overlap the toolbar when OSX Dock configured to MDI mode
Status: RESOLVED DUPLICATE of bug 114985
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 104978 105704 106425 106633 109131 112176 112709 113292 113389 113528 113531 (view as bug list)
Depends on:
Blocks: Full-Screen-Mode
  Show dependency treegraph
 
Reported: 2016-10-25 09:06 UTC by Marc
Modified: 2018-01-28 14:19 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (94.70 KB, image/png)
2016-10-25 09:06 UTC, Marc
Details
settings page (382.44 KB, image/png)
2016-10-26 08:00 UTC, Marc
Details
No Full Screen Mode (423.64 KB, image/png)
2016-10-26 10:47 UTC, Marc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc 2016-10-25 09:06:31 UTC
Description:
If I open multiple documents the tabs overlap the toolbar at the top so I cant see the top toolbar anymore.

See: http://imgur.com/wHhEn5y 

Steps to Reproduce:
1. Open multiple documents

Actual Results:  
Tabs overlap the toolbar

Expected Results:
Show the tabs above the toolbar


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/53.0.2785.143 Safari/537.36
Comment 1 Marc 2016-10-25 09:06:54 UTC
Created attachment 128237 [details]
screenshot
Comment 2 Alex Thurgood 2016-10-25 15:15:50 UTC
@Marc : not sure where you got that screenshot from, but LO doesn't have, to my knowledge, a functioning MDI (multiple document interface) with tabbing like you have displayed.

Please explain how you arrived at such a situation with detailed steps on how to reproduce.
Comment 3 Alex Thurgood 2016-10-25 15:16:51 UTC
Are you using an extension of some kind, or a particular download version of LibreOffice from a different site ?
Comment 4 Marc 2016-10-26 07:59:42 UTC
Hi Alex,

Thanks for responding! Obviously I made the screenshot myself. I downloaded the version of LO from the main website. https://nl.libreoffice.org/download/libreoffice-fris/ to be precise. I didn't install any extensions or whatsoever. I would have like to explain step by step what I did, but it was nothing more than downloading and installing. It was like this from the start.

I've tried to reinstall, but both Fresh and Still do the same. I'll add another screenshot to show you.

The last thing I can tell you is that I use macOS Sierra 10.12 16A323.
Comment 5 Marc 2016-10-26 08:00:11 UTC
Created attachment 128278 [details]
settings page
Comment 6 Jean-Baptiste Faure 2016-10-26 08:22:46 UTC
Please, could you try with a clean new user profile ?
See https://wiki.documentfoundation.org/UserProfile

Best regards. JBF
Comment 7 Marc 2016-10-26 08:38:18 UTC
I have removed LO. Then removed my User Profile. Reinstalled LO Fresh, but it didn't solve the problem.
Comment 8 Jean-Baptiste Faure 2016-10-26 08:49:24 UTC
(In reply to Marc from comment #7)
> I have removed LO. Then removed my User Profile. Reinstalled LO Fresh, but
> it didn't solve the problem.

Do you have an old LO 3 or OpenOffice.org profile? If this the case you should, before removing your current user profile, remove or rename it to prevent LO 5 to migrate this old profile.

Best regards. JBF
Comment 9 Marc 2016-10-26 09:01:45 UTC
I have a freshly installed MacBbook and I've never installed any version of LO before. I double checked the /Users/<user name>/Library/Application Support/ folder for any other versions, but there is nothing.
Comment 10 Alex Thurgood 2016-10-26 10:24:19 UTC
All of my documents open in separate application windows on OSX (even in Sierra). I don't understand why yours do not.

Do you have some special extension, or additional programme installed that allows you to do that, or are you working in full screen mode or something similar ?
Comment 11 Alex Thurgood 2016-10-26 10:29:46 UTC
Ah, I've found it. You have activated full screen mode and have opened further documents from there (which you didn't mention in your initial report).

What you also didn't mention is that the tabs only overlap the toolbar when you move the mouse cursor up to the top of the screen to display the LibreOffice main menu.

Confirming. This is another bug linked to incomplete and now deprecated code that attempts to mimic full screen support for LibreOffice in OSX. It has never worked.
Comment 12 Alex Thurgood 2016-10-26 10:33:47 UTC
Note that in this particular situation, when the user leaves fullscreen mode, they can be left with a weird main application window containing tabbed documents which do indeed overlap the toolbar. If that window is then closed, all of the documents are closed.

This would require further investigation in a debugger to find out exactly what is going on, but considering that it relates to our "pseudo-fullscreen" code that doesn't do what Apple wants, it is unlikely to be fixed in the near future.
Comment 13 Marc 2016-10-26 10:47:25 UTC
Created attachment 128283 [details]
No Full Screen Mode

Hmm, that is funny. I have to tell you I am new to macOS so I might have done something, but I don't use any unusual software or extension. Atleast not that I know of. Colleagues don't have this issue either.

Do you mean Full Screen Mode under View > Full Screen. Because I didn't activate this. I didn't mention any of these things because I don't think they apply. See the new screenshot. This is not Full Screen Mode, is it? It doesn't have to do anything with the toolbar itself. The tabs overlap the top of any window. But I might be wrong.
Comment 14 Alex 2016-11-27 00:50:59 UTC
One woman's/man's/child's feature is another childs's/woman's/man's bug.

macOS Sierra (ver. 10.12.0 and up) introduced in September 2016, has a new feature - tabbed windows.

The feature is configured in: System Preferences --> Dock --> "Prefer tabs when opening windows:" which can be set to one of:
  * Always
  * In Full Screen Only
  * Manually

When this OS-level feature kicks-in on LibreOffice (LO), all LO windows are opened as tabs in a single window - that's nice, right? Wrong, because you also get a row of tab labels displayed immediately under the window title-bar, overlapping the top of LO window content that you just might like to see.

Workaround suggestions:
-----------------------

 * Live the life of a normal person, without everything tabbed, by setting "System Preferences" --> Dock --> "Prefer tabs when opening windows:" to "Manually". IMHO the Sierra tabs are a tad unsightly and bland - you won't miss them. Mission Control is a cool/slick/useful macOS feature with handy keyboard shortcuts, which makes the job of navigating between a plethora of windows real easy.

 * If you can't tear yourself away from the new shiny apple-scented eden of tabs, and you care to see all of your LO window content as well, then right-click the lovely (but obstructing) tab header in LO window, and select "Move Tab To New Window", every time the tabs pop-up, again, and again and again...
Comment 15 Antonio Faoro 2016-12-29 15:27:51 UTC
*** Bug 104978 has been marked as a duplicate of this bug. ***
Comment 16 Alex Thurgood 2017-02-03 11:03:03 UTC
Altering title as a consequence of comment 14 - thanks Alex for this !
Comment 17 Alex Thurgood 2017-02-03 11:03:45 UTC
*** Bug 105704 has been marked as a duplicate of this bug. ***
Comment 18 Alex Thurgood 2017-02-03 11:05:03 UTC
See comment 14 of bug 103486 for how to workaround this problem.
Comment 19 dbelya01 2017-02-03 14:18:25 UTC
(In reply to Alex Thurgood from comment #18)
> See comment 14 of bug 103486 for how to workaround this problem.

I think comment 18 was supposed to go into Bug 105704, I'll copy paste it there in case someone has the same issue and finds it.

also want to take a moment to respond to comment 14 here: you mock us tab-enablers, but the feature exists because it's useful to some of us.  

also this doesn't just happen in full-screen mode since the tab-for-new-docs can be enabled as "always" in the system settins
Comment 20 Alex Thurgood 2017-02-03 15:23:38 UTC
(In reply to dbelya01 from comment #19)
> (In reply to Alex Thurgood from comment #18)
> > See comment 14 of bug 103486 for how to workaround this problem.
> 
> I think comment 18 was supposed to go into Bug 105704, I'll copy paste it
> there in case someone has the same issue and finds it.

Correct, my bad, thanks for copying it over.


> 
> also want to take a moment to respond to comment 14 here: you mock us
> tab-enablers, but the feature exists because it's useful to some of us.  
> 
> also this doesn't just happen in full-screen mode since the tab-for-new-docs
> can be enabled as "always" in the system settins


I changed the title to reflect that it wasn't just in fullscreen mode. I didn't know that this option even existed until today, but when I initially confirmed this bug, I could only reproduce the behaviour described after having put LO into fullscreen mode and opening further documents.

Personally, I would very much like to have a functional MDI, but what I would like doesn't necessarily mean I get to have it ;-)
Comment 21 dbelya01 2017-02-03 18:07:33 UTC
> Personally, I would very much like to have a functional MDI, but what I
> would like doesn't necessarily mean I get to have it ;-)

now you can with almost no effort, at least on one platform
just gotta figure out this one little bug ;)
Comment 22 Alex Thurgood 2017-03-09 11:58:04 UTC
*** Bug 106425 has been marked as a duplicate of this bug. ***
Comment 23 Xisco Faulí 2017-03-19 11:42:46 UTC
*** Bug 106633 has been marked as a duplicate of this bug. ***
Comment 24 Marcel Dorn 2017-03-20 09:38:43 UTC
I also have this "bug" and was looking for a solution on this forum. Personally I also prefer the option to tab documents (without it covering the toolbar, obviously). Maybe this can go on a feature request list at Libreoffice?

(In reply to Alex Thurgood from comment #20)
> (In reply to dbelya01 from comment #19)
> > (In reply to Alex Thurgood from comment #18)
> > > See comment 14 of bug 103486 for how to workaround this problem.
> > 
> > I think comment 18 was supposed to go into Bug 105704, I'll copy paste it
> > there in case someone has the same issue and finds it.
> 
> Correct, my bad, thanks for copying it over.
> 
> 
> > 
> > also want to take a moment to respond to comment 14 here: you mock us
> > tab-enablers, but the feature exists because it's useful to some of us.  
> > 
> > also this doesn't just happen in full-screen mode since the tab-for-new-docs
> > can be enabled as "always" in the system settins
> 
> 
> I changed the title to reflect that it wasn't just in fullscreen mode. I
> didn't know that this option even existed until today, but when I initially
> confirmed this bug, I could only reproduce the behaviour described after
> having put LO into fullscreen mode and opening further documents.
> 
> Personally, I would very much like to have a functional MDI, but what I
> would like doesn't necessarily mean I get to have it ;-)
Comment 25 Mark Simon 2017-03-20 21:12:13 UTC
My own bug (106633) has be marked as a duplicate of this bug. However, it should be mentioned that the bug affects dialog boxes as well as ordinary windows.

I regard myself as a relatively normal person, and I do like the MDI interface for normal windows. I appreciate that the suggestion of disabling MDI is just workaround, but the issues does highlight a problem with the way windows are beign handled in LO.

In particular dialog boxes should not be handled the same way. The problem with the toolbar display in ordinary windows is one thing, but dialog boxes shouldn’t be docked at all.

I have other software on my Mac which handles windows properly:

- Merging windows in an option in the Window menu
- Merged windows are clean and the scace is adjusted properly
- Dialog boxes are not merged but remain separate

I hope this information is helpful.
Comment 26 Xisco Faulí 2017-07-15 13:31:38 UTC
*** Bug 109131 has been marked as a duplicate of this bug. ***
Comment 27 Bachsau 2017-07-17 08:40:40 UTC
The fact that this bug exists, shows that LibreOffice is in some way incorrectly using the window manager's API. This definitely should be fixed.
Comment 28 Telesto 2017-09-03 07:13:08 UTC
*** Bug 112176 has been marked as a duplicate of this bug. ***
Comment 29 Alex Thurgood 2017-10-23 12:10:03 UTC
*** Bug 113292 has been marked as a duplicate of this bug. ***
Comment 30 Maxim Monastirsky 2017-10-23 22:29:41 UTC
*** Bug 113389 has been marked as a duplicate of this bug. ***
Comment 31 Maxim Monastirsky 2017-10-30 19:33:32 UTC
*** Bug 113528 has been marked as a duplicate of this bug. ***
Comment 32 Xisco Faulí 2017-10-31 06:48:31 UTC
*** Bug 113531 has been marked as a duplicate of this bug. ***
Comment 33 Adolfo Jayme 2017-11-01 19:20:11 UTC
*** Bug 112709 has been marked as a duplicate of this bug. ***
Comment 34 Xisco Faulí 2017-11-02 08:48:23 UTC
*** Bug 113531 has been marked as a duplicate of this bug. ***
Comment 35 Maxim Monastirsky 2018-01-28 14:19:04 UTC

*** This bug has been marked as a duplicate of bug 114985 ***