Bug 103814 - Text appears compressed in a particular PPTX presentation
Summary: Text appears compressed in a particular PPTX presentation
Status: RESOLVED DUPLICATE of bug 103725
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha1+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2016-11-09 18:45 UTC by Aron Budea
Modified: 2016-11-12 00:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Slide screenshot with common layout enabled (158.63 KB, image/png)
2016-11-09 18:45 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2016-11-09 18:45:00 UTC
Created attachment 128621 [details]
Slide screenshot with common layout enabled

Open attachment 128104 [details] from bug 103347.
See slide 7 (screenshot attached) or slide 10 (plus similar issues in a few other slides).
Slides look fine with common layout turned off.

Version: 5.3.0.0.alpha1+
Build ID: a6ce5d391476e4b6a2cb2d92ff45548c1d75684b
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-04_00:03:22
Locale: hu-HU (hu_HU); Calc: CL
Comment 1 Xisco Faulí 2016-11-09 18:49:07 UTC
I can't reproduce it in

Version: 5.3.0.0.alpha1+
Build ID: 8a2a3f1032b4e60f7607e3ecb1ff99a6bb9af7f9
CPU Threads: 4; OS Version: Linux 4.2; UI Render: GL; VCL: gtk2; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 2 Aron Budea 2016-11-09 19:06:38 UTC
Indeed, I couldn't reproduce it in Linux, either with daily build from 2016-11-06_23:07:09. Setting OS to Windows.

Note that by default Linux doesn't have Constantia font that's used in the presentation (I installed it as described in [1]), but it doesn't matter, the slides look okay with and without font substitution.

[1] http://www.pcworld.com/article/2863497/how-to-install-microsoft-fonts-in-linux-office-suites.html
Comment 3 Xisco Faulí 2016-11-10 11:42:15 UTC
Confirmed in

Version: 5.3.0.0.alpha1+
Build ID: f6391d9696bfa7485bf785ac81edef4d5441e232
CPU Threads: 2; OS Version: Windows 6.1; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-11-10_00:11:47
Locale: es-ES (es_ES); Calc: group
Comment 4 Khaled Hosny 2016-11-10 21:46:20 UTC
Font scaling issue.

*** This bug has been marked as a duplicate of bug 103725 ***
Comment 5 Aron Budea 2016-11-12 00:58:26 UTC
Confirmed fixed in:

Version: 5.3.0.0.alpha1+
Build ID: 0d6f974b97597744119db9dc3d193aeeb8f9d3fa
CPU Threads: 4; OS Version: Windows 6.1; UI Render: GL; Layout Engine: new; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-11-11_23:56:36
Locale: hu-HU (hu_HU); Calc: CL