Bug 103978 - FILEOPEN: DOCX: Table is displayed behind the text
Summary: FILEOPEN: DOCX: Table is displayed behind the text
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Justin L
URL:
Whiteboard: target:6.0.0 target:5.3.8 target:5.4.4
Keywords: bibisected, bisected, filter:docx, regression
: 105794 (view as bug list)
Depends on:
Blocks: DOCX-Tables
  Show dependency treegraph
 
Reported: 2016-11-17 10:57 UTC by Xisco Faulí
Modified: 2017-11-08 08:22 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
InTheBackgroundTestShape.docx: simplified unit test (34.61 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-07-07 00:28 UTC, Justin L
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2016-11-17 10:57:09 UTC
1. Open attachment 98549 [details]

Observed behaviour: Table on first page is displayed behind the text

Reproduced in 

Version: 5.3.0.0.alpha1+
Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout
Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

but not in

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e
Comment 1 Xisco Faulí 2016-11-17 10:58:38 UTC
Regression introduced by:

author	Miklos Vajna <vmiklos@collabora.co.uk>	2014-06-18 09:57:31 (GMT)
committer	Miklos Vajna <vmiklos@collabora.co.uk>	2014-06-18 10:09:15 (GMT)
commit	d379d18666aa42031359ca8eb34b0021960347ae (patch)
tree	d0324e2297be256e8c291cd6e17676f68f9f072d
parent	8e67a7796f598de2f11b694542bccb48343f0d9a (diff)

oox: import WPS shape with text as shape with textbox

This allows having real shapes (like having rounded corners) and complex
content (like containing a table) at the same time.

WPS shapes are wrappers around drawingML markup in DOCX files, so this
only affects the DOCX import.

Adding Cc: to Miklos Vajna
Comment 2 Xisco Faulí 2017-02-06 13:23:28 UTC
*** Bug 105794 has been marked as a duplicate of this bug. ***
Comment 3 Hugo 2017-02-06 13:32:37 UTC
Xisco Faulí: thanks for so quickly pointing out the duplicate!

I can confirm this behaviour, see also bug 105794.
Comment 4 Xisco Faulí 2017-04-25 18:29:55 UTC
*** Bug 107428 has been marked as a duplicate of this bug. ***
Comment 5 Hugo 2017-04-25 19:52:19 UTC
Given there's now a few cases reported (see the duplicate bug reports), each of which has attachments illustrating the problem, perhaps the status can be updated to "confirmed"?
Comment 6 Justin L 2017-07-07 00:28:35 UTC
Created attachment 134522 [details]
InTheBackgroundTestShape.docx: simplified unit test

proposed fix: gerrit.libreoffice.org/39671.
Comment 7 Justin L 2017-07-07 00:37:13 UTC
This fixes this bug's 304_Optimised.docx, and bug 105794's lege brief - En.docx. Bug 107428 has no background frames, so a different (but related) problem.
Comment 8 Commit Notification 2017-07-15 01:40:15 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cc438f60d6ad0855f754dd32da9c9a80c7cabf92

tdf#103978 textboxhelper: syncProperty OPAQUE (wrap in background)

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Xisco Faulí 2017-08-01 23:22:51 UTC
Verified in

Version: 6.0.0.0.alpha0+
Build ID: 50799a721c7ddcf9475a1b79984ed64ddd7cdf57
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 10 Commit Notification 2017-11-08 08:20:47 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d71ac6936bd47e4e19d25c2c10c51d41ae759991&h=libreoffice-5-3

tdf#103978 textboxhelper: syncProperty OPAQUE (wrap in background)

It will be available in 5.3.8.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2017-11-08 08:22:32 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1649d5dfaca6fb29e75bd18e3e0d4f985a9eebeb&h=libreoffice-5-4

tdf#103978 textboxhelper: syncProperty OPAQUE (wrap in background)

It will be available in 5.4.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.