Bug 104567 - Crashing while closing LibO Writer after pasting shape from Draw, Crash in: SdTransferable::ObjectReleased()
Summary: Crashing while closing LibO Writer after pasting shape from Draw, Crash in: S...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 104286 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-12-10 20:27 UTC by Telesto
Modified: 2017-01-08 22:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature: ["SdTransferable::ObjectReleased()"]


Attachments
Example file (9.52 KB, application/postscript)
2016-12-10 20:27 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2016-12-10 20:27:14 UTC
Description:
LibreOffice is crashing will closing

Steps to Reproduce:
1.Open attached file in Draw
2.Open Writer (New document)
3.Copy the smiley in Draw
4.Paste it into the new Writer document
5.Close Draw
6.Close Writer (Click No save)


Actual Results:  
Crash

Expected Results:
No crash


Reproducible: Always

User Profile Reset: No

Additional Info:
Version: 5.4.0.0.alpha0+
Build ID: b894104a0b02a9b074c76feb925389d7bee6a493
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-10_01:00:52
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Comment 1 Telesto 2016-12-10 20:27:41 UTC
Created attachment 129465 [details]
Example file
Comment 2 tommy27 2016-12-11 21:25:34 UTC
not reproducible using LibO 5.2.3.3 under Win8.1 x64

reproducible using LibO 5.4.0.0.alpha0+
Build ID: 33f5bc54aaa7fe7aa9335726e30f9c349155e04d
CPU Threads: 4; OS Version: Windows 6.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-12-01_23:21:05
Locale: it-IT (it_IT); Calc: group

status NEW
edited summary notes
Comment 3 raal 2016-12-16 18:43:13 UTC
This seems to have begun at the below commit.
Adding Cc: to Tomaž Vajngerl; Could you possibly take a look at this one? Thanks

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2016-11-23 16:01:46 (GMT)
committer	Tomaž Vajngerl <quikee@gmail.com>	2016-11-24 14:26:30 (GMT)
commit	c53cf1dfc5eacd8fee6b2b549ec6b59ad927e01c (patch)
tree	d606badf14936a325876ea089389517cc637d253
parent	93154946452fdedad9b8b536ec3d9704a4707304 (diff)
tdf#103852 avoid clipboard deadlock

e06c68b74e0c470815a67a3c784224d86ff9b85c is the first bad commit
commit e06c68b74e0c470815a67a3c784224d86ff9b85c
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Nov 24 11:30:51 2016 -0800

    source sha:c53cf1dfc5eacd8fee6b2b549ec6b59ad927e01c
 git bisect log
# bad: [479ca41474b9720803421ab7717aa69fa6c60528] source sha:f8c463b393885b660500bf4f7f73b4fb90ce2389
# good: [defb73f1c6e2a66dbd21ba89e684f57427e8bc4b] source sha:5b168b3fa568e48e795234dc5fa454bf24c9805e
git bisect start 'origin/master' 'oldest'
# good: [1c50425620ffbce30bb57f9ff19ef3c5d20d69f1] source sha:b62f4c2cd9685618fff2270760ce0787880f1c8d
git bisect good 1c50425620ffbce30bb57f9ff19ef3c5d20d69f1
# good: [70770f0ce4d3672d5cd2759605adb44d867e7208] source sha:0b7e11a2a7ade0b565c18d1deb58c19848f6ceef
git bisect good 70770f0ce4d3672d5cd2759605adb44d867e7208
# good: [ce5c761b06e108ba3a25fccda8acb9d3c2aedaba] source sha:ea6b378221efea0392c5085d621ff38a612ade3e
git bisect good ce5c761b06e108ba3a25fccda8acb9d3c2aedaba
# good: [d385e273cdb47c051f2718c82758a9ad10364233] source sha:40f8c14be28aeb78fe758264b43a255d2bfd4938
git bisect good d385e273cdb47c051f2718c82758a9ad10364233
# good: [48729d96c1f2aff794a59c54c71efa3ac119a3a9] source sha:ebf04205508227a245885ecb367f1fc8abbd6591
git bisect good 48729d96c1f2aff794a59c54c71efa3ac119a3a9
# good: [817b5433ac03e8b48c207374aae11cae3f13f798] source sha:75fb3f79c3ba5e94740cea947527477bba50b358
git bisect good 817b5433ac03e8b48c207374aae11cae3f13f798
# bad: [14162cabb15aa4fb34db3cba75b14ca7c8d70a4b] source sha:8114a779143a7f0042d7e15b476037315ed2b4c3
git bisect bad 14162cabb15aa4fb34db3cba75b14ca7c8d70a4b
# bad: [60bccbcbaa004096130e1d63a7ed9830ff009740] source sha:2ce21dd8b9075486f92c18ac007f61a27062ce63
git bisect bad 60bccbcbaa004096130e1d63a7ed9830ff009740
# good: [4ae8806d9031c7907e8b54489b4368ce60807688] source sha:29dbac6fe556eb27067155c3be0c566b5328995c
git bisect good 4ae8806d9031c7907e8b54489b4368ce60807688
# good: [f2c1df4e70c54ce4ab134976530c7f93b84d6500] source sha:93154946452fdedad9b8b536ec3d9704a4707304
git bisect good f2c1df4e70c54ce4ab134976530c7f93b84d6500
# bad: [4b46fd89a6bbb5b62b032d5db20a1c6ac928445c] source sha:4f8eff151e8ec71eb1a5b6757d9b17d3224d67ca
git bisect bad 4b46fd89a6bbb5b62b032d5db20a1c6ac928445c
# bad: [da22ce871d82bc6a5dba828f1a19f75000681a8e] source sha:c100e38b49512512b11a0c594f244a4937bc6d66
git bisect bad da22ce871d82bc6a5dba828f1a19f75000681a8e
# bad: [e06c68b74e0c470815a67a3c784224d86ff9b85c] source sha:c53cf1dfc5eacd8fee6b2b549ec6b59ad927e01c
git bisect bad e06c68b74e0c470815a67a3c784224d86ff9b85c
# first bad commit: [e06c68b74e0c470815a67a3c784224d86ff9b85c] source sha:c53cf1dfc5eacd8fee6b2b549ec6b59ad927e01c
Comment 4 JoNi 2016-12-26 09:25:43 UTC
*** Bug 104286 has been marked as a duplicate of this bug. ***
Comment 5 Telesto 2016-12-30 14:20:31 UTC
No repro anymore with:
Version: 5.4.0.0.alpha0+
Build ID: a7c51323b7343f82b5aea6098f5d5e31a8bad0e9
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-12-29_23:35:20
Locale: nl-NL (nl_NL); Calc: CL

Probably fixed by: http://cgit.freedesktop.org/libreoffice/core/commit/?id=db1726216ba200c8a55c23a9d8c2ffd2066263a7

process all outstanding events before shutdown, tdf#104969, tdf#104286, tdf#104399