Bug 105000 - Palettes and color names are not localizable
Summary: Palettes and color names are not localizable
Status: ASSIGNED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Gabor Kelemen
URL:
Whiteboard: target:6.0.0 target:6.1.0 target:6.0....
Keywords: needsDevEval, topicUI
: 114097 (view as bug list)
Depends on:
Blocks: Color-Palettes Not-Localizable
  Show dependency treegraph
 
Reported: 2016-12-30 12:40 UTC by Martin Srebotnjak
Modified: 2018-02-15 16:45 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of palette names' list in Slovenian UI (35.38 KB, image/png)
2016-12-30 12:41 UTC, Martin Srebotnjak
Details
Screenshot of pallete name and a color name as tooltip - nonlocalizable (62.35 KB, image/png)
2018-02-12 20:28 UTC, Martin Srebotnjak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Srebotnjak 2016-12-30 12:40:01 UTC
Description:
The bundled palettes with LO 5.3 do not have localizable names.

Steps to Reproduce:
1. Open LO and a new or existing document in Writer.
2. Select some text and via icons or menus select color for background
3. In the color selection menu select the palette drop-down menu.

Actual Results:  
The list of available palettes' names is in English, some palettes have localized names (like "custom" and "Document Colors", the latter with capital letter), others are hard-coded. 

Expected Results:
Palette names should be localizable.


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:50.0) Gecko/20100101 Firefox/50.0
Comment 1 Martin Srebotnjak 2016-12-30 12:41:07 UTC
Created attachment 130027 [details]
Screenshot of palette names' list in Slovenian UI
Comment 2 Heiko Tietze 2017-01-04 08:25:04 UTC
Palette names were never localizable. The list shows just the file names (lower case is provided here for cross-platform compatibility; my try to change this was rejected) without the extension (modification with 5.3). "Custom" and "Document colors" are special inbuilt swatches without a file reference. It would require a mapping table to show a different name for the ordinary .soc palettes like breeze.soc = Breeze, which could then be matter of l10n. 

But first drawback is IMHO that we run into trouble with adding new palettes, for instance per extension. Plus, I don't understand why proper names need to get translated. Breeze=Lüftchen in German?

Clear WONTFIX for me.

PS: The issue with color names (White=Blanc) was asked by Sophie somewhere else. I reckon that translated colors are hard coded and Calc only for diagrams.
Comment 3 Yousuf Philips (jay) (retired) 2017-05-02 15:29:56 UTC
(In reply to Heiko Tietze from comment #2)
> Palette names were never localizable.

True as we only added multiple palettes in 4.4.

> "Custom" and "Document colors" are special inbuilt swatches without a file
> reference. It would require a mapping table to show a different name for the
> ordinary .soc palettes like breeze.soc = Breeze, which could then be matter
> of l10n. 

Yes this should be done, just like we've done it for bitmap preset names.

http://opengrok.libreoffice.org/xref/core/svx/source/dialog/sdstring.src#1624

> But first drawback is IMHO that we run into trouble with adding new
> palettes, for instance per extension. Plus, I don't understand why proper
> names need to get translated. Breeze=Lüftchen in German?

Well extensions should provide their own localizations, so dont see a problem there. If the german translation team prefer to leave proper names as is, then they are free to do so.

> PS: The issue with color names (White=Blanc) was asked by Sophie somewhere
> else. I reckon that translated colors are hard coded and Calc only for
> diagrams.

Localizing color name should also be done IMHO.
Comment 4 sophie 2017-05-03 12:55:00 UTC
(In reply to Yousuf Philips (jay) from comment #3)
> (In reply to Heiko Tietze from comment #2)
> > Palette names were never localizable.
> 
> True as we only added multiple palettes in 4.4.
> 
> > "Custom" and "Document colors" are special inbuilt swatches without a file
> > reference. It would require a mapping table to show a different name for the
> > ordinary .soc palettes like breeze.soc = Breeze, which could then be matter
> > of l10n. 
> 
> Yes this should be done, just like we've done it for bitmap preset names.
> 
> http://opengrok.libreoffice.org/xref/core/svx/source/dialog/sdstring.src#1624
> 
> > But first drawback is IMHO that we run into trouble with adding new
> > palettes, for instance per extension. Plus, I don't understand why proper
> > names need to get translated. Breeze=Lüftchen in German?
> 
> Well extensions should provide their own localizations, so dont see a
> problem there. If the german translation team prefer to leave proper names
> as is, then they are free to do so.
> 
> > PS: The issue with color names (White=Blanc) was asked by Sophie somewhere
> > else. I reckon that translated colors are hard coded and Calc only for
> > diagrams.
> 
> Localizing color name should also be done IMHO.

+1 to all your comments, thanks Jay,  and yes, color name should always be localized - Sophie
Comment 5 Gabor Kelemen 2017-08-27 19:16:08 UTC
Started working on the color names localization, first patch is in gerrit: 
https://gerrit.libreoffice.org/#/c/41330/
Comment 6 Gabor Kelemen 2017-09-20 07:54:56 UTC
Pushed all necessary patches to gerrit:

https://gerrit.libreoffice.org/#/c/41330/7 - standard
https://gerrit.libreoffice.org/#/c/41614/ - tango
https://gerrit.libreoffice.org/#/c/42513/1 - breeze
https://gerrit.libreoffice.org/#/c/42514/1 - chart
https://gerrit.libreoffice.org/#/c/42515/1 - tonal
https://gerrit.libreoffice.org/#/c/42516/1 - html

Don't worry about the merge conflicts, these are built on top of each other (sorry...) and committing them in this order should make the conflicts disappear.

Also this one to make the tonal palette patch actually work:
https://gerrit.libreoffice.org/#/c/42517/1

Color names that end with numbers or percentages need to be translated only once, the number or percentage is added to the end programmatically. The tonal palette has names that *start* with a percentage, so the code needs to be adjusted to help minimize translator effort. The alternative to this last patch is to change the tonal palette file to not start but end the color names with the percentage.
Comment 7 Commit Notification 2017-09-21 07:16:49 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=50a210d48b7db47eaaafeb5520bd796d8e690346

tdf#105000, related tdf#80196: Make new color names translatable

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2017-10-21 13:12:38 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fe5b70723fc83f229fb4b41231a663a8700f48c4

tdf#105000, related tdf#87538: Make new color names translatable

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2017-10-23 08:08:25 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6999bafb8675461a7f1400880eabd2daffe96ba4

tdf#105000, related tdf#87538: Make new color names translatable

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Yousuf Philips (jay) (retired) 2017-11-16 19:35:02 UTC
Gabor: Thanks for merging standard. Unfortunately we'll likely be removing tango (bug 113858) so i'll be reverting that patch of yours.
https://gerrit.libreoffice.org/#/c/44837/

It would be great if you could send in a patch to translate the palette names, as you didnt have a patch for that.
Comment 11 Heiko Tietze 2017-12-01 10:31:27 UTC
*** Bug 114097 has been marked as a duplicate of this bug. ***
Comment 12 Heiko Tietze 2017-12-01 10:33:13 UTC
There is also a request from the l10n team to make the palette name itself localizable. Doubt that it works for those installed per extension and also that localizing "Standard" or "Html" makes sense and will ever happen.
Comment 13 Martin Srebotnjak 2017-12-02 00:24:17 UTC
Heiko, it does mean sense, because in some languages "html" and "standard" do not mean a thing. What does "standard" mean in Chinese to an everage office suite user?

l10n means localization, of everything. Not of only things that the head of design team thinks makes sense to localize. If those strings can remain as they are in other languages, that are relevant questions for every l10n team.

Everyone should do their own job, professionally. Even if they are not professionals.

And the designers of UI should incorporate the l10n aspect in every pore of their work, not to be smart and decide for l10n teams what is worth localizing after it is discovered they have not done their job properly ...
Comment 14 Commit Notification 2017-12-02 10:20:05 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=83638a195dfde7255115cac84b2e9bb7e8e1b440

Revert "tdf#105000, related tdf#87538: Make new color names translatable"

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2017-12-03 19:33:11 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6a0e03bc6c1d6e9f3b66459d82274ecad7f16f58&h=libreoffice-6-0

Revert "tdf#105000, related tdf#87538: Make new color names translatable"

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2018-01-11 22:47:47 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8901c7c7bc4db5076a615ef942af6fb65e943ee3

tdf#105000, related tdf#80196: Make new color names translatable

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Xisco Faulí 2018-02-12 18:47:08 UTC
A polite ping to Gabor Kelemen: is this bug fixed? if so, could you
please close it as RESOLVED FIXED ? Thanks
Comment 18 Martin Srebotnjak 2018-02-12 20:23:19 UTC
It is not OK yet.
See the screenshot I am attaching (from fully, 100 % localized Slovenian 6.0.1.1 build.
Comment 19 Martin Srebotnjak 2018-02-12 20:28:31 UTC
Created attachment 139842 [details]
Screenshot of pallete name and a color name as tooltip - nonlocalizable

Some color names are still not localizable (see the tooltip - "Spring Green 50%" in English instead of Slovenian), also see palette name ("tonal").
Comment 20 Gabor Kelemen 2018-02-14 09:27:10 UTC
(In reply to Martin Srebotnjak from comment #19)
> Created attachment 139842 [details]
> Screenshot of pallete name and a color name as tooltip - nonlocalizable
> 
> Some color names are still not localizable (see the tooltip - "Spring Green
> 50%" in English instead of Slovenian), also see palette name ("tonal").

Yup, I should have cherry-picked that one to the 6-0 branch, sorry. Done now.

About the palette names, I don't see it yet where should the code be modified to translate those, so this part will take a bit more longer.
Comment 21 Commit Notification 2018-02-15 16:45:14 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=11d0e4d946950204fd9f1d23f206b91e8326388e&h=libreoffice-6-0

tdf#105000, related tdf#80196: Make new color names translatable

It will be available in 6.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.