Bug 105281 - Screen of the Display Options
Summary: Screen of the Display Options
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.3.0.1 rc
Hardware: All All
: medium normal
Assignee: Adolfo Jayme
QA Contact:
URL:
Whiteboard: target:5.4.0 target:5.3.4
Keywords:
: 105401 105403 107109 (view as bug list)
Depends on:
Blocks: Options-Dialog
  Show dependency treegraph
 
Reported: 2017-01-12 11:30 UTC by ThierryT
Modified: 2017-06-01 11:24 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Libreoffice options screen (28.35 KB, image/png)
2017-01-12 11:30 UTC, ThierryT
Details
view tab of options dialog in english (87.97 KB, image/png)
2017-01-19 09:20 UTC, Yousuf Philips (jay)
Details
View options in Finnish, 5.2.4 (65.68 KB, image/png)
2017-01-19 09:32 UTC, Buovjaga
Details
Slovenian Settings dialog on OS X (104.39 KB, image/png)
2017-03-27 07:28 UTC, miles
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ThierryT 2017-01-12 11:30:35 UTC
Created attachment 130355 [details]
Libreoffice options screen

Version: 5.3.0.1 (x64)
Build ID: 3b800451b1d0c48045de03b5b3c7bbbac87f20d9
Threads CPU : 4; Version de l'OS :Windows 6.29; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR); Calc: group

Menu Tools>Options
Windows LibreOffice>Display
The lists for the first 4 options are not display correctly.
Comment 1 Buovjaga 2017-01-14 17:29:19 UTC
It looks fine here.

Version: 5.4.0.0.alpha0+
Build ID: 9e7526044c8fa6b006b0cb791d15f2476c96ebf2
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-01-14_04:20:03
Locale: fi-FI (fi_FI); Calc: group
Comment 2 Adolfo Jayme 2017-01-15 20:05:59 UTC
@UX: Can we please have shorter labels for these controls in this tabpage?
Comment 3 Samuel Mehrbrodt (CIB) 2017-01-16 07:53:37 UTC
Maybe something like:
--------------------
*Icon Size*
  Sidebar:
  Notebookbar:
  Toolbar:

*Icon Style*
  Theme
--------------------

Although the dialog should expand itself if the widgets don't fit. Tomaž did something similiar for the Area style dialog.
Comment 4 Maxim Monastirsky 2017-01-18 09:16:24 UTC
*** Bug 105403 has been marked as a duplicate of this bug. ***
Comment 5 Maxim Monastirsky 2017-01-18 09:18:06 UTC
*** Bug 105401 has been marked as a duplicate of this bug. ***
Comment 6 Yousuf Philips (jay) 2017-01-19 09:19:41 UTC
(In reply to Adolfo Jayme from comment #2)
> @UX: Can we please have shorter labels for these controls in this tabpage?

The labels in english are short, so this is a french translation issue.

@Sophie: Any thoughts?
Comment 7 Yousuf Philips (jay) 2017-01-19 09:20:19 UTC
Created attachment 130549 [details]
view tab of options dialog in english
Comment 8 Buovjaga 2017-01-19 09:32:58 UTC
Created attachment 130550 [details]
View options in Finnish, 5.2.4

It's even worse with Finnish. You can't see the dropdowns.
Comment 9 kompilainenn 2017-01-19 09:43:15 UTC
(In reply to Yousuf Philips (jay) from comment #6)
> (In reply to Adolfo Jayme from comment #2)
> > @UX: Can we please have shorter labels for these controls in this tabpage?
> 
> The labels in english are short, so this is a french translation issue.
 

first - not only french, and russian also (see bug 105403)
second - not fact, that it is translation problem, because in 5.2 this wasn't
Comment 10 sophie 2017-01-19 09:52:26 UTC
(In reply to Yousuf Philips (jay) from comment #6)
> (In reply to Adolfo Jayme from comment #2)
> > @UX: Can we please have shorter labels for these controls in this tabpage?
> 
> The labels in english are short, so this is a french translation issue.
> 
> @Sophie: Any thoughts?

No way to reduce the length of the strings, each word is needed. Maybe change it as Samuel suggested by adding a generic 'Icon Size' string. Sophie
Comment 11 Yousuf Philips (jay) 2017-01-19 10:45:23 UTC
(In reply to Buovjaga from comment #8)
> It's even worse with Finnish. You can't see the dropdowns.

Well that relates to the translated text in the graphics output section being to long.

(In reply to kompilainenn from comment #9)
> first - not only french, and russian also (see bug 105403)
> second - not fact, that it is translation problem, because in 5.2 this wasn't

(In reply to sophie from comment #10)
> No way to reduce the length of the strings, each word is needed. Maybe
> change it as Samuel suggested by adding a generic 'Icon Size' string. Sophie

Well then we either fix the dialog not resizing to its needed size and/or change the strings as Samuel suggested.

My suggestion for changing the strings

*Icon*
 Style:
 Toolbar:
 Sidebar:
 Notebookbar:
Comment 12 Heiko Tietze 2017-01-19 12:36:48 UTC
Shorter labels make sense, but in the end the l10n needs to be concise. Perhaps you can add something to the tooltip. Or how does it work with line wrapping (\n)?
Comment 13 kompilainenn 2017-03-26 12:44:07 UTC
bug have fixed in 5.3.2.1 for RU GUI
Comment 14 Buovjaga 2017-03-26 16:14:34 UTC
(In reply to kompilainenn from comment #13)
> bug have fixed in 5.3.2.1 for RU GUI

Is the fixing commit hiding somewhere in here: https://cgit.freedesktop.org/libreoffice/core/log/?qt=grep&q=options
Comment 15 miles 2017-03-27 07:27:14 UTC
For Slovenian the localization cannot be shortened so Heiko, please address the issue of UI, not force localizers into translations that do not make sense.
See attached screenshot from OSX.
Comment 16 miles 2017-03-27 07:28:08 UTC
Created attachment 132166 [details]
Slovenian Settings dialog on OS X
Comment 17 sophie 2017-03-28 17:11:15 UTC
(In reply to Heiko Tietze from comment #12)
> Shorter labels make sense, but in the end the l10n needs to be concise.
> Perhaps you can add something to the tooltip. Or how does it work with line
> wrapping (\n)?

Nothing to add to the tooltip and no possibility for line wrap (where do you wrap the string?). If the dialog has the wrong size, change it or reorganize the labels so that we don't have to repeat "Size of the icons" in each string. There is no bug in l10n here :) Sophie
Comment 18 Adolfo Jayme 2017-03-29 09:23:46 UTC
Note to myself: OK, forwarding this to UX was useless; organize your time better and just do it yourself.

Patch coming…
Comment 19 Commit Notification 2017-03-29 09:28:16 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bd911c02594c77e1f7e8a01a364b6e0967d4db26

tdf#105281 Rearrange a few things for l10n-friendliness

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 sophie 2017-04-12 08:58:11 UTC
*** Bug 107109 has been marked as a duplicate of this bug. ***
Comment 21 Commit Notification 2017-06-01 11:24:12 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=828a54cfb944c1b98cd38628dbb8cb99fc86dfec&h=libreoffice-5-3

tdf#105281 Rearrange a few things for l10n-friendliness

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.