Download it now!
Bug 105489 - Scaling algorithm makes icons look ugly
Summary: Scaling algorithm makes icons look ugly
Status: RESOLVED DUPLICATE of bug 115439
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.2 rc
Hardware: x86-64 (AMD64) All
: high minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2017-01-23 19:10 UTC by Bojan
Modified: 2018-10-31 03:03 UTC (History)
16 users (show)

See Also:
Crash report or crash signature:


Attachments
Options screenshot (66.90 KB, image/png)
2017-01-23 19:10 UTC, Bojan
Details
LO Writer screenshot (50.22 KB, image/png)
2017-01-23 19:32 UTC, Bojan
Details
Screenshot of LO Writer with new document showing the icons in toolbar, side panels. (70.93 KB, image/png)
2017-05-02 07:20 UTC, Andreas Neudecker
Details
Icons too large and pixelated (74.14 KB, image/png)
2017-06-29 08:31 UTC, Melanie Bacou
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bojan 2017-01-23 19:10:45 UTC
Created attachment 130634 [details]
Options screenshot

LO 5.3.02, Linux, openSuse Leap 42.2, Plasma 5.8.5

The icons of the UI look terribly. In toolbar, in sidebar and in all possible bars. Even is I select small icons they appear big and ugly. Have tried all possible icon sets and options. No openGL is used. If I turn openGL on, LO wont start at all.
The problem occurred with LO 5.3, previous version were OK. The problem remains if LO is started with a brand new user profile.

Regards,
Bojan
Comment 1 Tomaz Vajngerl 2017-01-23 19:22:15 UTC
... any screenshot so we can see what you are referring to?
Comment 2 Bojan 2017-01-23 19:32:23 UTC
Created attachment 130636 [details]
LO Writer screenshot

Attached is a screenshot of LO Writer. The same with Calc and all other modules (Impress, Draw, ...)
Comment 3 Buovjaga 2017-01-24 08:23:48 UTC
Is there anything special about your KDE antialiasing settings?
Comment 4 Bojan 2017-01-24 10:07:54 UTC
No, no special settings, and in particular no changes at all if compared to previous installation of LO 5.2. All applications and the Desktop of course, run smoothly, including Firefox, Thunderbird and other GTK based applications.
Comment 5 Buovjaga 2017-01-24 10:11:49 UTC
Aha, it works OK in KDE for me, so I have no idea of the problem.
Comment 6 Bojan 2017-01-24 10:53:34 UTC
Some more strange behaviour of LO53RC2.

I just installed it in my office, along with LO5.2. If ran as LO5.2 user, LO5.3 will not start. I ran it from the command line by cd /opt/libreoffice5.3/program and entered soffice. No message whatsoever and no running LO5.3. If LO5.2 user is renamed to 4_ok, a new directory 4 is created and LO5.3 runs without problems. Also UI icons are fine now.

The UI icons problem I have reported occured in my home laptop, however, all the settings are more or less the same. The user directory 4 is a tru copy of the 4 directory from my office. And as I already stressed, LO5.2 works fine and UI icons are fine, on both computers.
Comment 7 Buovjaga 2017-01-24 10:57:57 UTC Comment hidden (obsolete)
Comment 8 Bojan 2017-01-24 18:42:18 UTC
As I mentioned in my first post, starting LO with a new user profile makes no difference. Today, I tried again with a new user profile, re-installed Nvidia drivers, check all anti-aliasing settings, but no success at all. Not even a slight difference. Funny thing, if I reinstall LO5.2 everything runs fine and without any problem.
Comment 9 Bojan 2017-01-25 10:10:20 UTC
Some additional information on the issue.

My home computer is notebook (HP Elitebook), Nvidia graphic with a display of 1920x1080. The UI icons are ugly in LO5.3 but fine in LO5.2.

My office computer is a HP Z400 workstation, Nvidia Quadro K2000 graphic with a display of 2560x1440. Both, LO5.2 and LO5.3 present fine icons. However, LO5.3 ignores settings from LO5.2 user profile.
Comment 10 Buovjaga 2017-01-25 10:13:55 UTC
(In reply to Bojan from comment #9)
> Some additional information on the issue.
> 
> My home computer is notebook (HP Elitebook), Nvidia graphic with a display
> of 1920x1080. The UI icons are ugly in LO5.3 but fine in LO5.2.
> 
> My office computer is a HP Z400 workstation, Nvidia Quadro K2000 graphic
> with a display of 2560x1440. Both, LO5.2 and LO5.3 present fine icons.
> However, LO5.3 ignores settings from LO5.2 user profile.

Ok, so ignoring the talk of profile, please try with Safe Mode in 5.3 on your home notebook. Let's see what happens.
Comment 11 Bojan 2017-01-25 14:33:07 UTC
I made a fresh install of LO5.3. Started LO5.3 from the command line /opt/libreoffice5.3/program/soffice
and nothing had happened.
I renamed the LO5.2 user profile 4 to 4_OK nad started LO5.3 again as described above. Now, LO5.3 started but the UI is even uglier than before. Probably because icons are somewhat bigger. Or maybe I just imagine. Nevertheless, no antialiasing on UI and icons look terrible.

BTW: now I have both LO5.2 and LO5.3 installed. It is said on the LO website that they may coexist.
Comment 12 Buovjaga 2017-01-25 14:37:11 UTC
Could you try with Safe Mode, though?
Comment 13 Bojan 2017-01-25 14:59:51 UTC
Well, all what I wrote in my previous post has been done in both normal mode and Safe Mode.
Comment 14 Buovjaga 2017-02-11 20:38:51 UTC
*** Bug 105778 has been marked as a duplicate of this bug. ***
Comment 15 Buovjaga 2017-02-11 20:39:57 UTC
NEW per dupe.
Comment 16 Buovjaga 2017-02-12 17:46:21 UTC
*** Bug 105950 has been marked as a duplicate of this bug. ***
Comment 17 Buovjaga 2017-02-12 17:48:55 UTC
(In reply to Buovjaga from comment #16)
> *** Bug 105950 has been marked as a duplicate of this bug. ***

This affects Windows as well and is HiDPI-dependent.
Comment 18 Matt 2017-02-12 19:16:38 UTC
Let me know when there's a build I can test with my Windows hiDPI setup.
Comment 19 Buovjaga 2017-03-04 18:03:29 UTC
*** Bug 106191 has been marked as a duplicate of this bug. ***
Comment 20 Tilman Vogel 2017-03-07 15:12:55 UTC
I also see this on 5.3.0.3 on openSUSE 13.1. Worked fine before with 5.2.2.2. 

My xdpyinfo output lists

  resolution:    143x144 dots per inch

Could this be an issue? 

I know that e.g. firefox tries to be smart and scales up its UI on "high resolution" displays (> 72 dpi?). There, I need to set

layout.css.devPixelsPerPx = 1

in order to get back to 1:1 scaling prevent pixelated icons and overall space waste.
Comment 21 Tilman Vogel 2017-03-07 15:24:27 UTC
If I force font resolution to 196 as suggested here

https://wiki.documentfoundation.org/Development/HiDpi

the icons get even larger.

If I instead force to 96, the icons look non-pixelated but the UI text is smaller than expected.
Comment 22 Tilman Vogel 2017-03-07 15:28:06 UTC
If I force font resolution to 196 as suggested here

https://wiki.documentfoundation.org/Development/HiDpi

the icons get even larger.

If I instead force to 96, the icons look non-pixelated but the UI text is smaller than expected. 120 seems to be a reasonable workaround.

This is on KDE 4.11.5.
Comment 23 Ondřej Kučera 2017-03-19 17:45:55 UTC
The same happens to me on Arch Linux (LO 5.3.1, Plasma 5.9.3). My resolution is 1600x900 with 131x131 DPI.

It happens with SAL_USE_VCLPLUGIN set to kde4 (my long-time default), gtk or gen. With SAL_USE_VCLPLUGIN set to gtk3, icons are fine. However, with this value, "everything else" is smaller -- a document outline takes less space (with zoom level set to 100% in all test cases), a text with the font set to 12 points is much smaller (not only compared to other SAL_USE_VCLPLUGIN values but also in comparison with the same text using the same font in Calligra Words), etc.
Comment 24 Buovjaga 2017-03-26 17:39:35 UTC
*** Bug 106682 has been marked as a duplicate of this bug. ***
Comment 25 Andreas Neudecker 2017-05-02 07:20:00 UTC
Created attachment 133003 [details]
Screenshot of LO Writer with new document showing the icons in toolbar, side panels.
Comment 26 Andreas Neudecker 2017-05-02 07:21:12 UTC
Comment on attachment 133003 [details]
Screenshot of LO Writer with new document showing the icons in toolbar, side panels.

I have the same problem with Version: 5.3.1.2 (Build-ID: 1:5.3.1-0ubuntu2, amd64) on a 12" laptop with a 1280x800 display. I checked Tango, Galaxy, and Elementary icon sets, always with the same result: icons are displayed somewhat larger than they used to be (using small icons setting), and are very badly scaled. I am wondering: is LO upscaling small png icons or scaling svg icons badly?
Comment 27 Andreas Neudecker 2017-05-02 07:23:19 UTC
PS: I am running LO on XFCE in Xubuntu 17.04.
Comment 28 Melanie Bacou 2017-06-29 08:31:22 UTC
Created attachment 134375 [details]
Icons too large and pixelated

Ubuntu 16.10 Gnome 3.22
Comment 29 Melanie Bacou 2017-06-29 08:33:26 UTC
I'm also on a 125 ppi display.
Comment 30 Buovjaga 2017-08-21 16:45:37 UTC
*** Bug 110457 has been marked as a duplicate of this bug. ***
Comment 31 Bojan 2017-09-29 09:27:20 UTC
The bug is still present.

OS opensuse Leap 42.3, LO 5.4.1, notebook resolution 1920x1080

Bojan
Comment 32 dennis-r 2017-10-23 19:07:03 UTC
New 6.0.0.alpha1 is also affected.

Tested on Ubuntu 16.04, Linux Mint 18.2 with screen resolution 1920x1080
Comment 33 Anton Kochkov 2017-12-04 17:00:21 UTC
Very ugly icons at 

Huawei Matebook E 12 Windows 10 64bit
Screen size 2160x1440 pixels

Version: 6.0.0.0.alpha1 (x64)
Build ID:c1d1f859b268f650143d48f294999cda0fa57350
CPU 线程:4; 操作系统:Windows 10.0; UI 渲染:默认; 
Locale: en-US (en_US); Calc: group

Screenshot:  bugs.documentfoundation.org/attachment.cgi?id=137424
Comment 34 Buovjaga 2017-12-21 15:06:54 UTC
*** Bug 114444 has been marked as a duplicate of this bug. ***
Comment 35 Bojan 2017-12-29 17:15:33 UTC
LO 6.0 RC1 still contains said bug.

Bojan
Comment 36 Buovjaga 2018-01-17 08:39:23 UTC
*** Bug 110356 has been marked as a duplicate of this bug. ***
Comment 37 Buovjaga 2018-03-07 16:51:05 UTC
This will be solved when SVGs are used for icons.

*** This bug has been marked as a duplicate of bug 115439 ***
Comment 38 mgundogdu 2018-10-31 01:09:24 UTC
I still have this issue on Manjaro Xfce and Windows 10
I don' have HiDPI but my screnn is 14 inch 1920 x 1080
On Xfce scaling dpi to 120 fine but icons so small doesn't obey general dpi settings. When I even make dpi 121 icons get bigger and pixelated
I have another laptop 15.6 inch 1366 x 768 icons are normal size and fine
in both laptops LO Version is 6.1.2.1
Comment 39 V Stuart Foote 2018-10-31 03:03:14 UTC
As noted, scaling PNG will never be of acceptable quality on HiDPI. Producing and maintaining bitmap icons at 64px or 128px in addition to the 16px 24px and 36px now can not be reliably accomplished.

Relief will only come with implementation of scaled SVG icon themes as in bug 115439

*** This bug has been marked as a duplicate of bug 115439 ***