Download it now!
Bug 106181 - FILESAVE: Check boxes get lost when saving as .XLSX
Summary: FILESAVE: Check boxes get lost when saving as .XLSX
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: medium normal
Assignee: Serge Krot (CIB)
URL:
Whiteboard: target:7.0.0 target:6.4.5 target:7.1.0
Keywords: filter:xlsx
: 106726 (view as bug list)
Depends on:
Blocks: XLSX XLSX-Form-Controls 135987
  Show dependency treegraph
 
Reported: 2017-02-24 20:41 UTC by Johannes Schneider
Modified: 2020-09-03 08:00 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
spreadsheet in .XLSX format containing the bug (5.45 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-02-24 23:08 UTC, Johannes Schneider
Details
spreadsheet in .ODS format, working properley (10.84 KB, application/vnd.oasis.opendocument.spreadsheet)
2017-02-24 23:09 UTC, Johannes Schneider
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Schneider 2017-02-24 20:41:59 UTC
When I create a check box in a spread sheet and then save the file in the format "Microsoft Excel 7 - 2013 XML (.XLSX)", the check box is disappeared after closing and reopening the file. Obviously calc doesn' t save check boxes in this format.
Comment 1 tommy27 2017-02-24 20:49:13 UTC
please post a test file where you exactly replicate your bug.
Comment 2 Johannes Schneider 2017-02-24 23:08:27 UTC
Created attachment 131460 [details]
spreadsheet in .XLSX format containing the bug
Comment 3 Johannes Schneider 2017-02-24 23:09:35 UTC
Created attachment 131461 [details]
spreadsheet in .ODS format, working properley
Comment 4 tommy27 2017-02-25 04:26:36 UTC
I confirm bug in LibO 5.2.5.1 and 5.4.0.0.alpha0+ (*)

the issue is not new and is already present in LibO 4.0.1.2 as well.
I did not test earlier releases.

status NEW



(*) Build ID: 5bb5a9dacb84ec14f7148a5a5d9ba38b7e9f1039
CPU Threads: 4; OS Version: Windows 6.29; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-02-17_23:30:45
Locale: it-IT (it_IT); Calc: group
Comment 5 m.a.riosv 2017-02-26 01:23:51 UTC
Looks like a dup, please if you are not agree reopen it.

*** This bug has been marked as a duplicate of bug 69098 ***
Comment 6 Johannes Schneider 2017-03-01 21:10:53 UTC
In bug 69098 writer does not show check boxes in a word document, word does. It looks like the reverse problem.
What I found is that calc does not save the check boxes with the document when saving it in .XLSX format. It is about saving, not about file-opening or rendering.
Comment 7 m.a.riosv 2017-03-23 22:46:10 UTC
*** Bug 106726 has been marked as a duplicate of this bug. ***
Comment 8 Aron Budea 2017-10-02 01:52:29 UTC
Exporting form controls has been recently implemented in DOCX format (bug 50097), with the following commit:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=c0cc02e2934aeb12dda44818955e5964496c186a

Likely something similar has to be done in case of XLSX files.
Comment 9 Côme Desplats 2018-06-15 07:43:37 UTC
The bug is still present in LibreOffice 6.0.4.2.
Comment 10 QA Administrators 2019-06-16 02:57:16 UTC Comment hidden (obsolete)
Comment 11 Johannes Schneider 2019-06-16 15:09:26 UTC
The bug still (ore again) exists in Version 6.1.6.3 (x64)
As far as I remember it had been resolved in one of the versions since then.

The bug also occured in the versions 3.3 and 6.2.4.2.
(I tested using the portable versions. During the installation there happened some complaints because I have no java runtime.)

Version: 6.1.6.3 (x64)
Build ID: 5896ab1714085361c45cf540f76f60673dd96a72
CPU threads: 4; OS: Windows 6.1; UI render: default; 
Locale: de-DE (de_DE); Calc: group threaded
Comment 12 Commit Notification 2020-05-25 22:21:49 UTC
Serge Krot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/fd238380ae7820f12ac1f7c52d0f7180a93f3ba3

tdf#106181 XLSX export: output form controls

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2020-06-09 08:35:32 UTC
Serge Krot committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/577dd32b1c4eb0a4cff574fbabca987cb52b831b

tdf#106181 XLSX export: output form controls

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Xisco Faulí 2020-07-01 15:06:17 UTC
Using the ods attach, the file is still reproducible in

Version: 7.1.0.0.alpha0+
Build ID: 7df1884118a0d995ec57679ef83e586c95063858
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

checkbox is gone after roundtripping the file to XLSX
Comment 15 Serge Krot (CIB) 2020-08-17 10:40:27 UTC
The checkbox for attached sample is being saved into XLSX file correctly - You could verify it by opening the file with MS Excel for example.

Import of form controls from XLSX is too big topic to mix it here with export function. => Please, open new tickets
Comment 16 Serge Krot (CIB) 2020-08-21 11:07:44 UTC
New issue was created tdf#135987
Comment 17 Thorsten Behrens (CIB) 2020-08-21 11:49:42 UTC
So yep, the checkbox info is now properly saved to XLSX. Sadly, the load part of our XLSX filter is not handling this properly yet, see bug 135987 for that.
Comment 18 Xisco Faulí 2020-09-02 10:38:48 UTC
(In reply to Serge Krot (CIB) from comment #15)
> The checkbox for attached sample is being saved into XLSX file correctly -
> You could verify it by opening the file with MS Excel for example.
> 
> Import of form controls from XLSX is too big topic to mix it here with
> export function. => Please, open new tickets

oh, I see, thanks for the clarification and for creating the new ticket. I plan to create a unittest for this issue
Comment 19 Commit Notification 2020-09-03 08:00:52 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3696b51de1a4075f99fea6ea4e20ad4949188117

tdf#106181: sc_subsequent_export_test: Add unittest

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.