Bug 106681 - Ability to add style toolbar buttons from the Customize dialog
Summary: Ability to add style toolbar buttons from the Customize dialog
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:5.4.0
Keywords:
Depends on:
Blocks: Styles Customize-Dialog Toolbars
  Show dependency treegraph
 
Reported: 2017-03-21 16:13 UTC by vermontpoet
Modified: 2017-05-15 07:05 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
"Add Commands" dialog proposal (33.69 KB, image/png)
2017-03-28 07:09 UTC, Thomas Lendo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vermontpoet 2017-03-21 16:13:38 UTC
Description:
All ebook formats, in my experience, prefer styles over direct formatting. For anyone using LO to prep ebooks, the direct formatting buttons in the LO toolbar are all but useless. Would be much less cumbersome if modern writers could access character styles as easily and conveniently as direct formatting. 

Steps to Reproduce:
1.) View --> Toolbars --> Customize
2.) Assign a character style to a button.

Actual Results:  
Impossible to achieve. 

Expected Results:
A customized toolbar button allowing writers to easily apply character styles rather than direct formatting. 


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 vermontpoet 2017-03-21 16:14:25 UTC
The feature, by the way, was first requested here:

https://ask.libreoffice.org/en/question/39336/is-there-a-way-to-create-a-toolbar-button-for-a-specific-style-in-writer/
Comment 2 V Stuart Foote 2017-03-21 19:45:29 UTC
Agree, it has never made sense to me that the Formatting toolbar has just the one Style control--"Set Paragraph Style", the rest are direct formatting. And, as a result most paragraphs are rendered to canvas with "Default" character style.

Manipulating the Character Styles in conjunction with the assigned Paragraph style is otherwise awkward requiring use of the F11 Styles and Formatting dialog now resident in the Sidebar. It results in too much direct formatting being applied

But rather than providing generic unassigned buttons to hold assignment of .uno actions to apply a Character Style--IMHO it would make more sense to provide for toolbar customization to show a drop list/split button that could display the assigned character style adjacent to the assigned paragraph style.

Then rather than buttons, use the drop list widget to change Character style assignment of a selection (character, word or even full paragraph).

Expect we would need to provide the same functions as the existing Set Paragraph Style widget--i.e. display, assign and edit. 

The Styles and Formatting (F11) deck of the Sidebar would remain primary tool to manage all styles, but ability to customize the toolbar to display character style in addition to paragraph style would be of help to encourage the use of styles.
Comment 3 vermontpoet 2017-03-21 21:01:29 UTC
//But rather than providing generic unassigned buttons to hold assignment of .uno actions to apply a Character Style--IMHO it would make more sense to provide for toolbar customization to show a drop list/split button//

Yes, that too, but bold and italics are so ubiquitous that, IMHO, they should be as easily applied as direct formatting -- the ability to assign (re-assign) keystrokes for example. 

As I increasingly use LO to prep for ebooks, I feel like I'm using a 20th century application ill-suited to the new realities of the 21rst century.
Comment 4 Thomas Lendo 2017-03-21 23:39:27 UTC
(In reply to V Stuart Foote from comment #2)
> But rather than providing generic unassigned buttons to hold assignment of
> .uno actions to apply a Character Style--IMHO it would make more sense to
> provide for toolbar customization to show a drop list/split button that
> could display the assigned character style adjacent to the assigned
> paragraph style.

A drop list for character styles would be nice. But I assume 2 negative aspects: Such a drop list needs much horizontal space in the toolbar and the "average user" is not using drop lists - they are afraid of it, buttons are much easier to choose and click. (I don't know any colleague that uses drop lists, they like more visual widgets like the color picker or list picker.)

I like the initial idea of the bug that I could use the bold toolbar command to assign the "strong emphasis" character style to characters/words without using the Styles and Formatting sidebar. 

But I would go a step further:
Allow all paragraph, character and list styles to be linked to toolbar commands (buttons), context menus and shortcut keys. With that the user could customize LibreOffice to match his/her needs in using soft formatting.

In a next step many hard formatting commands could be replaced by similar styles. Strong emphasis character style instead of bold. Emphasis character style instead of italics. List styles in the list picker widget instead of hard coded lists, etc. This would reduce the use of hard formatting in documents without changing the user's workflow much.
Comment 5 Heiko Tietze 2017-03-22 07:59:58 UTC
(In reply to vermontpoet from comment #0)
> Expected Results:
> A customized toolbar button allowing writers to easily apply character
> styles rather than direct formatting. 

(In reply to vermontpoet from comment #3)
> ...bold and italics are so ubiquitous that, IMHO, they
> should be as easily applied as direct formatting...

(In reply to Thomas Lendo from comment #4)
> I like the initial idea of the bug that I could use the bold toolbar command
> to assign the "strong emphasis" character style to characters/words without
> using the Styles and Formatting sidebar. 

I'm in favor of WONTFIX because basic direct formatting is expected by most users (comment 3). Surely we want to educate them we also do not want to become something like Latex. Last argument pro WF is that with the use case is covered perfectly by the newly introduced Notebookbar that ultimately should allow an easy configuration of the toolbar. (The ease is not really done yet.)

While I don't understand the request as moving from direct formatting to an emphasis character style for bold this idea came in my mind too. The bold button would be just a quick link to one predefined style. 
Microsoft merges paragraph and character styles, by the way which, is a good idea. Average users have no clue about the difference, and if the whole paragraph changes instead of the selection a simple Undo solves it.
Comment 6 vermontpoet 2017-03-22 11:22:24 UTC
//I'm in favor of WONTFIX because basic direct formatting is expected by most users (comment 3). Surely we want to educate them we also do not want to become something like Latex.//

I'm not sure I understand the basis for this objection? It's not an either/or situation. Allowing end-users to access soft-formatting as easily as hard-formatting in no way defeats the expectations of most users. I see no reason why the default wouldn't remain hard-formatting.

What I'm asking for is the ability to more easily access soft-formatting. Were LO to allow button assignment or re-assignment of buttons (or shortcut keys) as a post installation customization, any user content with hard-formatting would notice no difference at all.

As for the Latex comparison, I would point out that soft-formatting is already a fully integrated feature set of LO! I'm not asking for the introduction of features "like LATEX". They're already there. LO is already "something like Latex" as far as that goes. All I'm asking is that soft-formatting be made more easily accessible for writers increasingly writing for ebooks.
Comment 7 Regina Henschel 2017-03-22 16:57:58 UTC
I have made a HowTo for getting a character style into a toolbar in current LO.
https://wiki.documentfoundation.org/User:Regina/HowTo_Symbol_For_Character_Style

That is no solution, but only a workaround. Therefore it is a subpage of my user page in the Wiki.
Comment 8 vermontpoet 2017-03-23 00:22:00 UTC
Thanks for the Howto. Am using Mint/Ubuntu 16.04 with LO 5.3.1.2

Some differences in Linux:

The location of the config file for the user's custom toolbar is:

home/<user>/.config/libreoffice/4/user/config/soffice.cfg/modules/swriter/toolbar

The location of the menubar.xml file is:

usr/lib/libreoffice/share/config/soffice.cfg/modules/swriter/menubar

I edited my Styles toolbar thusly:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE toolbar:toolbar PUBLIC "-//OpenOffice.org//DTD OfficeDocument 1.0//EN" "toolbar.dtd">
<toolbar:toolbar xmlns:toolbar="http://openoffice.org/2001/toolbar" xmlns:xlink="http://www.w3.org/1999/xlink" toolbar:uiname="Styles"/>
<toolbar:toolbaritem xlink:href=".uno:StyleApply?Style:string=Strong%20Emphasis&amp;FamilyName:string=CharacterStyles" toolbar:text="Style Bold"/>
<toolbar:toolbaritem xlink:href=".uno:StyleApply?Style:string=Emphasis&amp;FamilyName:string=CharacterStyles" toolbar:text="Style Italics"/>

In Linux, '&' apparently needs to be '&amp'. So, your example:

<toolbar:toolbaritem xlink:href=".uno:StyleApply?Style:string=Strong%20Emphasis&FamilyName:string=CharacterStyles" toolbar:text="Style Strong Emphasis"/>

Should appear as the following in Linux:

<toolbar:toolbaritem xlink:href=".uno:StyleApply?Style:string=Strong%20Emphasis&amp;FamilyName:string=CharacterStyles" toolbar:text="Style Strong Emphasis"/>

All that said, all I get in LO is an empty toolbar. There's probably some other nicety that's missing as concerns Linux.
Comment 9 vermontpoet 2017-03-23 00:34:28 UTC
Update. It works:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE toolbar:toolbar PUBLIC "-//OpenOffice.org//DTD OfficeDocument 1.0//EN" "toolbar.dtd">
<toolbar:toolbar xmlns:toolbar="http://openoffice.org/2001/toolbar" xmlns:xlink="http://www.w3.org/1999/xlink" toolbar:uiname="Styles">
 <toolbar:toolbaritem xlink:href=".uno:DesignerDialog" toolbar:text="Styles"/>
 <toolbar:toolbaritem xlink:href=".uno:StyleApply?Style:string=Default%20Style&amp;FamilyName:string=CharacterStyles" toolbar:text="Default"/>
 <toolbar:toolbaritem xlink:href=".uno:StyleApply?Style:string=Emphasis&amp;FamilyName:string=CharacterStyles" toolbar:text="Italics"/>
 <toolbar:toolbaritem xlink:href=".uno:StyleApply?Style:string=Strong%20Emphasis&amp;FamilyName:string=CharacterStyles" toolbar:text="Bold"/>
</toolbar:toolbar>

I initially tried to edit the custom toolbar while it was blank. That didn't work because syntax was missing (and I wouldn't know enough to recognize it). I then tried adding the Styles button before adding my own lines. Adding the Styles button via LO's customize option apparently reconfigured the xml file so that I could edit it successfully. (?) I'm guessing.
Comment 10 vermontpoet 2017-03-23 00:46:23 UTC
Just tried applying icons. I used the stock "Default", "Italics", and "Bold" Icons offered by LO. However, they're not showing up in the toolbar, only text. The Icons option is chosen. Also tried "Icons & Text" option. 

Possibly a bug?
Comment 11 LibreTraining 2017-03-23 01:43:52 UTC
The ability to assign styles to toolbar buttons is a very useful feature.
I started watching this feature request because this is a feature I could use yesterday.

Let me see if I understand this WONTFIX “logic” ...
A feature which will help knowledgable advanced users is not a priority 
because ignorant beginner users use what is in front of them.
<shakes head>


To an advanced user the Formatting toolbar is nearly useless.
I turn it off.
The ONLY thing on that toolbar which is useful is the style drop-down.
Everything else is going to be in the styles.
To a knowledgable user the Formatting toolbar is a waste of screen real estate.

Same with the Standard (Single Mode) toolbar – 15 of those tools are useless to anyone properly using styles. So more than half the tools are a waste of space.

So what is an advanced user to do? 
Create their own toolbars. 
Actually useful toolbars.

How about an Ebook toolbar with all the proper styles required to create an ebook?
That would help even ignorant beginners get started in the right direction.

How about a Long Document toolbar with all the needed styles and tools right there?
Instead of scattered all over buried in menus.

The ability to assign styles to toolbar buttons is a very useful feature.


Word also has a feature where styles can be made the only formatting option. 
The author can select the allowed styles, and then turn-off everything else. 
The direct formatting tools are all greyed-out, and not available.
A quick way to break the direct formatting habit.
No more receiving Word-salad documents.


Style drop-down selectors are also very useful.

Word has a style drop-down which you can include in the Quick Access bar.
You can turn-off the ribbon and still easily access your styles.

The Quick Styles gallery on the ribbon is basically a bunch of styles buttons.
Little style buttons which actually have a little preview of the style in them.
Style buttons. Good idea.

You can also add the Quick Styles gallery to the Quick Access bar.
You can have two styles tools on the Quick Access bar and turn-off the ribbon and menus.

The Adobe InDesign toolbar includes both paragraph and character style drop-down selectors, and it is easy to switch back and forth between them.


Given the current stated goal of enabling LibeOffice users to have-it-your-way
it would seem to make sense to give them the tools to do so.


The ability to assign styles to toolbar buttons is a very useful feature.
Comment 12 Heiko Tietze 2017-03-23 09:25:35 UTC
(In reply to LibreTraining from comment #11)
> Given the current stated goal of enabling LibeOffice users to
> have-it-your-way it would seem to make sense to give them the tools to do so.

Still for WF because

* you can quickly apply styles from the sidebar
* medium-experienced users can customize the toolbar right now as requested
* the Notebookbar aims to solve this request perfectly
* users expect a classic toolbar, which typically has no variability
* ebook writers might not be the majority of our users (in fact we defined Benjamin as our core user -> HIG persona)

I would fully agree with this idea when we talk about the Notebookbar. But messing up with the classic concepts of toolbars is a failure.
Comment 13 Thomas Lendo 2017-03-23 10:38:02 UTC
(In reply to Heiko Tietze from comment #12)
> Still for WF because
> * you can quickly apply styles from the sidebar

But the user has to switch between paragraph styles, character styles, etc. manually, therefore a toolbar command would make that easier and faster.

> * the Notebookbar aims to solve this request perfectly
> 
> I would fully agree with this idea when we talk about the Notebookbar

How will/would aim the Notebookbar this issue? Is there a concept or mockup adressing character and other styles?
Comment 14 Heiko Tietze 2017-03-23 11:08:37 UTC
(In reply to Thomas Lendo from comment #13)
> But the user has to switch between paragraph styles, character styles, etc.
> manually, therefore a toolbar command would make that easier and faster.

If that is an issue we better talk about merging the different styles, right.

> How will/would aim the Notebookbar this issue? Is there a concept or mockup
> adressing character and other styles?

An idea is to make the NB as flexible as known from Mozilla Firefox. You add/delete and arrange controls per drag 'n drop. And why not allow to drop a style from the sidebar to the NB? Another option is to introduce a responsive section that lists all (used) styles as buttons. As said I wouldn't do this with classic toolbars but the NB would be perfectly suited for such an enhancement, IMHO.
Comment 15 Regina Henschel 2017-03-23 11:13:42 UTC
(In reply to vermontpoet from comment #8)
> 
> In Linux, '&' apparently needs to be '&amp'.

It is '&amp;' in Windows too. It was only a problem with the Wiki-syntax. I have corrected it.
Comment 16 Regina Henschel 2017-03-23 11:20:56 UTC
(In reply to vermontpoet from comment #10)
> Just tried applying icons. I used the stock "Default", "Italics", and "Bold"
> Icons offered by LO. However, they're not showing up in the toolbar, only
> text. The Icons option is chosen. Also tried "Icons & Text" option.

They have no default icon. You need to assign icons manually. Do not do this under icon size "automatic", but set icon size fixed and then chose the icon which has this size for the new command. You need to do it for each icon size.
Comment 17 vermontpoet 2017-03-23 12:19:16 UTC
Hi Heiko, I'm uttrly perplexed...

//* you can quickly apply styles from the sidebar//

You can also easily apply hard-formatting through the menu system. By this logic, there is no need for toolbars whatsoever.

//* medium-experienced users can customize the toolbar right now as requested//

Wait.... what? If so, then why are you objecting to doing what can already be done? And if so, where in LO's menu system can this be accomplished? And direct us to the official documentation that explains how to do this.

//* the Notebookbar aims to solve this request perfectly//

But didn't you just write that users can already customize toolbars as requested? So why do we need a notebookbar?

//* users expect a classic toolbar, which typically has no variability//

What does that have to do with customization and ease of accessibility? Users can already customize the classic toolbar so why arbitrarily refuse to allow soft-formatting buttons?

//* ebook writers might not be the majority of our users (in fact we defined Benjamin as our core user -> HIG persona)//

What does that have to do with accessibility? This is a request to make features (already available in LO) more easily accessible. How does ease of accessibility negatively impact core users? Please explain.

//But messing up with the classic concepts of toolbars is a failure.//

Please explain how allowing me, an end-user, to customize your toolbar is a failure?
Comment 18 Heiko Tietze 2017-03-23 12:29:38 UTC
(In reply to vermontpoet from comment #17)
> Please explain how allowing me, an end-user, to customize your toolbar is a
> failure?

I'm sorry for you that customization of toolbars with soft-formatting (nice term, btw) is not a piece of cake. You have to go the hard way as explained by Regina. I wouldn't go further. NB is a different situation as it stands for new concepts and more flexibility.
Comment 19 vermontpoet 2017-03-23 12:31:48 UTC
//You need to assign icons manually. Do not do this under icon size "automatic", but set icon size fixed and then chose the icon which has this size for the new command. You need to do it for each icon size.//

Thanks Regina, but LO on linux must be different. The icons I assigned were assigned manually, by me, from the default set of icons offered by LO. There is no "automatic" option and no option to set icon size as "fixed".
Comment 20 vermontpoet 2017-03-23 12:43:06 UTC
//I'm sorry for you that customization of toolbars with soft-formatting is not a piece of cake.//

So when authors ask me which word processor they should use for writing e-books, you're okay with me sending them to this thread and your comments?
Comment 21 Thomas Lendo 2017-03-23 13:10:50 UTC
Please calm down everybody and let us discuss in a constructive way.

(In reply to Heiko Tietze from comment #14)
> (In reply to Thomas Lendo from comment #13)
> > But the user has to switch between paragraph styles, character styles, etc.
> > manually, therefore a toolbar command would make that easier and faster.
> If that is an issue we better talk about merging the different styles, right.

Possibly but IMO not, because
a) the style list would be longer than now and now it's already a long list for each style type (finding the right style would be less easy in a list with paragraph, character and list styles together -- and how to differ them from each other style type?) and
b) the toolbar command suggestion is only usable for few styles because the horizontal space is limited (only styles that are used very often for a specific user; e.g. in an instruction that describes an HMI screen of a machine control software you want to highlight buttons of the HMI with a special character style to show the reader easily what's an HMI element in the text).

> > How will/would aim the Notebookbar this issue? Is there a concept or mockup
> > adressing character and other styles?
> An idea is to make the NB as flexible as known from Mozilla Firefox. You
> add/delete and arrange controls per drag 'n drop. And why not allow to drop
> a style from the sidebar to the NB?

Thanks for the info. As far as I can see as non-developer, fixing of this bug would enable (or would deliver the base to make it possible for) the Notebookbar to do what you suggest. As I read in the wiki, the Notebookbar uses the same configuration system as toolbars today. So I think it wouldn't be a waste of effort to make it possible to assign a style to a command in the "Customize..." dialog tabs. Will the Notebookbar also be customizable with the "Customize..." dialog?
Comment 22 Regina Henschel 2017-03-23 13:45:30 UTC
I support the idea of making it possible to generate a toolbar symbol for styles. There exists already the category "Styles" for keyboard shortcuts. I see no reason, why this category is not available in the other customize dialog pages.
Comment 23 vermontpoet 2017-03-23 14:08:38 UTC
//There exists already the category "Styles" for keyboard shortcuts.//

Ha! Duh. You just made my day. =) 

And here I thought I couldn't do that. I just re-assigned CTRL-B and CTRL-I to their commensurate character-styles. More re-key assigning to come...

Indeed, if we can do with this, then why not Toolbar buttons?
Comment 24 LibreTraining 2017-03-23 20:05:21 UTC
(In reply to Heiko Tietze from comment #12)
> (In reply to LibreTraining from comment #11)
> > Given the current stated goal of enabling LibeOffice users to
> > have-it-your-way it would seem to make sense to give them the tools to do so.
> 
> Still for WF because
...
> 
> I would fully agree with this idea when we talk about the Notebookbar. But
> messing up with the classic concepts of toolbars is a failure.

Wadda bunch of nose-in-the-air conceptual nonsense.

I guess those idiots at Microsoft and Adobe should note their failures.


FYI
I already use the sidebar to apply styles - how else would you do it?
I have already assigned a number of styles to keyboard short-cuts.
Heaven forbid the toolbars should include the tools to actually be useful.


I set-up an RSS feed a few days ago to start watching the needUXEval posts.
As a way for a new guy to see what was happening and to get involved in the Design team as a contributor.
But if a valid request from an advanced knowledgeable user for a real productivity enhancement is treated like this - it appears this "team" is likely to be a giant waste of time.

This condescending no-can-do attitude will very definitely dissuade many contributors.

The opposite with a can-do attitude ... 
Thank You Regina for the contribution towards the actual goal.
Very helpful.
Comment 25 vermontpoet 2017-03-23 21:10:08 UTC
//This condescending no-can-do attitude will very definitely dissuade many contributors.//

Though the comment will probably be marked abusive, I unfortunately agree. It's not even clear to me that Tietze understands the feature request---his objections are completely specious.

Have to say, I'm having a very hard time with LO right now. I've tried using LO's Search and Replace feature to replace hard-formatting with "character styles" (as a simple workaround) but this very basic feature is utterly broken.

https://bugs.documentfoundation.org/show_bug.cgi?id=106730

Worse yet, the latest release of LO has broken many of its macros and extensions:

https://bugs.documentfoundation.org/show_bug.cgi?id=106529

So  I can't t publish to Epub format using LO. From where I sit, and as far as modern word processing goes, LO is imploding. I could install an earlier version of LO but that would only fix one of the bugs. I'll be using Word and Softmaker Office until all this gets sorted out.

Thanks.
Comment 26 LibreTraining 2017-03-23 21:24:47 UTC
(In reply to vermontpoet from comment #25)
> ---his objections are completely specious.

Specious - exact word I was thinking when I was first formulating the response in my head.


Wow. If

//This condescending no-can-do attitude will very definitely dissuade many contributors.//

is abusive, this must be Snowflake-Land.
Comment 27 Yousuf Philips (jay) (retired) 2017-03-25 15:34:03 UTC
It has been my view that a formatting toolbar targeting style users would be a beneficial feature to have, but unfortunately LibreOffice doesnt currently have the necessary functionality in place to make it a good/seamless experience, like what is available with direct formatting. If it did, it could easily be added as another toolbar layout that advanced users could easily toggle on.

What is possible today is to add some basic paragraph and character styles as clickable buttons to the formatting toolbar, similar to what Regina made with the guide, but these buttons wouldnt be toggle buttons, which means that you couldn't glance at them to know what is being applied. In order to have them as toggle buttons, UNO commands would need to be created for them and these commands would need to detect whether the underlying paragraph/character style is being applied. @Maxim, @Samuel, @Gulsah: Is this something that can easily be achieved?

When i mentioned the seamless experience above, it was focused on the easy ability with direct formatting to mix formatting attributes together like bold + italics or italics + underline when clicking on the toolbar buttons, while this wouldnt be possible with the character style buttons, as if text was in bold (aka strong emphasis) and you wanted to apply italics (aka emphasis) to that text, it would overwrite bold with italics and not mix the two together as a new character style. It would be great if LibreOffice had a style-only mode, where all applied direct formatting was turned into styles, iWork works in this way i believe.

If there is interest in making this styles-focused formatting toolbar, i'd be up to brainstorming its creation with those interested in it.

About whether this bug report should stay open, i'd have to agree with Heiko that it should be closed, as Regina has provided instructions on how to do so and there isnt much we can/should do to simplify the process of adding character styles to the toolbars, as bug 88512 is intended to solve the underlying issue.

(In reply to Heiko Tietze from comment #12)
> * you can quickly apply styles from the sidebar

Cant say that i agree with this, which is why i've suggested styles be redesigned - attachment 115020 [details].

> * medium-experienced users can customize the toolbar right now as requested

As none of the paragraph or character styles in the Styles menu appear in the customization dialog, not sure if a medium-experienced user could do this if they didnt read this bug report or Regina's wiki.

> * the Notebookbar aims to solve this request perfectly

The notebookbar wont solve this issue in my view.

> * users expect a classic toolbar, which typically has no variability
> * ebook writers might not be the majority of our users (in fact we defined
> Benjamin as our core user -> HIG persona)

Agree.
Comment 28 vermontpoet 2017-03-25 16:40:32 UTC
Hi Jay, thanks for your detailed response. Makes much more sense. My thoughts:

//but these buttons wouldnt be toggle buttons//

Neither are the menu selections in the side-pane. For now, buttons would simply provide quicker and easier access. The realization that I can apply shortcut keys to character styles greatly alleviates the need for toolbar buttons. That said, a basic Ebook toolbar (even if not functionally equivalent to direct formatting -- and maybe it shouldn't be --see below) would be a first-rate first step---a signal that LO recognizes (without sounding too condescending) the 21rst century and the requirements of professional writers (who are not apparently, named Benjamin).

//What is possible today is to add some basic paragraph and character styles as clickable buttons to the formatting toolbar//

Yes and no. The icons don't work in Linux. And where does one find custom character styles? 

//When i mentioned the seamless experience above, it was focused on the easy ability with direct formatting to mix formatting attributes together//

Excellent observation and one that didn't occur to me. However, this at first glance would seem to defeat the purpose of character styles or, to put it another way, mixing format attributes is little more than a GUI for the creation of *new* character styles. If a user were to add italics to a bold character style then, presumably, he or she would be asked if she wanted to create a new character style (for example). It's not clear why such a feature would be necessary or desirable however... 

What this suggests to me is that, eventually, the professional writer and Benjamin are going to have to part ways. Maybe in the next decade we'll get a WYSIWIG paragraph and character-style based wordprocessor (or sort of WYSIWIG Lyx) that uses soft-formatting rather than hard-formatting as its primary formatting. Maybe a fork of LO? LO seems to be throwing in its lot with Benjamin. Is Benjamin a baby-boomer per-chance?

//If there is interest in making this styles-focused formatting toolbar, i'd be up to brainstorming its creation with those interested in it.//

Any input I could offer would be conceptual. I'm not a coder (not since BASIC and PASCAL).

//It would be great if LibreOffice had a style-only mode, where all applied direct formatting was turned into styles, iWork works in this way i believe.//

Yes it would be--but maybe that's going to have to be a fork since LO is wedded to Benjamin. It would also be great if LO's search and replace weren't broken. One could easily replace direct formatting with soft formatting. LO really ought to fix this basic functionality before doing diddly-squat-else IMHO. As it is, I just paid 49 dollars to upgrade to Softmaker 2016. The Search & Replace feature works beautifully. I converted all my direct formatting to soft formatting. Done. Lovely.

I'm sure Benjamin is a nice guy. Don't mean to be too snarky. Send him my regards.
Comment 29 Regina Henschel 2017-03-25 18:03:44 UTC
(In reply to Yousuf Philips (jay) from comment #27)

There are two requests mixed up:
(1) Enhance the customize dialog, so that it is possible to make a toolbar button that assigns a style.

(2) Change the default toolbar, so that it has buttons for assigning character styles.

While you are mainly talk about (2) and its UX-problems, I think (1) can be done immediately and would be a good enhancement. For example, it would be possible to make document templates with a toolbar embedded in the template, that contains exact that styles, which are essential for that document template.
Comment 30 LibreTraining 2017-03-25 18:06:47 UTC
It appears part of the problem is these ridiculous personas.
Let’s remove all the useless fluff and nonsense about politics and eating habits and look at how they actually use LibreOffice

Primary (Beginner) Benjamin – ignorant, lazy, slacker who will only use the bare minimum of features which he can figure-out with an absolute minimum of effort.
So the lofty goal of the Design Team is to cater to this basic idiot.

Primary (Expert) Eve – writes studies and reviews. (how vague)
How about some info about what features she actually uses to create these studies and reports?
This should be the Beginner/Novice. At least she has a brain and some initiative.

Secondary (Admin) Adrian – does not even use LibreOffice. <rolls-eyes>

If these are your target audience/user that explains the lack of support for knowledgeable users.

Where are the REAL users?

Office Worker (Beginner)
We keep seeing the reports about this government agency or that city that has dumped MS Office and moved to LibreOffice.
What problems will they encounter?
What features do they use?
What missing features do they need?
How are they going to convert all their documents?
How are they going to standardize on new style sheets?
How are they going to attach the new style sheet when that basic feature is still missing?!

Student/Academic (Intermediate/Advanced)
Many educational institutions support using LibreOffice.
These users will take the time to actually learn to use LibreOffice because they need the features required to create term papers, academic studies, and other long documents.
What features do they use?
What missing features do they need?
Why do the default settings for creating an index bear no resemblance to the real world?
Every time these users must recreate settings which are actually required. Dumb defaults.
Many of these documents will be submitted as PDFs, or DOCs, or ODTs.
Why is there still no way to create links in the index?
That is ridiculous.

Author (Intermediate/Advanced)
Books are written using word processors. Duh.
Today many books are only available physically print or as an ebook. 
PDFs are getting harder to find.
Where do you think the thousands and thousands of books on Amazon, iTunes, etc. come from?
Authors write their books in Word, or LibreOffice, or other word processor.
And while doing so they have to make sure to the document is structured properly so it will convert properly to its final form.
What features do they need?
How about a toolbar with the proper styles they need?
How about a working search for direct formatting and replace with a proper style?


These personas are REAL users who use LibreOffice everyday for real world applications.
Not some lowest-common-denominator lazy slacker who could use any word processor, poorly.

The idea that the above personas are some small insignificant percentage of users is ridiculous.
The office workers alone would be hundreds of thousands, if not millions of users.
Upper level students, academics, authors – hundreds of thousands.

Dump these useless silly personas and replace them with some real world personas.
Then have a goal to attract, and to support, these intelligent motivated real users.
Comment 31 LibreTraining 2017-03-25 18:14:34 UTC
(In reply to Regina Henschel from comment #29)

> While you are mainly talk about (2) and its UX-problems, I think (1) can be
> done immediately and would be a good enhancement. For example, it would be
> possible to make document templates with a toolbar embedded in the template,
> that contains exact that styles, which are essential for that document
> template.

That is a great idea.
I assume a notebookbar style could be used?

With your guidance and input I would be happy to work on:
 - eBook Bar
 - Long Doc Bar
Comment 32 Thomas Lendo 2017-03-25 19:47:43 UTC
I support what Regina said in comment 22 and comment 29, point (1): Make it possible for users that want do it by themselves.

All other ideas (changing anything in toolbars etc.) that UX people avoid like the plague (fürchten wie der Teufel das Weihwasser) must be handled in new bugs and shouldn't result in closing THIS bug.

(In reply to Yousuf Philips (jay) from comment #27)
> What is possible today is to add some basic paragraph and character styles
> as clickable buttons to the formatting toolbar, similar to what Regina made
> with the guide, but these buttons wouldnt be toggle buttons, which means
> that you couldn't glance at them to know what is being applied. In order to
> have them as toggle buttons, UNO commands would need to be created for them
> and these commands would need to detect whether the underlying
> paragraph/character style is being applied. @Maxim, @Samuel, @Gulsah: Is
> this something that can easily be achieved?

This would be the optimum for that bug!

> When i mentioned the seamless experience above, it was focused on the easy
> ability with direct formatting to mix formatting attributes together like
> bold + italics or italics + underline when clicking on the toolbar buttons,
> while this wouldnt be possible with the character style buttons, as if text
> was in bold (aka strong emphasis) and you wanted to apply italics (aka
> emphasis) to that text, it would overwrite bold with italics and not mix the
> two together as a new character style.

The overwriting is was users expect, that know was styles and soft-formatting are doing.

> It would be great if LibreOffice had
> a style-only mode, where all applied direct formatting was turned into
> styles, iWork works in this way i believe.
> 
> If there is interest in making this styles-focused formatting toolbar, i'd
> be up to brainstorming its creation with those interested in it.

Here we are ...
Comment 33 Thomas Lendo 2017-03-26 17:58:12 UTC Comment hidden (no-value)
Comment 34 vermontpoet 2017-03-26 18:33:29 UTC
(In reply to Regina Henschel from comment #29)
> (In reply to Yousuf Philips (jay) from comment #27)
> 
> There are two requests mixed up:
> (1) Enhance the customize dialog, so that it is possible to make a toolbar
> button that assigns a style.
> 
> (2) Change the default toolbar, so that it has buttons for assigning
> character styles.

That's exactly it. The intent of this bug report was never to change the default toolbar. However, a basic and customizable "EBook" Toolbar offering soft-formatting buttons and drop down menus for paragraph styles *and "character styles" is devoutly to be wished for. 

As I wrote previous, I personally don't think it makes sense for soft-formatting buttons to mix attributes (at least not initially). It could be done, and might be a useful feature several years from now (for a styles based word-processor) but styles work differently. 

A good first step:

1.) Create the style separately with whatever attributes one desires (as is done now) but 2.) allow the user to more easily add a toolbar button with which to apply that style.
Comment 35 Yousuf Philips (jay) (retired) 2017-03-26 19:14:53 UTC
(In reply to vermontpoet from comment #28)
> Hi Jay, thanks for your detailed response. Makes much more sense. My
> thoughts:

Hi vermontpoet,

> Neither are the menu selections in the side-pane. For now, buttons would
> simply provide quicker and easier access.

The menu selection in the styles & formatting sidebar does provide toggle behaviour, where you do see which style is currently applied and provides easier access than toolbar buttons. You dont have to take my word for it, as i'm not a style users, you can ask pretty much any LO style user, like Cor or Sophie, or any style user on MSO, as the style management window in MSO hasnt changed in 25+ years. ( http://shaunakelly.com/wordimages/numbering/bullets2007/AddListBulletStyleToQuickStyleGallery.png )

> The realization that I can apply
> shortcut keys to character styles greatly alleviates the need for toolbar
> buttons.

The current customization dialog wont allow you to assign/reassign shortcut keys to paragraph or character styles, as they arent listed in the uno commands list.

> That said, a basic Ebook toolbar (even if not functionally
> equivalent to direct formatting -- and maybe it shouldn't be --see below)
> would be a first-rate first step

I've create a bug report for the new toolbar (106781).

> Yes and no. The icons don't work in Linux. And where does one find custom
> character styles? 

The issue with custom icons is a recent bug (bug 106784), but for them to appear by default in a new style formatting toolbar, uno commands for these buttons would need to be created.

> What this suggests to me is that, eventually, the professional writer and
> Benjamin are going to have to part ways. Maybe in the next decade we'll get
> a WYSIWIG paragraph and character-style based wordprocessor (or sort of
> WYSIWIG Lyx) that uses soft-formatting rather than hard-formatting as its
> primary formatting. Maybe a fork of LO? LO seems to be throwing in its lot
> with Benjamin. Is Benjamin a baby-boomer per-chance?

LO is intended both for Benjamin (a basic user who primarily uses direct formatting and has little to no knowledge of styles, e.g. my step mother or my 13-year old son) and for Eve (a professional user who primarily creates style-only documents, e.g. my father who is an author, or my wife who is a secretary) and everyone in between (e.g. Me, who uses the built in paragraph styles, but doesnt customize them). Benjamin will uses LO differently than Eve, but that doesnt mean the LO only caters to Benjamin.
Comment 36 vermontpoet 2017-03-26 19:43:41 UTC
(In reply to Yousuf Philips (jay) from comment #35)

> The menu selection in the styles & formatting sidebar does provide toggle
> behaviour, 

No they don't. I just tested. 

> where you do see which style is currently applied and provides
> easier access than toolbar buttons.

So why have toolbars? Why not have menus for everything?

> You dont have to take my word for it, as
> i'm not a style users, you can ask pretty much any LO style user, like Cor
> or Sophie, or any style user on MSO


Do you think, if I thought menus were easier, I would have requested toolbar buttons?

But I don't need to ask Cor or Sophie. This is a demonstrably ridiculous assertion. Didn't Tietze just break into a cold sweat when he thought we were messing with his default toolbar? Forget Cor and Sophie, just ask Heiko Tietze (or ask Benjamin) what would happen if we were to replace all his toolbars with menus. "Hey Benjamin, menus are easier! Just ask Core and Sophie!"  

> style management window in MSO hasnt changed in 25+ years.

Yeah, and that ebook market was booming 25+ years ago...  

> The current customization dialog wont allow you to assign/reassign shortcut
> keys to paragraph or character styles

I just did it and tested it. Works fine.

> I've create a bug report for the new toolbar (106781).

Be sure and mark it as a duplicate of this one.

> The issue with custom icons is a recent bug (bug 106784), but for them to
> appear by default in a new style formatting toolbar, uno commands for these
> buttons would need to be created.

Works fine in Windows. Just did it. And no they wouldn't. That subject has been discussed above.

> ...but that doesnt mean the LO only caters to Benjamin.

That remains to be seen.
Comment 37 Yousuf Philips (jay) (retired) 2017-03-26 19:45:09 UTC
(In reply to Regina Henschel from comment #29)
> While you are mainly talk about (2) and its UX-problems, I think (1) can be
> done immediately and would be a good enhancement. For example, it would be
> possible to make document templates with a toolbar embedded in the template,
> that contains exact that styles, which are essential for that document
> template.

Yes (1) can be done immediately if a dev is ready to do it, but the UX-problems i've mentioned would be present with (1) or (2). So as (1) is what is wanted in this bug report, i'm fine with it staying open.

If a dev takes this on, then a 'Add Style' button should be added under 'Add Separator' and it would open up a dialog which would have a listbox for paragraph styles and listbox for character styles and a 'Add Paragraph Style' and 'Add Character Style' buttons below them.
Comment 38 Regina Henschel 2017-03-26 19:48:14 UTC
(In reply to Yousuf Philips (jay) from comment #35)

> The current customization dialog wont allow you to assign/reassign shortcut
> keys to paragraph or character styles, as they arent listed in the uno
> commands list.

The feature to assign a shortcut key to a style is available at least since OpenOffice.org 2.4.3. Scroll the category list down till its end.
Comment 39 Regina Henschel 2017-03-26 19:54:13 UTC
(In reply to Yousuf Philips (jay) from comment #37)
> 
> If a dev takes this on, then a 'Add Style' button should be added under 'Add
> Separator' and it would open up a dialog which would have a listbox for
> paragraph styles and listbox for character styles and a 'Add Paragraph
> Style' and 'Add Character Style' buttons below them.

I would not make a new kind of customize. It is only needed to extend the category in tab "Toolbar > Add Commands" with the item "Styles", same as it already exists in tab "Keyboard".
Comment 40 Yousuf Philips (jay) (retired) 2017-03-26 20:11:26 UTC
(In reply to Regina Henschel from comment #38)
> The feature to assign a shortcut key to a style is available at least since
> OpenOffice.org 2.4.3. Scroll the category list down till its end.

Yep it seems i missed it. :D

(In reply to Regina Henschel from comment #39)
> I would not make a new kind of customize. It is only needed to extend the
> category in tab "Toolbar > Add Commands" with the item "Styles", same as it
> already exists in tab "Keyboard".

True. :D

So is this something you are ready to fix?
Comment 41 Thomas Lendo 2017-03-28 07:09:36 UTC
Created attachment 132202 [details]
"Add Commands" dialog proposal

I've attached a mockup screenshot with that you can see all styles as they are already available in "Tools > Customize... > Keyboard > Functions Category" today. (Side note: Table and Cell lists are empty in 5.3.2.1. Character, Paragraph, Pages, Frame, Numbering lists are available.)

And just to be clear:
We're talking not only about paragraph and character styles but also all other style types, right? I do so because it wouldn't make any sense not to have list styles, which are also part of text formatting.

I'm working on a style toolbar for internal use of my company's corporate identity styles (based on Regina's marvelous instructions) and lists are a core style feature beside paragraphs and characters. In the future the same will be valid for table styles as they are available in the Styles & Formatting sidebar too since LibO 5.3.

(In reply to Yousuf Philips (jay) from comment #27)
> What is possible today is to add some basic paragraph and character styles
> as clickable buttons to the formatting toolbar, similar to what Regina made
> with the guide, but these buttons wouldnt be toggle buttons, which means
> that you couldn't glance at them to know what is being applied. In order to
> have them as toggle buttons, UNO commands would need to be created for them
> and these commands would need to detect whether the underlying
> paragraph/character style is being applied. @Maxim, @Samuel, @Gulsah: Is
> this something that can easily be achieved?

Is any further information needed so that devs can make a statement?
Comment 42 Maxim Monastirsky 2017-05-08 22:39:48 UTC
Taking. The amount of copy-paste in this code is unbelievable...
Comment 43 Maxim Monastirsky 2017-05-09 08:21:03 UTC
https://gerrit.libreoffice.org/37422/
Comment 44 Commit Notification 2017-05-09 09:26:37 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e4d7511d7e49af14e3c8113bb1440e0eb04f40ad

tdf#106681 Styles category for the Add Commands dialog

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 45 Thomas Lendo 2017-05-11 23:01:33 UTC
Maxim, very cool, thank you for your work!

Tested customization of menus, context menus, keyboard shortcuts and toolbars in Writer and Calc.

2 things:

* Toolbar commands can have a user-defined icon unlike all other commands. I can assign an icon to a style command ("change icon"), but it won't be shown in the toolbar itself.

* No table styles are available in Writer (and never were as long as I know). And what are cell styles in Writer which is also empty?


Version: 5.4.0.0.alpha1+
Build ID: f6fd7dd08b478857234a3b1b5b18e65e9b250174
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-11_08:26:56
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 46 Yousuf Philips (jay) (retired) 2017-05-12 09:48:08 UTC
(In reply to Thomas Lendo from comment #45)
> * Toolbar commands can have a user-defined icon unlike all other commands. I
> can assign an icon to a style command ("change icon"), but it won't be shown
> in the toolbar itself.

I think that is being caused by bug 106784.
Comment 47 Maxim Monastirsky 2017-05-13 19:40:02 UTC
(In reply to Thomas Lendo from comment #45)
> * No table styles are available in Writer (and never were as long as I
> know).
There are table styles in Writer since 5.3:

https://wiki.documentfoundation.org/ReleaseNotes/5.3#Table_Styles

> And what are cell styles in Writer which is also empty?
No idea. But the style list and categories are all returned by Writer core, so probably it has some meaning there... Anyway, those empty categories were present also in 5.3 in the keyboard tab, so this is not related to my patch. Would be great if you could open a separate bug for it.
Comment 48 Thomas Lendo 2017-05-14 22:59:57 UTC
Set to VERIFIED FIXED.

Version: 5.4.0.0.alpha1+
Build ID: b82c9439287f58a02a2b42d737fcf110fbfb1244
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-05-14_01:01:26
Locale: de-DE (de_DE.UTF-8); Calc: group

Thanks, Maxim!

New bugs:
bug 107852: Customize window: Styles > Table category in Add Commands empty
bug 107853: Customize window: Styles > Cell category in Add Commands empty
Comment 49 Thomas Lendo 2017-05-14 23:26:28 UTC
Followup:
Context menus of Print Preview and Comments won't show any styles commands, but I will not create bugs for that because it's not useful for print previews to have style commands and I know the formatting mess in the comment feature which should be corrected first.
I also don't get it work on text boxes incl. content - I haven't found the right context menus ...
Comment 50 Maxim Monastirsky 2017-05-15 07:05:15 UTC
(In reply to Thomas Lendo from comment #49)
> Followup:
> Context menus of Print Preview and Comments won't show any styles commands,
This is by design. Context menus hide all disabled command.

> I also don't get it work on text boxes
I don't think we support styles in text boxes (the sidebar controls are disabled too).

> I haven't found the right context menus ...
Right now "Shape Text". There is a request in Bug 107635 comment 9 to have a separate context menu for text boxes.