Bug 107224 - Notebookbar: tabs and background are unreadable in Ubuntu's Ambiance theme
Summary: Notebookbar: tabs and background are unreadable in Ubuntu's Ambiance theme
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0
Keywords: bibisected, bisected, regression
: 112887 (view as bug list)
Depends on:
Blocks: Notebookbar-Theming
  Show dependency treegraph
 
Reported: 2017-04-17 09:23 UTC by Xisco Faulí
Modified: 2017-12-13 12:15 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (24.31 KB, image/png)
2017-04-17 09:23 UTC, Xisco Faulí
Details
Breeze Dark icon sytle (41.33 KB, image/png)
2017-08-02 00:31 UTC, fcastillousfq
Details
notebookbar vs dialog (73.10 KB, image/png)
2017-10-18 15:24 UTC, Yousuf Philips (jay) (retired)
Details
3 notebookbar layouts in Ambiance (495.88 KB, image/png)
2017-10-19 09:03 UTC, Yousuf Philips (jay) (retired)
Details
Screenshots (335.18 KB, image/png)
2017-12-13 12:06 UTC, OfficeUser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2017-04-17 09:23:05 UTC
Created attachment 132631 [details]
screenshot

Check attached image to see how it looks in GTK3 with Ambiance theme. Maybe, it's the same behaviour with other dark themes as well.

Reproduced in

Version: 5.4.0.0.alpha0+
Build ID: 7635e0c1c7f821a1081f8e3868f641ae74a172d6
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 1 Xisco Faulí 2017-04-17 09:36:22 UTC
Regression introduced by:

author	Szymon Kłos <eszkadev@gmail.com>	2017-03-15 12:42:03 (GMT)
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2017-03-16 07:47:00 (GMT)
commit	3b7d751ad4f950aae0641a75b2ea993025629c9d (patch)
tree	1cf0934defe528db39246188e6b643573a0d17af
parent	d5f48aecd8f61979e98bfbbdbc0b2ee43eb792a6 (diff)
tdf#103235 Notebookbar: use persona theme

bisected with bibisect-linux-64-5.4

Adding Cc: to Szymon Kłos
Comment 2 fcastillousfq 2017-08-02 00:31:42 UTC
Created attachment 135060 [details]
Breeze Dark icon sytle

I can confirm that this still happens on Build ID: 1:5.4.0~rc3-0ubuntu0.16.04.1~lo1

I think it's a great idea that the notebookbar can also use the persona theme. It just has to be better handle, especially on the icon style.
I tried leaving the default theme (with the bug) and switching to a dark icon theme, but this didn't fix the issue at all, even though it should have. This screenshot show's the result.

As a workaround, install any other theme for libreoffice that's not dark.
Comment 3 Xisco Faulí 2017-10-05 07:48:14 UTC
*** Bug 112887 has been marked as a duplicate of this bug. ***
Comment 4 Yousuf Philips (jay) (retired) 2017-10-18 13:51:27 UTC
The background color used is the same color that is found in the menubar[1] and in Ubuntu's ambiance theme it looks this way, but looks fine in other themes, as was corrected in bug 103235, as it previously used the menu color.

[1] http://3.bp.blogspot.com/-pS8YMNyG7W4/UCJrUdK8yJI/AAAAAAAAJeM/VdyhX515tdw/s1600/libreoffice-3.6_2.png

Xisco: Assume this is not just a gtk3 issue, it should likely happen in gtk2 as well.
Comment 5 Szymon Kłos 2017-10-18 14:48:23 UTC
I see:

SetBackground(rStyleSettings.GetMenuBarColor());

Backbround color is set to menubar color, "background color" from the theme should be used instead... This may help, I will try.
Comment 6 Yousuf Philips (jay) (retired) 2017-10-18 15:24:39 UTC
Created attachment 137077 [details]
notebookbar vs dialog

screenshot from ubuntu mate 17.10 and the notebookbar should be the same color as the background of the dialog.
Comment 7 Commit Notification 2017-10-18 16:18:30 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a1f93eee75450c3ab6bc623bfad4f850260b86d0

tdf#107224 use correct bg for notebookbar

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Yousuf Philips (jay) (retired) 2017-10-19 08:59:19 UTC
Szymon: According to Norbit's screenshots, the tabbed seems to be fixed, but the background isnt.

Version: 6.0.0.0.alpha0+
Build ID: a4a182e24d2e3e954831a0a7c70a7299f28950cb
CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-10-18_04:57:07
Locale: de-DE (de_DE.UTF-8); Calc: group
Comment 9 Yousuf Philips (jay) (retired) 2017-10-19 09:03:28 UTC
Created attachment 137103 [details]
3 notebookbar layouts in Ambiance
Comment 10 OfficeUser 2017-10-19 09:24:39 UTC
For the tabbed config (bottom screenshot) we should achieve to have the part left and right besides the tabs light gray as well.
Comment 11 OfficeUser 2017-12-12 10:35:56 UTC
I can confirm that these dark background issues are fixed for ALL variants of the Notebookbar with the following build:

Version: 6.1.0.0.alpha0+
Build ID: 8c99d76144b550b17810135418d1c2f12ef8f138
CPU threads: 8; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-11-26_22:25:0
Comment 12 OfficeUser 2017-12-12 10:36:44 UTC
Setting to RESOLVED WORKSFORME because I have no details on the latest patch that fixes all variants.
Comment 13 OfficeUser 2017-12-13 12:06:46 UTC
Created attachment 138417 [details]
Screenshots
Comment 14 OfficeUser 2017-12-13 12:10:33 UTC
I have added screenshots with the fixed background.

However, other problems remain:

- Switching between Notebookbar variants often needs to trigger a windows redraw (size change) to remove glitches.

- Unnecessary divider lines are displayed
Comment 15 OfficeUser 2017-12-13 12:15:00 UTC
Filed bug 114438 for the remaining issues.