Download it now!
Bug 107368 - Unable to ESC out of slideshow the first time it's launched using gen/kde4 backend
Summary: Unable to ESC out of slideshow the first time it's launched using gen/kde4 ba...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: kde4
Keywords: haveBacktrace
Depends on:
Blocks: Media-Playback KDE
  Show dependency treegraph
 
Reported: 2017-04-23 13:24 UTC by Buovjaga
Modified: 2019-01-01 19:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Short webm video for testing (250.61 KB, video/webm)
2017-04-23 13:24 UTC, Buovjaga
Details
GDB trace of hang with 5.4 master (69.44 KB, text/plain)
2017-04-23 13:24 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Buovjaga 2017-04-23 13:24:12 UTC
Created attachment 132767 [details]
Short webm video for testing

1. Add video to slide
2. In sidebar properties, tick the Repeat button in the Playback row
3. Play slideshow
4. Try to cancel out of it

You can get out by Alt-tabbin and then you can kill LibO.

This sometimes does not need the repeat. GTK3 always works no matter what.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.2.2
Build ID: 5.3.2-1
CPU Threads: 8; OS Version: Linux 4.10; UI Render: default; VCL: kde4; Layout Engine: new; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group

Arch Linux 64-bit, KDE Plasma 5
Version: 5.4.0.0.alpha0+
Build ID: d69e6321fbb2c9f5b4d30890074a230ee6b39d2d
CPU threads: 8; OS: Linux 4.10; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 17th 2016
Comment 1 Buovjaga 2017-04-23 13:24:37 UTC
Created attachment 132768 [details]
GDB trace of hang with 5.4 master
Comment 2 Buovjaga 2017-04-23 13:34:38 UTC
Note: no problem on Windows. Well, there is a different one: bug 106981
Comment 3 Xisco Faulí 2017-04-24 18:10:14 UTC
I can't reproduce it in

Version: 5.4.0.0.alpha0+
Build ID: 7635e0c1c7f821a1081f8e3868f641ae74a172d6
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

I can cancel the presentation by pressing ESC.
Comment 4 Xisco Faulí 2017-11-02 10:21:19 UTC
Hi Buovjaga,
Do you still reproduce this issue on master?
Comment 5 Buovjaga 2017-11-02 10:39:36 UTC
(In reply to Xisco Faulí from comment #4)
> Hi Buovjaga,
> Do you still reproduce this issue on master?

Still repro, but on the first try I was able to cancel by repeatedly hitting Esc. I recommend to try a couple of times.

Arch Linux 64-bit, KDE Plasma 5
Version: 6.0.0.0.alpha1+
Build ID: af318eeb4e23694e17b09b902afb98ddf9da9b7b
CPU threads: 8; OS: Linux 4.13; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on November 1st 2017
Comment 6 Xisco Faulí 2017-11-02 11:03:41 UTC
Tried many times by using F5 and ESC and no problem at all

Version: 6.0.0.0.alpha1+
Build ID: 1f8c3e3b78e0abb96d06a51eca354ae7ade5deb2
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 7 Xisco Faulí 2018-01-29 17:31:03 UTC
Hi Buovjaga, does it happen in LibreOffice 6.0 RC3 from https://wiki.documentfoundation.org/QA/GetInvolved#Test_Pre-releases ?
Comment 8 Buovjaga 2018-01-29 17:48:03 UTC
Still repro

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: 2d8f17565ebe867210f5769851d91b2e7b612a8f
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on January 27th 2018
Comment 9 Jean-Baptiste Faure 2018-06-24 17:07:31 UTC
Not reproducible for me with Version: 6.1.0.0.beta2+
Build ID: 546a4b61390ab1eee44dbf982a582b1de3a9a5a9
Threads CPU : 4; OS : Linux 4.4; UI Render : par défaut; VCL: gtk2; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: threaded

I guess the problem, if it still exists, is KDE only.

Best regards. JBF
Comment 10 Buovjaga 2018-06-24 17:21:21 UTC
Still repro, but not with gtk2

Should try with kde5 some time

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 5b42a17dc99fba2ccf8dd8d0a8e0e4e836e30120
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on June 22nd 2018
Comment 11 Buovjaga 2018-06-25 12:20:01 UTC
Modified summary: with gen backend, it does not repeat and I can mouse click out of the slideshow.
Comment 12 Xisco Faulí 2018-06-25 13:33:11 UTC
I can reproduce this issue back to 

Version 4.1.0.0.alpha0+ (Build ID: efca6f15609322f62a35619619a6d5fe5c9bd5a)

using a clean profile with repeat mode or without it...

Only reproducible the first the slideshow is launched. then, the ESC goes out of it
Comment 13 Buovjaga 2019-01-01 19:16:24 UTC
Looks like the problem is gone with kde5.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 2c7b0030b40de00e8c9ab997bdfe83631861968a
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 1 January 2019