Bug Hunting Session
Bug 108966 - Copy/Paste of individual image from Word into LO Writer performs no action. (Paste special as GDI image works and should be default)
Summary: Copy/Paste of individual image from Word into LO Writer performs no action. (...
Status: RESOLVED DUPLICATE of bug 99507
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 94436 (view as bug list)
Depends on:
Blocks: Paste-From-MSO
  Show dependency treegraph
 
Reported: 2017-07-05 09:46 UTC by Marco A.G.Pinto
Modified: 2018-09-19 09:00 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Word doc with an image (26.33 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-09-18 18:19 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marco A.G.Pinto 2017-07-05 09:46:36 UTC
I have an image in Word 2016 and wanted to paste it into LO.

If I do a CTR+A in Word, and then paste into LO, it works.

If I copy from Word and paste in LO, nothing appears.
Comment 1 Timur 2017-07-05 10:20:10 UTC Comment hidden (obsolete)
Comment 2 Marco A.G.Pinto 2017-07-05 10:34:58 UTC Comment hidden (obsolete)
Comment 3 Xisco Faulí 2017-07-05 10:37:43 UTC Comment hidden (obsolete)
Comment 4 Marco A.G.Pinto 2017-07-05 10:52:20 UTC Comment hidden (off-topic)
Comment 5 Timur 2017-07-05 11:51:32 UTC Comment hidden (obsolete)
Comment 6 V Stuart Foote 2017-07-05 14:29:48 UTC
To paste an image copied from a Word document (by menu or shortcut), Ctrl+V would not be the correct paste action. 

IIUC you need to paste special as "GDI metafile" into any LO module--except draw/impress which will take it by default as a GDI metafile (with Ctrl+v) but alternatas a Bitmap via paste special.

Of course, a copy all (Ctrl+A) paste is picking up formatting applied to the Word page _and_ any image object(s)--so don't use that unless you want to formatting to come across.

Try it with the paste special--should give you the result you want.
Comment 7 Marco A.G.Pinto 2017-07-05 15:22:08 UTC Comment hidden (off-topic)
Comment 8 V Stuart Foote 2017-07-05 16:49:47 UTC
Well sorry, but pasting works. So -> Enhancement

Summary adjusted.

From UX perspective: is forcing users to Paste special for selected images correct UI? And, what is being passed across clipboard when just an image is selected?

Seems the default Ctrl+V clipboard logic needs attention, and was not quite correct with https://cgit.freedesktop.org/libreoffice/core/commit/?id=46e03df0a7471a887e7cf403765b4de3582d9a1e

@Andrzej, * any comment on Luke's https://bugs.documentfoundation.org/show_bug.cgi?id=81835#c8
Comment 9 Luke 2018-09-18 17:43:57 UTC
This is a bug, actually a regression as it worked in 4.4, but was fixed 4.4 with:
https://cgit.freedesktop.org/libreoffice/core/commit/sot/source/base/formats.cxx?id=538c13f3d1756f2d105115f64ab1bc0b7426eebc

It was then broken again by:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=a96a7ce51aa98fb9ee97ea3803e2b7e648611008

Miklos fixed the Excel -> Writer variant of this in Bug 115574
Comment 10 Luke 2018-09-18 18:19:38 UTC
Created attachment 144992 [details]
Word doc with an image

I hid some noise caused by a lack of a steps to reproduce in the description. 

Steps to Reproduce:
1. In a MS Word document with an image, select it
2. CTRL+C
3. In Writer, New document
4. CTRL+V

Note this is about copying images only. Bug Bug 35176 is about images + content.
Comment 11 Luke 2018-09-18 18:25:39 UTC
*** Bug 47655 has been marked as a duplicate of this bug. ***
Comment 12 Luke 2018-09-18 19:19:15 UTC
*** Bug 94436 has been marked as a duplicate of this bug. ***
Comment 13 Luke 2018-09-18 19:31:02 UTC

*** This bug has been marked as a duplicate of bug 99507 ***
Comment 14 Luke 2018-09-18 19:37:03 UTC
This bug is a dupe of Bug 99507 which has a much clearer description of the problem.
Comment 15 Xisco Faulí 2018-09-19 08:41:34 UTC
@Heiko, You assigned yourself a duplicated bug. Did you want to assign yourself bug 99507 instead ?
Comment 16 Heiko Tietze 2018-09-19 08:57:38 UTC
(In reply to Xisco Faulí from comment #15)
> @Heiko, You assigned yourself a duplicated bug. Did you want to assign
> yourself bug 99507 instead ?

No, I'm not assigned here. Sounds difficult.
Comment 17 Xisco Faulí 2018-09-19 09:00:22 UTC
damn, you just added yourself as CC, not as assignee, I think I need another coffee...