Bug Hunting Session
Bug 89453 - Improve the wording of "Paste Special" options
Summary: Improve the wording of "Paste Special" options
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium enhancement
Assignee: Heiko Tietze
URL:
Whiteboard: target:6.1.0
Keywords: needsDevEval, topicUI
Depends on:
Blocks: HelpGaps-NewFeatures Paste-Special
  Show dependency treegraph
 
Reported: 2015-02-18 22:44 UTC by Amr Ibrahim
Modified: 2019-09-21 12:24 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
New dialog content (116.58 KB, image/png)
2018-04-03 17:43 UTC, Heiko Tietze
Details
Paste Special dialog on Windows (13.66 KB, image/png)
2018-04-04 10:11 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Amr Ibrahim 2015-02-18 22:44:33 UTC
When I copy a group of cells in Calc and then I choose "Paste Special" from the toolbar in either Calc or Writer, I get these terms that a normal user may not understand.

In Calc: GDI metafile, PNG Bitmap, Bitmap, calc8, DDE link, DIF

In Writer: the same as in Calc

The titles should be more descriptive. There are also two Bitmap options in Calc, which adds more confusion.
Comment 1 A (Andy) 2015-02-22 20:31:15 UTC
Reproducible with LO 4.4.0.3, Win 8.1.

This is really not intuitive if you are not used to it.  The currently available online help does also not help.  These options should be explained in the LO help.  I for instance do not have any idea what "calc8" means.
Is it also maybe possible to add tooltips in such a dialogue box to explain the entries?

Steps Done:
1. Open CALC
2. Select any cell and press CTRL + C
3. Open a new document in WRITER
4. Go to EDIT -> PASTE SPECIAL in the WRITER document
Comment 2 Amr Ibrahim 2015-11-29 15:39:06 UTC Comment hidden (no-value)
Comment 3 V Stuart Foote 2016-01-14 14:44:26 UTC
Well, it is a valid issue. The "paste special" list is correct as to the object type that would be pasted--but it is not very intuitive as to just what the object represents.

Implement a translatable and human "friendly" labeling for each--not sure if a tooltip might also be possible, but if so that would help.

Back to UI
Comment 4 Amr Ibrahim 2016-01-19 17:50:07 UTC
For the sake of completeness, improve all the paste options in all LO components.

Paste options in Draw: Draw 8, Drawing format, GDI metafile, Bitmap
Comment 5 Aron Budea 2016-09-02 16:15:35 UTC
Thanks for pointing to this report, Timur.
In bug 101818 Marco brought up MS's variant of this (see sketch at [1]), and I argued for having a novice/expert view of the dialog, one would be straightforward and convenient to use even for new users, and the other would show all the choices the Paste Special dialog currently has (wording should still be improved there of course).

[1] https://bugs.documentfoundation.org/attachment.cgi?id=127096
Comment 6 Yousuf Philips (jay) (retired) 2016-09-06 15:28:01 UTC
The format strings are defined in the below file, so it really just comes down to us deciding what the new strings should say.

http://opengrok.libreoffice.org/xref/core/svtools/source/dialogs/formats.src

@Eike, @Maxim: Your input on this would be appreciated.

(In reply to Aron Budea from comment #5)
> In bug 101818 Marco brought up MS's variant of this (see sketch at [1]), and
> I argued for having a novice/expert view of the dialog, one would be
> straightforward and convenient to use even for new users, and the other
> would show all the choices the Paste Special dialog currently has (wording
> should still be improved there of course).

As novice users dont use the dialog or the split button part of the paste toolbar button, as they simply click the main part of the paste button in the toolbar or Ctrl+V, there doesnt need to be modes for the dialog. What the dialog does need is a label description under the selection list that details what the type of option can be used for, similar to the one found in the Tools > Customize dialog.
Comment 7 Aron Budea 2016-09-06 18:55:21 UTC
(In reply to Yousuf Philips (jay) from comment #6)
> As novice users dont use the dialog or the split button part of the paste
> toolbar button, as they simply click the main part of the paste button in
> the toolbar or Ctrl+V, there doesnt need to be modes for the dialog. What

Disagree. Just because it says "special," pasting clipboard unformatted is still very common functionality.

Also, needsDevEval is for easy hacks.
Comment 8 Yousuf Philips (jay) (retired) 2016-09-06 19:16:50 UTC
(In reply to Aron Budea from comment #7)
> Disagree. Just because it says "special," pasting clipboard unformatted is
> still very common functionality.

Never stated pasting clipboard unformatted isnt common, which is why it is in the context menu and an entry in the Edit menu. Other paste special options arent common which is why they arent visible in these places.

> Also, needsDevEval is for easy hacks.

Yes the design team sets "needsDevEval, topicUI" to request a design dev to look into what skills are needed and whether its a easy hack.
Comment 9 Aron Budea 2016-09-06 19:48:11 UTC
You're right, my mistake.
Comment 10 Amr Ibrahim 2017-06-12 11:05:36 UTC Comment hidden (no-value)
Comment 11 Amr Ibrahim 2017-06-12 11:13:00 UTC
*** Bug 101818 has been marked as a duplicate of this bug. ***
Comment 12 Yousuf Philips (jay) (retired) 2017-06-12 16:57:50 UTC
Maxim, Eike, Miklos, UX-Team: Would you recommend changing the format names[1] to make them more understandable within the listbox and/or to defined these formats in help[2] and show these definitions within the dialog (similar to MS[3]).

The benefit of improving the listbox labels is that the improvement will also be visible in the toolbar split button. The benefit of defining these formats in help is that we can have sentence long descriptions for each format.

[1] http://opengrok.libreoffice.org/xref/core/sot/source/base/exchange.cxx#59
[2] https://help.libreoffice.org/Common/Paste_Special
[3] http://www.msoffice-tutorial-training.com/images/excel-t19-pic4.gif
Comment 13 Heiko Tietze 2017-06-13 07:02:05 UTC
Microsoft does the trick with a long static tooltip below the list of options like "Insert the content of the clipboard as a bitmap picture. This format can take up a lot of memory and disc space, but is exactly what you see on the screen". Hard to imagine that we find a similar appropriate text that is shorter. But lets try:

GDI metafile - Screen optimized bitmap (GDI)
PNG Bitmap - Cross-plattform optimized bitmap (PNG)
Bitmap - Compatibility optimized bitmap [Remark: is that true?]
calc8 - Calc object [Remark: what's the difference to standard paste operation?]
DDE link - Reference only (DDE link)
DIF - Paste text using standardized formats (DIF)
Unformatted text - Paste plain text
Formatted text [RTF] - Paste with formattings (RTF)
Formatted text [Richtext] - Paste with formattings (Richtext) [Remark: What's the difference between "RTF"=Rich formatted text and "Richtext"?]
HTML (HyperText Markup Panguage) - Paste with web formatting (HTML)
Star Object Descriptor (XML) - Backward compatibility object (SOD XML)

[Remark: Today we have an awkward mixture of brackets)

Adding Olivier for input from documentation team.
Comment 14 Cor Nouws 2017-06-13 08:38:38 UTC
Does the HELP button link to appropriate explanation?
Comment 15 Amr Ibrahim 2017-09-03 08:24:20 UTC Comment hidden (no-value)
Comment 16 Mike Kaganski 2018-03-31 18:36:09 UTC
(In reply to Heiko Tietze from comment #13)
> ...
> calc8 - Calc object [Remark: what's the difference to standard paste
> operation?]

Regarding the cited line from Heiko's comment: one of the formats is the default one chosen when user pastes normally (Ctrl+V). It would help to see the "(default)" after the format that is selected that way (see e.g. bug 116685 where the default for one operation is discussed).
Comment 17 Mike Kaganski 2018-03-31 18:37:37 UTC
Also I'd say Heiko please just do the change, it might be fine-tuned later.
Comment 18 Heiko Tietze 2018-04-03 17:43:39 UTC
Created attachment 141061 [details]
New dialog content

Patch at https://gerrit.libreoffice.org/#/c/52336/
Comment 19 Cor Nouws 2018-04-04 09:24:20 UTC
(In reply to Heiko Tietze from comment #13)

> GDI metafile - Screen optimized bitmap (GDI)

Isn't that misleading, reading https://en.wikipedia.org/wiki/Windows_Metafile ?
It is basically a vector format, designed for Windows, Windows EMF, that allows for using the Windows GDI, Graphical Device Interface?


(In reply to Mike Kaganski from comment #17)
> Also I'd say Heiko please just do the change, it might be fine-tuned later.

+1
Comment 20 Heiko Tietze 2018-04-04 10:11:19 UTC
Created attachment 141074 [details]
Paste Special dialog on Windows

(In reply to Cor Nouws from comment #19)
> > GDI metafile - Screen optimized bitmap (GDI)
> 
> Isn't that misleading, reading
> https://en.wikipedia.org/wiki/Windows_Metafile ?
> It is basically a vector format, designed for Windows, Windows EMF, that
> allows for using the Windows GDI, Graphical Device Interface?

Windows has no similar entry, and spelling full is not much informative, IMHO.

Following https://en.wikipedia.org/wiki/Windows_Metafile "Essentially, a WMF file stores a list of function calls that have to be issued to the Windows Graphics Device Interface (GDI) layer to display an image on screen." it's kind of screen-optimized image. Alternative perhaps "Windows vector format (GDI metafile)", but is that really better?
Comment 21 Mike Kaganski 2018-04-05 22:54:56 UTC
Please note that the improvement should not disable interoperability: user needs to be able to see similar/familiar strings from other applications. Even if something looks "incomprehensible", it's actually less issue than "easy-to-understand" name that doesn't ring a bell to user that saw it multiple times in other apps with a different name. Actually, for an average user, no text would be easy enough. But familiarity, and also googleability are of importance. So - please also use usual names (maybe in parentheses after improved string).
Comment 22 Heiko Tietze 2018-04-07 09:46:03 UTC
Comment on attachment 141061 [details]
New dialog content

New patch with just <fullname> (<shortname>) in preparation. The format explanation should go into the documentation. See also http://nabble.documentfoundation.org/Terminology-modifications-to-Paste-Special-format-tt4237242.html
Comment 23 Commit Notification 2018-04-07 12:03:08 UTC
heiko tietze committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a2f7eb5f8ea7f3ae50aea72de8b15c3364493285

tdf#89453 - Improve the wording of "Paste Special" options

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.