Bug Hunting Session
Bug 109007 - crash pressing either "Insert Special Character" button standard toolbar
Summary: crash pressing either "Insert Special Character" button standard toolbar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.0.0
Keywords: haveBacktrace
: 109351 109789 110441 (view as bug list)
Depends on:
Blocks: Special-Character
  Show dependency treegraph
 
Reported: 2017-07-07 17:53 UTC by V Stuart Foote
Modified: 2017-09-07 08:43 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
two special character buttons, either will crash LO (33.42 KB, image/png)
2017-07-07 17:53 UTC, V Stuart Foote
Details
WinDbg stacktraces TB39 20170723 build with symbols (11.72 KB, application/x-zip-compressed)
2017-07-28 05:18 UTC, V Stuart Foote
Details
WinDbg stacktraces TB39 20170729 build with symbols, wOpenGL active (12.91 KB, application/x-zip-compressed)
2017-07-29 03:43 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2017-07-07 17:53:46 UTC
Created attachment 134532 [details]
two special character buttons, either will crash LO

See to have duplicate button controls for work on Special Character dialog, the existing uno:InsertSymbol and the new split button assigned uno:CharmapControl--both have the same "Insert Special Character" labeling.

Not sure why. But selecting either now crashes LO.

https://gerrit.libreoffice.org/gitweb?p=core.git;a=commit;h=800ac37021e3f8859a52c5eebca261a5d3bc5a11

=-ref-=
On Windows 8.1 Ent 64-bit en-US with
Version: 6.0.0.0.alpha0+
Build ID: 7ab9f12b57b1cb25b8b29f8bcbf006968db6b679
CPU threads: 8; OS: Windows 6.29; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-07-07_05:27:37
Locale: en-US (en_US); Calc: CL
Comment 1 Telesto 2017-07-08 18:20:42 UTC
Repro with:
Version: 6.0.0.0.alpha0+
Build ID: 7b4f4f15971047664fa278fff96b959d53b272b3
CPU threads: 4; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-07-08_00:29:31
Locale: it-IT (nl_NL); Calc: CL

but not with:
Version: 6.0.0.0.alpha0+
Build ID: cac5c9f6081590b0548d3116bc4cd4a2509ec576
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-07-01_00:41:48
Locale: it-IT (nl_NL); Calc: CL
Comment 2 Xisco Faulí 2017-07-11 08:44:52 UTC
This seems to be Win only. I can't reproduce it in

Version: 6.0.0.0.alpha0+
Build ID: ddadcb4f4a2bc6538c219a0a577bdf5999015150
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk2; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 3 V Stuart Foote 2017-07-21 17:43:39 UTC
On Windows builds, both UI buttons assert same fault.

https://opengrok.libreoffice.org/xref/core/include/vcl/builder.hxx#410

The button widget for the old dialog from uno:InsertSymbol using cui (cuilo.dll), and the new split button for the GSOC uno:CharmapControl via sfx (sfxlo.dll).

The warning dialog aborts at
https://opengrok.libreoffice.org/xref/core/desktop/source/app/officeipcthread.cxx#946
Comment 4 Xisco Faulí 2017-07-25 19:50:04 UTC
*** Bug 109351 has been marked as a duplicate of this bug. ***
Comment 5 V Stuart Foote 2017-07-28 05:18:12 UTC
Created attachment 134923 [details]
WinDbg stacktraces TB39 20170723 build with symbols
Comment 6 V Stuart Foote 2017-07-28 05:26:29 UTC
@Caolán, *

The attached zip contains WinDbg stack trace with symbols for crash on Windows using either of the Special Character dialog buttons--the old uno:InsertSymbol (cuilo.dll) and the new uno:CharmapControl via sfx (sfxlo.dll).

They both seem to hang up in VCL builder builder.cxx @ 2081 when passed into boost::gettext

=-testing-=
On Windows 10 Pro 64-bit en-US
Version: 6.0.0.0.alpha0+
Build ID: 28b382b7b0a32417e0aedd4ae415a69e479fe60b
CPU threads: 8; OS: Windows 6.19; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-07-23_03:20:41
Locale: en-US (en_US); Calc: CL
Comment 7 Xisco Faulí 2017-07-28 08:41:58 UTC
*** Bug 109789 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2017-07-28 09:34:54 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=42dacdf2d1c90a4b80fefeb49cbcc08dcbf70a96

Resolves: tdf#109007 unicode block names keys instead of translations

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 V Stuart Foote 2017-07-29 03:43:15 UTC
Created attachment 134960 [details]
WinDbg stacktraces TB39 20170729 build with symbols, wOpenGL active

@Caolán, still crashing for both widgets.

Another set of stack traces attached for Kendy's TB39 x86 build 20170729 (3c75009a677ae950105a65c699b16caf72b516b0). The trace seems pretty similar to the last set for both, although this set was taken with OpenGL rendering enabled.
Comment 10 Xisco Faulí 2017-07-30 19:15:30 UTC
*** Bug 110441 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2017-07-31 08:01:35 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=545c6fdd8267354d74d3d3a6fc6641fd7c25a0dc

Resolves: tdf#109007 SvxCharView is in sfx2 not cui

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 V Stuart Foote 2017-08-01 05:20:29 UTC
On Windows 10 Pro 64-bit en-US with
Version: 6.0.0.0.alpha0+ (x64)
Build ID: c210d7cc092616ecdd1072f1238ec3b619f7387b
CPU threads: 8; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2017-07-31_23:32:03
Locale: en-US (en_US); Calc: CL

Both button widgets behave now. On Windows builds, finally able to access the new GSOC Favorites/Recent character list and the reworked Special Character dialog.
Comment 13 Heiko Tietze 2017-08-01 08:41:59 UTC
Remark: The 'legacy' access to special characters will be removed from the toolbar but is still needed for at least the main menu at Insert > Special Character...