Bug 111307 - Numbers cut in numeric input fields (with OpenGL enabled only)
Summary: Numbers cut in numeric input fields (with OpenGL enabled only)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.4.4
Keywords: bibisected, bisected, regression
: 112748 115144 (view as bug list)
Depends on:
Blocks: VCL-OpenGL DirectWrite
  Show dependency treegraph
 
Reported: 2017-08-03 10:41 UTC by bellgardt
Modified: 2018-10-30 18:51 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen shot showin incomplete numbers (100.51 KB, image/jpeg)
2017-08-03 10:43 UTC, bellgardt
Details
Memory Options View (53.40 KB, image/png)
2017-08-03 14:39 UTC, Jacques Guilleron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bellgardt 2017-08-03 10:41:34 UTC
Description:
In numeric input fields of the UI (direct input or selection lists) number with left alignment are cut on the left side, i.e. the first left most digit is shown incomplete. 

Steps to Reproduce:
Open LO and find a numeric input field in a dialog box or side bar.

Actual Results:  
First digit is cut

Expected Results:
Should be shown completely


Reproducible: Always

User Profile Reset: No

Additional Info:
System: Windows 7 Enterprise 64 bit with Intel i5 3230.
LO version: 5.403, 32 bit


User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0
Comment 1 bellgardt 2017-08-03 10:43:06 UTC
Created attachment 135096 [details]
Screen shot showin incomplete numbers
Comment 2 bellgardt 2017-08-03 10:54:37 UTC
The bug only appears when openGL is enabled.
Comment 3 Jacques Guilleron 2017-08-03 14:39:38 UTC
Created attachment 135101 [details]
Memory Options View

Hi,

Don't reproduce with
LO 5.4.0.3 (x64) Build ID: 92c2794a7c181ba4c1c5053618179937228ed1fb
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
with or without OpenGL enabled.
Enlarge the window should solve the problem. No?
Comment 4 bellgardt 2017-08-04 07:46:07 UTC
Hi Jaques, my build number is obviously the same as yours:
Build ID: 92c2794a7c181ba4c1c5053618179937228ed1fb
CPU threads: 4; OS: Windows 6.1; UI render: GL; 
Locale: de-DE (de_DE); Calc: CL

Now I found the input fields are only cut when openGl is enabled. Without openGL all is correct. 

Making the dialog boxes bigger has no influence: the first left number is always cut.

I checked with LO 4.4.7.2. There it still worked fine.

Karl
Comment 5 Aron Budea 2017-08-09 03:40:41 UTC
Confirmed with LO 5.4.0.3 / Windows 7, looks fine in 5.4.0.2.
Interestingly, it's technically a regression from the commit referenced below, bibisected using repo bibisect-win32-6.0. It could be that the commit only exposed an existing bug (at least I wonder how antialiasing settings could cause this). Nevertheless, adding Cc: to Tomaž Vajngerl.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=3fdc41af6370a53f7db4e52104cfd3328ee40563
author		Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2017-07-19 21:28:31 (GMT)
committer	Tomaž Vajngerl <quikee@gmail.com>	2017-07-20 16:26:24 (GMT)

"tdf#107166 improve AA mode selection, retry, more checks"
Comment 6 Xisco Faulí 2017-09-29 10:53:06 UTC
*** Bug 112748 has been marked as a duplicate of this bug. ***
Comment 7 Aron Budea 2017-11-05 23:20:21 UTC
Seems fixed in master, but not in 5.4.3.2.
Comment 8 Xisco Faulí 2018-01-22 15:13:50 UTC
*** Bug 115144 has been marked as a duplicate of this bug. ***
Comment 9 Xisco Faulí 2018-06-05 21:08:52 UTC
Adding Cc: to Tomaž Vajngerl
Comment 10 V Stuart Foote 2018-10-30 18:51:38 UTC
Fixed by Mike K. with the DirectWrite adjustment for OpenGL rendering for bug 113347 
https://cgit.freedesktop.org/libreoffice/core/commit/?id=de811bb2359757b90a0a9851963bd8702b97dab0&h=libreoffice-5-4